Support Website Contact Support Blog

[Pix4Dcapture iOS 2.1.0] Feedback and experience

Hello Pix4D members and iOS users,

We are glad to announce a new version of iOS Pix4Dcapture!

Please use this post to share your experience with other users and us.
We are looking forward to your feedback!

Pix4D Support Team

I’m so glad this finally came out. I have tested it and found two issues.

1 On my first mission everything went well until the mission was ending, on its return to its home point it was trying to land 6+ meters from its home point (I had to take manual control-not the end of the world but it should have been closer in my opinion)

2 On my second mission I realized that halfway through the mission my controller was in “s” mode. I tried changing it to “p” mid mission and it interrupted the mission and I had to manually bring it back home (should capture have allowed the mission to start with the control in the wrong position?) 

 

Other than that I was intrigued with the difference between how the Inspire2 is controlled by Capture vs how my Phantom4Pro runs. 

Thanks,

Matt

 

I did a test yesterday and found a few issues:

  • The camera (X5s) was slightly out of focus

  • The (color)saturation changed a few times in one mission

  • The app crashed once in 5 missions

  • The app incorrectly stated a few times that we were to far form the mission (we were within 150 m)

  • The flight time changed (became much longer) for the same mission after an app restart

  • The app gave a flight time warning for an 11 minute mission (batteries 100%)

  • We had  the flight speed on high, but the Inspore flew very, very slow

  • The inspire flew backwards a few times??? On one mission (90 degree camera angle) it actually slowely spun arund it axes during one leg

@Matt

  1. The 6-meter distance from the home point (where the drone is turned on and where it is supposed to land) is within the expected range.
  2. The drone should not be able to takeoff in S-mode. Our developers will try to reproduce the issue.
  3. Regarding the comparison between the Inspire 2 and the Phantom 4 Pro, could you be more specific? They are controlled in the same way by Pix4Dcapture but the DJI SDK is not the same.

@Michiel

A default predefined focus is applied so that the captured images are as if they were focused on infinity. However, blurry images not only happen because of out of focus. The exposure time can also create blur. Since the exposure is supposed to be constant over the flight (automatic DJI exposure), changing light conditions can negatively impact the quality of the images.

Did you try to set the white balance in Pix4Dcapture (Auto, Sunny, Cloudy)? You can find this option in the list of mission settings. However, if the weather is changing, the images will be anyway affected.

Regarding the distance to the mission, there are actually two limitations. You can find more information here.

The time estimation takes the distance to the mission into account, meaning that if the home point (where the drone is turned on) is far from the flight, the duration significantly increases. Note there are two different picture trigger modes that cab be selected in the mission settings.

  • Safe: The drone stops to take every picture which significantly increases the flight time. The way-points where to shoot are uploaded to the drone before starting the mission. This means the drone can fly the mission without requiring a connection with the app.The drone also flies slower in between pictures.
  • Fast: The app sends a signal when to shoot. This mode does not make the drone stop but the connection with the drone should be maintained without interruption. It is solely based on the position of the aircraft.

The drone is not expected to fly backwards or spin. Did you observe this behavior several times? Is the latest firmware installed on the drone?

Thank you for your reply. First:

The weather was excellent all day. Bright and sunny. 0% cloud cover. I made sure everything was up to date (including firmware)

 

  • The focus problem does not look like motion blur to me. http://i1185.photobucket.com/albums/z341/Miob80/p4d_zpsenzuojhz.png

  • I had the white balance on sunny on all flights. Again, 0% cloud cover all day.

  • I think you forgot the link to the information on the flight distance?

  • The time changed for exactly the same mission after a restart of the app. No settings changed. ONce the time changed back to normal when we moved the slider to slow (aircraft speed) and the back to fast again. The second time that didn’t work. It also gave a flight time warning, even with an estimated flight time of 11 minutes. The first flight was an easy 7 acres (!!), the second flight we couldn’t make the area any larger then roughly 3 acres, after that we would get the warning. All settings were the same for all flights. (with the aircraft in fast mode)

  • We observed in 2 out of 5 flights.

 

I hope this feedback helps!

 

I still miss that we can’t save Our Projects(polygons) for later use like in the DroneDeploy app.
Also when the Project is so big that we have to swap batteries it doesnt start where it ended and we would have to Draw a new polygon for the remaining.

We did another asingment yesterday with te inspire 2. Again some strange behavior:

  • None of the flights (3) the camera poimted straight forward, all flicghts it was tilterd right about 10 to 20 degrees

  • The order of the legs was really strange one of the flights, it skipped one and made that one the alst leg of the flight: http://i1002.photobucket.com/albums/af144/929coupe/p4d2.png

  • The inspire flew backwards again, it seemded to be random. Sometimes teh inspire just didn’t turn between legs, so it would go one way forward and one way backwards: https://youtu.be/TTzZs91OSDk 

 

The first one decreased the overlap every two legs (because the camera would be angled out 2 legs and then in 2 legs. We used extra overlap and thankfully the result seems fine. We didn’t notice the off set camera on previous missions. We tried restarting the Ipad, but the result was the same.

 

O, wait, and one more: We had to abort one mission (because of birds), we did that by putting the inspire in sports mode. We forgot to take it out of sport mode for the next flught, but everything still worked as ussual. It was my understanding that ‘flight modes’ wouldn’t work in sports mode?

EDIT by Pix4D Support : We have merged the two comments into this one. A comment can be edited by clicking on the little gear in the top right corner and selecting Edit.

 

@Michiel

We added the link of the article that we indeed forgot, thank you!

Regarding the maximum area that can be covered in one single mission, the limiting factors are:

  • Altitude and overlap (the higher the less overlap required, meaning fewer lines in the grid, and vice versa).
  • Size of the grid (length of the flight track).
  • Distance to the home point if the drone is connected.

Actually the color of the grid refers to the estimated flight time that is calculated given the factors above assuming the battery is fully charged at the beginning of the mission. Note that even if the color is yellow or orange it is still possible to fly the mission.

Regarding the other comments:

  • For double grid missions, the camera angle cannot be vertical. The angle is adjusted to optimize the image acquisition. Tha camera angle can be changed in the flight settings if needed for the simple / double grid and polygon missions.
  • The order of the flight lines is optimized in terms of battery and also depends on the home point location. It might sometimes look a bit strange.
  • After checking with our devs, the drone is actually expected to fly backwards during polygonal flight.
  • The latest version now overrules the pilot mode of the drone. In other words, even if the button is in the S position, the app still activates the P mode for flying a mission.

@Jim

The save option will come very soon on iOS. It is a top priority.
Note however, even if you close Pix4Dcapture, force quit Pix4Dcapture and even reboot the device, the flight plan that you designed will remain on the Map view when re-opening the app. In other words, only one mission can be saved.

Regarding the base map, the background is automatically cached for 2-3 days depending on how the temporary memory of the device is used. You can take advantage of these temporary background maps to plan flights without Internet connection.

It is not possible to fly large areas with the iOS version of the app at the moment because the resume option is not available yet. It is however, in our pipeline to implement multi-battery flights but it takes some time. Rest assured that our developers are currently working on it. It might be ready by the end of June as a rough estimation.

When will we see the features and functions be the same between iOS and Android?  Setting the altitude is limited more here.

Hi Adam,

You can extend the altitude if you select the tab Advanced in the flight settings. After selecting a type of mission, tap the settings icon.

 

I see advanced in the Android app but not iOS.  And the issue is lower elevation, not higher.  But that was just an example of the 2 apps being different when they should have the EXACT same features and settings.

Sorry for not being clear earlier, below you can find screenshots on how to access the Advanced flight settings from the Map view.

 

Note that DJI SDKs are different between Android and iOS. Therefore the tools to develop third-party applications slightly vary from one OS to the other.

Some options can be found on iOS and not Android like the White Balance. It was created on iOS to avoid color variations from one image to the other. On Android however, it was decided that the workaround would be to set the white balance in DJI GO (4). It should be taken into account when flying.

Some more important features like the Project List (instead of Mission Manager) and the possibility to duplicate projects and missions is only on Android for now. The resume feature is something that will be implemented on iOS as well.

Actually some features are first developed on one OS to test them before being implemented on the two platforms. Obviously the goal is to have the two apps but in practice it is more complicated :).

Hi! 

I have been attempting to fly missions for the last three or so weeks and have been receiving a “mission not uploaded” error (the symbol is an orange triangle with an exclamation mark in it, not the red x). The first time I ever used Pix4D Capture I had great success, but since then not so much luck. I have tried:

  • Resetting the size of the flight pattern ever so slightly and refreshing.
  • Cancelling the mission multiple times, force quitting the app and restarting the equipment.
  • Uninstalling the app and reinstalling the app.

I am operating a Phantom 3 4K, which I understand is not fully supported, with Pix4D Capture 1.7.2 (IOS) and DGI GO v3.1.10. I am desperately trying to complete some more trial runs before I a tackle a project that is quickly approaching. 

Any help would be greatly appreciated as I would prefer to continue using this system rather than DroneDeploy

Thanks,

Grady

(Also all of the other pre-flight checks were confirmed with the green arrow)

Grady, simply copy the files off the drone manually to a computer.  They said the upload has been sped up but I NEVER use the app to get pictures from the drone. I also use Desktop and not the Cloud for obvious reasons but that is irrelevant to getting the pics off the drone and then choosing where to process.

Adam 

Hey Jordan, thanks for the advice. I totally agree anytime you can hardwire for data transfer is always the best option. However, I may not have made my problem very clear. The issue that I am having is that the drone is not able to even start a mission because the flight pattern information is not being transferred from the app to my Phantom. I have also checked to ensure that the settings in my DJI GO App (i.e. max altitude and max distance) could not be interfering with the process. If anyone has any suggestions I am all ears.

Please add KML import and multiple mission projects to iOS!

@Grady , could you please let us know the following. So we can try to reproduce it on our side:

  • Type of the mission.
  • Dimensions.
  • Altitude.
  • Overlap.
  • Camera Angle.

If possible, can you also let us know the location where you tried to use the drone and you failed?

@Thomas , we are already considering implementing multiple mission projects for iOS. The import of KML files is not planned at the moment.

Let us know if you are experiencing outdated maps or missing tiles, together with the location, so we can check it on our side. You can try to switch to street base maps - sometimes it is more up to date.

Best,

@Pix4D Support  I’m bummed to hear that KML import is not planned for iOS. I absolutely think this is a highly sought after feature for a professional application of this nature. Being able to send/receive exact project extents generated from applications such as AutoCAD, ArcGIS or Google Earth would be a game changer for me, and many others, I’m sure. This capability would be very useful where the background imagery in the app is not current, and would help to maintain general mission efficiency (preventing flying too much or too little). I hope that feature gets added to the TO-DO list!

Hi

I’m just wondering when the DJI Phantom 4ADVANCED is going to be supported by Pix4D?

 

Thanks

@Thomas, we understand why you think the feature would useful. We will forward your suggestion to the project manager.

@Cameron, we did not test it at the moment. You can try to use DJI Phantom 4 Advanced by selecting Phantom 4 Pro in the app. If you wish to give it a try, we will be glad to read your feedback.