Support Website Contact Support Blog

[iOS] Pix4Dcapture with DJI drones

New thread about Pix4Dcapture Feedback and Experience on iOS.

*** ARCHIVED POST ***

Hello Pix4D members and iOS users,

We are glad to announce a new version of iOS Pix4Dcapture.

Please use this post to share your experience with other users and us.
We are looking forward to your feedback!

Pix4D Support Team

So will this app actually work unlike the Android version?

I have used Capture (beta) with my Inspire 1 Pro. Aside from the focusing problem mentioned in the release notes I’m struggling with one major issue, i.e., the stop-and-go approach for taking images.

Before shooting, the aircraft always comes to a full stop, shoots and accelerates to stop again just a few meters ahead. As I learnt from Pix4D this is the standard behavior provided by DJI’s SDK. For me, this is a major issue, if not to say a showstopper.

For mapping missions I’m used to fly between 5 and 15 m/s, shooting at about one image per second without any stopping, of course. Fast shutter speeds between 1/500 and 1/2000 s (depending on speed, altitude and focal length) allow to shoot very sharp images while moving.

Why did DJI choose this stop-and-shoot approach for every single image to be taken? The costs are a tremendous overhead in terms of flight time. If you fly 100 meters at 10 m/s taking an image every 10 m that takes about 20-40 seconds instead of 10, or, in other words, limits your coverage by a factor of 2 at least. 

I’m very much interested in your experience, thank you for your feedback.

I agree totally. After using 2 other apps that start the plan and stops only when finished with little battery usage, now i’m confused about this approach …

Same for me, just flew first test missions since the release and the ‘stop start’ process wastes too much battery on my Inspire 1. Unless this method can be overcome I will need to revert back to using my Phantom 2V+.

It is confusing. If DJI’s SDK doesn’t provide another shooting mode than this stop-and-shoot approach, then it seems to be inappropriate for mapping flights, IMHO.

 

I use other apps too for mapping, and none of these use the ‘stop and shoot’ approach, so is clear that sdk provide the normal ‘flight and shoot’ approach for mapping.

I dont understand why pix4d use actual method …

As far as I understand it’ a limitation of the “new” SDK. Obviously there are other APIs to communicate with DJI aircrafts. 

About 2-3 months ago I made some tests with Capture App on Android (I actually bought an Android device just for this one app). There was no stop-and-shoot behavior but quite some other flaws using the Inspire 1 Pro. I never managed to conduct successful missions too, unfortunately.

Hi all,

Thank you for your prompt feedback!

The stop-and-shoot behavior of the drone is related to the SDK3 of DJI.
This is not something we can control unfortunately, although we are aware that it significantly increases the flight time and consumes the battery.

Note that the current Android Pix4Dcapture (2.0.8) still relies on SDK2, therefore we cannot compare it with the new iOS release.
Similarly, other apps still support SDK2 too meaning that the stop-and-shoot behavior of the drone cannot be observed.

Regards,

 

Thanks for the clarification Julie.

It’s just hard to understand that DJI often evolve their products in a way that they render useless. Another example is Inspire’s lately introduced battery protection circuit: If the controller detects one single battery cell to drop below whatever threshold, they shut off all the engines, even while in flight! In cold weather conditions quite some Inspires fell out of the clouds. In order to protect a battery worth $200 they destroy your i1 for $5000. Why on earth do they do that?

I hope that your developers can show them that such changes have a tremendous impact.
Thanks a lot.

@Pix4D Support - Do you feedback the negative feelings to DJI? If so, what is their response?

Thank you Pix4D for all the r&d required to finally release the iOS version of Capture !!  We’ve been waiting.

Now we’re all hoping the stop-start method of capturing images can be modified quickly as it makes the app completely useless.

The DroneDeploy app manages to fly Inspire1/P3 drones in an efficient continuos manner, no start-stop required.

While that’s being fixed please also add a way to choose which end of the flight path will be the start point,

and basic telemetry from the drone would be nice too.

Thanks!

 

 

Previously the Android exported a CSV file

 

Can the iOS do the same? I cannot seem to acquire this file

Apart from the odd start-and-stop behavior, I want to emphasize that Capture is a nice app for conducting mapping missions.
Much simpler than everything I used before and pretty robust for a 1.0 version, congrats.

I’m sure Pix4D does its best to improve the current drawbacks.
Thanks in advance.

Hi,

I don’t own a drone yet but i am thinking to buy the Phantom 3.

For now I have downloaded both the Android and the iOS version of Capture to check how it works.

I noticed something weird in the latest iOS version. When I resize the grid to about 300x300 m it says that the mission is not possible because the Phantom is limited to fly only 7 lines!

The android version does not have this behavior! This have to do with the new SDK? If so it is useless!

Please check it. Thanks!

Very weird!

Other apps allow the return to home and continue from where you have stopped …

I cant believe that Pix4D isnt capable to do the same …

With my P3AI can’t take more than 50 pictures without being told the mission is too large.  Pix4d Mapper works very fast with the photos though as the geolocation error is very small.  So I can only use Capture for smaller projects.

 

I have good success with Map Pilot from MapsmadeEasy.   Pix4d mapper handles this data just fine just more slowly because of the geolocation variance.

 

Keep hammering at fixing the app though because I love the end product for surface mapping.

I am unable to upload the Mission to my New and fully up-to-date P3A. I found another user on the forum who is having the same issue. 

That is, I get to the final step of my Grid Mission, and the very last item has a Red X ‘Unable to load mission to Drone’. I have tried just about everything and have been scouring the forums etc. Can you please help me out? I am currently renting Pix4d Pro as well, and I need to get my mission flown. Thank you.

Is this perhaps an issue with the 1.7.006 firmware that was recently released? That is the version I have installed, and perhaps the reason why not many users have noted this issue yet?

I am using the P3P with the new firmware. This is the first time to try the app. I have done 2 flights with neither one being successful.

 

First Flight- Camera settings were set at 90 degrees but the app did not rotate the camera to 90 degrees. it took horizontal photos.

              - The drone took off and flew the mission stopping and starting at every photo location. but never showed any telemetry or an abort button. it showed a start button like it had been reset.

              - when it got to the end of the mission it just hovered and didn’t fly home and i had to manually bring it in to land and it didn’t try to upload any photos. in mission manager it showed an error.

 

Second Flight-  drone took off flew to altitude and just hovered. never tried to head toward start point. I noticed when it took off there was a abort button like it was following a mission but once it got to altitude i switched to camera view and manually rotated the camera facing down 90 degrees and when i switched back over to map view the abort button was gone and instead said start like it had been reset again. so i manually landed the drone.

 

I have not tried to fly again trying to get some answers or see if anyone is having the same problem with the phantom 3 pro with iphone 6 running the the newest capture app. and new drone firmware.