Support Website Contact Support Blog

[iOS, Android] New Phantom 4 Pro v2.0 not working

new phantom 4 pro v2.0 does not work with pix4d capture

i try with old phantom 4 pro settings but:

  • camera status unknown

  • drone sd card status unknown

  • switch state unknown

it’s for not yet compatible or for my drone malfunction?

thanks

1 Like

news?

Hi Adele,

Thank you for sharing your testing experience. The Phantom 4 Pro V2.0 is a very recent drone on the market which gets new features compared to the classic Phantom 4 Pro. 

We have not tested the compatibility of this drone with Pix4Dcapture yet. It is then not officially supported. Our capture development team is continually working to increase our support for new devices as they are released and the P4P V2.0 is no exception. Your feedback has been shared with the developer’s team so that they can investigate further the issue and consider to support this drone in the future.

To investigate further the issue can you:

Any feedback from customers testing Pix4Dcapture with the Phantom 4 Pro V2.0 is welcome. Info like the mobile device and the logs will be appreciated.

best,

I’m on Android device, it works well under pix4d with phantom pro 4 previus version, but i hven’t pix4d folder with log files, i think it’s because i can’t even take off…

same problem here with p4p2

Also I have the same problem (Phantom 4 Pro V2.0), Redmi Note 5A, Android 7.1.2 

The same problem with p4p v2.0 on ios

Add me to the list for ios

Hi Gael,

When do you expect Pix4Dcapture to be upgraded for support for P4P V2.0?

Your reply will be appreciated.

Thanks!

Hakchul Lee,
Their support is based off of DJI developing the SDK for the V2. We need to rattle DJI’s cage and get them to get it developed.

Same issue here. Pix4D Capture 4.2.1 & Ctrl+DJI 1.8.2 on Android 7.1.1 with a brand new DJI Phantom 4 Pro v2.0.

Ctrl+DJI seems to connect (as P4 Pro) but shows no telemetry info from drone, and in Capture when I create a mission and try to fly it, it shows drone connected but nearly all the pre-flight checklist items (compass calibration, camera issues, etc.) show issues needing to be fixed. (all the issues Adele listed in the OP). Capture says to use DJI Go to resolve the issues. When I disconnect and go into DJI Go, everything is fine with the drone.

Looks like I won’t be able to use this sUAS in my field research next week, which is really a bummer. Unless somebody else has a suggestion for an Android flight planning/data acquisition mapping app that will worth with the P4 V2.0 and collect data compatible with Pix4D cloud/desktop, that is?

 

Hi, I also have the same issue with phantom 4 Pro V2 and Pix4D capture.

I manage to make a new project but when I start the mission Pix4D capture detects the Phantom as a Mavik. The mission does not start. I have connected with DJI Go4 first and I can fly normally the Phantom but does not work with Pix4D. I use an IPad. Tried DroneDeploy, GS Pro and Atlas and does not work either. This is a massive failure in the system which needs a quick software update  

1 Like

It depends from DJI’s developers team that haven’t released new SDKs for P4PV2 yet. I wrote them yesterday and i was told they are on the road to resolve. It’s a few weeks question.

Sorry for my english…

Yes the ball definitely is in DJI’s court on this. Until they release the SDK the Pix4D, DroneDeploy, and the rest are unable to  make their apps work with the P4 Pro V2.

Reply I received from DJI Support:

Thank you for contacting DJI.

At this moment, we still don't have any updates for  the SDK for the new Phantom 4 Pro V2.0. What we can do is collect all related feedback related to this concern and forward them to our Developers as Customer's Suggestion to further review as a case possibility for the improvement of our products.

Though, we are unable to provide you an exact resolution time, we appreciate 
your question and we will take this as a suggestion that will help us improve 
our products. We urge you to constantly visit our link - [www.dji.com](http://www.dji.com/) for the 
latest updates on our technology and products. 

We thank you for your understanding. 

 

Everyone that has this issue please express your wishes to support@dji.com, the more pressure we put on them hopefully the sooner they will release the SDK.

 

From DJI Developers Team, some day ago:

Hi Federico,

Thank you for contacting DJI Developer Support with your question. We will have SDK support for the P4P V2.0 in the next few weeks so keep an eye out for it at developer.dji.com.

Thanks,
Lisa Fedane
DJI Developer Support

1 Like

Hello Team Pix4D,

I am very concerned about this issue as I have recently bought a Phantom 4 Pro v2.0 assuming that it would be compatible with Pix4D. This is because I look up to Pix4D as a top brand in drone app software and thought that your app was ready for this new drone from DJI.

90% of my projects have involved the use of a DJI drones and Pix4d app on Android and iOS. But, after looking at this thread I think I will have to hunt for and switch to another app on the market.

This very disappointing and unexpected of Pix4D. We are all looking forward to a solution soon. Please don’t let us down like this.

Thanks.

Ab C-

 

At this point this is entirely a DJI problem. They have failed to release the SDK that Pix4D needs in order to make Capture work with the P4PV2.

There are numerous threads on the DJI forums about this, such as:

https://forum.dji.com/thread-151129-1-1.html

https://forum.dji.com/forum.php?mod=viewthread&tid=152129&extra=page%3D1%26filter%3Dtypeid%26typeid%3D386%26typeid%3D386

https://forum.dji.com/forum.php?mod=viewthread&tid=152347&page=1#pid1415611

At this point the best info we have from DJI is that the SDK may be released sometime in the last half of July. But that really means nothing.

If you want your P4PV2 to work with Pix4D Capture, your expressions of disappointment and frustration should be directed at DJI, at least until they release the SDK. If Pix4D takes a long time to make use of it, then we can put pressure on them.

DJI has released the new SDK! Now it is up to Pix4D and other devs to make their apps work with the P4PV2…

Question for Pix4D: how long will that take?

_Dear Developer,

We are excited to announce the release of the DJI Mobile SDK 4.6 and UX SDK 4.6. You can find them on our developer site at https://developer.dji.com/mobile-sdk/downloads/.

This version of the SDK introduces support for the DJI Phantom 4 V2.0, Zenmuse XT2 thermal camera, Payload SDK, and missions for Spark (Follow Me, Hotpoint, and Waypoint). SDK 4.6 is revised for the GDPR (General Data Protection Regulation). The privacy policy is also updated according to the GDPR. Please refer to the release notes for the full list of changes.

The UX SDK 4.6 includes bug fixes and a color waveform widget for iOS. Please refer to the release notes for the full list of changes.

As always, the DJI Dev Team is committed to improving your developer experience. Please report any bugs or questions you have to dev@dji.com. We recommend frequently checking the DJI SDK downloads page to ensure that you are always working with the latest version of the DJI SDK. 

Best regards,
The DJI Developer Technologies Team_

Hi Pat, thank you for the update.

As DJI mobile SDK 4.6 comes out introducing support for the Phantom 4 Pro V2.0, we will analyze it and consider the possibility of officially supporting this drone in Pix4Dcapture. Our development team is continually working to implement the new drones but, at the moment, we can not guarantee if the P4P V2.0 will be supported and when.

In the meantime, we encourage users that would like support on this drone to leave a comment on this thread.

regards

2 Likes

Hello Team Pix4D,

we tried to fly with the P4P V2.0 and the PIX4D App (iOS). Unfortunately, this drone is not yet supported. We would be thankful for a quick implementation.
Best regards