Support Website Contact Support Blog

Picture capture fail

Hi, for the first time with pix4D capture today (since November), v.3.6.1, the mission has flown with regular clicks sounding OK and mission going all well, though in the end photo capturing has been interrupted and some random photos have been acquired at 10sec+ intervals… Should we trust the software or not?

Hi Dim,

Could you please tell the model of the drone you fly?
Also we recommend to have the latest firmware installed.

Regards,

We are experiencing the same issue! Flying an Inspire 1 with the latest firmware and latest version of the capture app I had three flights with completely random spacing, photos that were way over exposed and then random photos taken while returning to home at the end of the mission!?!

Hi Brett,

The latest version of Pix4Dcapture on Android improved the picture triggering (3.7.1).
Did you have the chance to test it?

Normally the camera settings are automatically defined in our app, but have you tried to change the exposure in DJI GO before starting the mission with Pix4Dcapture? https://support.pix4d.com/hc/en-us/articles/203204339

Regards,

We are iOS users not Android. I did also change settings in the DJI Go app but I shut it down completely when running Pix4D to avoid any conflicts with the Inspire. Even so it doesn’t explain the random spacing on pictures.

Hi Brett,

Yes you are right. The image spacing is not related to the fact that DJI GO is running in the background.

Could you confirm you are now using the latest iOS (1.7.0)?

To clarify the situation, there are two different picture triggering modes for the simple grid mission (Map view > Settings > Advanced).

  • Safe: The drone stops to take every picture which significantly increases the flight time. The way-points where to shoot are uploaded to the drone before starting the mission. This means the drone can fly the mission without requiring a connection with the app.
  • Fast: The app sends a signal when to shoot. This mode does not make the drone stop but the connection with the drone should be maintained without interruption. It is solely based on the position of the aircraft.

Gaps in the image acquisition can happen because of connection loss with the Fast Mode. The interactions between the drone and the app during a mission are as follows.

  1. The app receives the GPS location of the drone (drone >> phone).
  2. The app decides to take a picture according the new location, and asks the drone to do it (phone >> drone).
  3. The drone may or may not take a picture, even though usually it does.
  4. The drone sends back a message to say that the picture was taken (drone >> phone).
  5. The app shows the camera icon at the position of the drone when the message is received.

Therefore the camera icons on the flight track of the grid do not always correspond to the exact location of the photos where they were taken. Indeed some delays may happen in steps 1, 2 and 4 described above. Sometimes the app does not know whether an image was indeed taken (step 4) so the camera icon does not show up which explains gaps.

Hope this helps to better understand the situation.

Regards,

Hi:

I experienced a condition that camera icons are shown on the pix4d capture but there is not some images on my sd card

I am using ios

Hi there,

I am having similar issues, plus during the mission Pix4DCapture shuts itself down and from there on no images are captured. I flew some double grid missions to build a 3D models from crop plots. It seems that all the images were captured, but when I started to look into it in more details on Pix4D Mapper, I noticed that there were gaps where pictures were not taken. I was flying this morning and around half way of the mission Pix4DCapture just disappear from my iPad Mini 2’s screen. On the picture below one can see the exact moment that it happen. I launched the Pix4DCapture again and it connected to my Phantom 4 Pro, but from that point on it seems it start a “new mission” where no pictures were captured (see second image below). Looking at the flight time on that screenshot, the flight time (7min 48s) is kind have of the time of my original flight time. Have someone else experienced similar issues? After those issues experienced on the last couple days, I decided to try capture the image with the DroneDeploy app. The third image below shows the results of that flight after importing the picture into Pix4D Mapper. Now I am thinking that the problem is more related to DJI (hardware and/or software) than with the apps that run the survey missions.

Any help would be greatly appreciated.

I am flying a Phantom 4 Pro, using the latest firmware and using Pix4DCapture version 2.1.0(6).

 

Thanks.

 


2 Likes

@Danrsh

Could it be that the SD card was almost full?
Was the drone calibrated with the DJI app before?

@Paulo

Thank you for the detailed feedback.
Did you check the calibration of the drone with the DJI app?

This behavior is strange and I would like our developers to have a closer look. Could you please send us the log files using our request form: https://support.pix4d.com/hc/en-us/articles/hc/en-us/requests/new

For more information about the log file, please see: https://support.pix4d.com/hc/en-us/articles/215281483

Julie,

I check the DJI app before flying the mission with Pix4D capture and everything was ok. I would love to share the log file with you guys but I uninstall Pix4DCapture from my iPad and did a new installation to see it would solve my issues. Doing so, it seems that I lost the log files from my flights on July 5th. 

The new installation of Pix4DCapture seems not be the answer for me. I was out flying this morning and on my first flight the P4P (Phantom 4 Pro) went to the first point and just hover there for 30s-1min, and I brought it home. I reloaded the mission, took off and it seems that everything was going to work, but I was receiving any telemetry from the P4P and there were no “cameras pictures” along the flight path. I aborted the mission and that time I had to land the copter manually because for some reason Pix4DCapture was not giving me the option to come home and land. So, I landed, turned everything off and back on, uploaded the mission and try to take off again. After that my Pix4DCapture would connect with the P4P from my iPad. So, I turned everything off again and switched the iPad for my iPhone. From there on, Pix4DCapture connected to the copter, the mission was uploaded, I was receiving telemetry data from the copter, the “camera images” were showing on the screen, and at the end of the mission the copter came home and I received a message that I had captured around 240 images.

The surprise came few hours later when I was going to download the images to my desktop. There was only one image on the SD card, and it was in an awkward angle. The camera was not even pointing to the target area. Lately I have noticed that the on the checklist before taking off, the camera item is showing in orange and it says “unknown camera”. Few seconds later the mission is usually successfully uploaded and I can fly.  I do not remember seeing that a month or so ago.

I have the logs from the flights that I did this morning with the iPad and with my phone. I will share those logs with you guys, since I do not the ones from 2 days ago.

Thanks.

1 Like

Julie,

I just want to update you on the issue of Pix4DCapture shutting itself down during mission flight. I was just flying the P4Pro using the DJI app and everything worked just fine. So I decided to try to fly a mission with Pix4DCapture over some research trials. I flew two missions, basically the same mission twice, and Pix4DCapture shut itself down both times. On the first mission it took pictures of three passes and one the second flight it took pictures of 4 passes. I just checked the firmware versions of both controller and aircraft, and I have the latest versions installed. I will send you the log files from today using a request form

1 Like

Exactly the same as Paulo, Everithing looks fine, the drone ends its mission without any warnings, but when I tried to dowlnoad those pictures I realize that they weren’t taken. SD Card is Empty.

 

I hope you could help us. 

@Juan - Could you please confirm:

  • The latest versions of both Pix4Dcapture and DJI GO are installed.
  • Latest firmware is installed on the drone and the remote controller.

Also :

  • Did you try to log in the DJI app and connect to the drone before opening Pix4Dcapture?
  • Did you make sure DJI GO is not running in the background when starting with Pix4Dcapture?

Please send us more information (request form) and provide:

  • Device’s brand and model:
  • OS version (ideally the latest):
  • Type of mission:
  • Were you using the Safe or Fast mode to fly the mission?

For more information about the log files, please see: https://support.pix4d.com/hc/en-us/articles/215281483

Julie,

  • 2.1.0 (PIX4D)  / 3.1.13 (DJI GO)
  • Aircraft Version 1.9.20 / I can’t find the controller’s firmware, but when it needs an updating it ask for it in the cell phone screen.

 

  • Yes, I connected the drone with DJI GO, I close DJI GO and then I connected with PIX4Dcapture
  • Yes, i’m sure, because i closed it.

 

  • Phantome 3 Standard / Iphone 5S
  • OS 10.3.2 (Actually today was released the latest 10.3.3)
  • Double Grid
  • I don’t know where i can check if it was on safe o fast mode.

 

 

Hi Juan,

Thank you for all the details and sending us the log files.
We will follow up by email and will post any news related to this issue under this community post.

About the Safe or Fast mode, it is related to the Picture trigger mode in the mission settings.
For more information: https://support.pix4d.com/hc/en-us/articles/115002054263

Hi Julie,

  • I formated from DJI app the SD card 
  • I Clear the video cache

The problem was solved, but i’m not sure if those were the causes.

Thanks for your Help.

1 Like

Hi Julie, 

I’m having similar issues.  Formatted card… all firmware versions up to date.  I’m using DJI P3P.  Used GRID PATTERN for 3D model efficiency.  The whole mission went well.  When it landed… App said ‘downloading images… 0/252’… stuck on that for about 10 minutes so I cancelled (I know you can do that afterwards).  Got back to the office… NO images on SD card??

Btw… when its saying ‘downloading images’… why?  I don’t want to download? I want the images to stay on the SD card… not my iPhone?  

What would you suggest?  Thanks. -Peter

I have a Phantom 3 4k and I am using IOS (iphone 7) with the current versions of DJI GO, Pix4d DJI firmware and my drone will only store photos to the SD card about 50% of the time (entire mission with zero photos at the end)

I always start out with DJI GO first, calibrate, format SD card wait for ready status, force close DJI GO, then start Pix4D and fly mission - I abort when the drone is ready to land and manually land the drone. The sync status stays at 0% transferred - also check the card when I get back to the office - no photos

When using DJI GO I have no problems with taking photos and the images are properly stored on the card.

I have tried multiple SD cards and it does not seem to make a difference.  I have also cleared the video cache in DJI GO multiple times

@Juan

Thank you for letting us know!

@Peter @Jason

It seems like it happens because the camera is not initialized correctly and not ready to shoot when the drone starts the mission. The drone flies but not image is saved on the SD card.

Synchronizing after flying consists in generating the .p4d file and downloading (copying) the images from the drone to the mobile device. However, it is not mandatory to process the images later on your the desktop (more info). In your case, the download probably fails because the images are not found on the SD card.

@Jason

Please contact us using the request form and send us the log files: https://support.pix4d.com/hc/en-us/articles/215281483

I just want to share something related to the same subject that happened to me a week or so ago. I went out to do some flights (4 total) and I experienced the empty SD card issue on my first flight. Of course I did not realize that until I was back into my office. On my first flight, the copter (Phantom 4 Pro) took off and it was going to fly the mission just as normal, but I was not getting any telemetry back from the copter on my iPhone. So, I brought the copter back, restarted the copter and the RC, reloaded the mission, took off again, and I was feedback from the copter just fine. I saw the little cameras on my screen where it “took” the pictures and everything else, but at the end there were no pictures on the SD card, only an empty folder. In the afternoon I went back and flew the same mission and everything worked just fine.
I have experience sometimes what Julie mentioned regarding the camera not being ready or it shows as “unknown camera”. That did not happen during my first flight though.

Best,
Paulo