Support Website Contact Support Blog

Warning: Pix4Dcapture does not work

Devastating experience with Pix4Dcapture (Mavic Pro, iPad Pro):

For a scientific project we need to do repeated mapping of the micro topography of a bog in southern Finland during different times of the year. Testing of several apps available for this kind of mapping, we found that Pix4Dcapture was by far the most reliable (never a crash!) app for the job. We performed two campaigns this spring and early summer with excellent results.  

Today we tried the summer campaign. iPad Pix4Dcapture app updated to iOS 2.2.0. First mission began as usual, all settings in green. However the app crashed after about 75% into the mission. Below is a screenshot taken from the mission manager. Had to manually get the Mavic back to the home point. 

We expected that at least the indicated photos were taken.

We started the second mission. Everything recorded as green. But after liftoff, the Mavic just takes off with high speed away. It’s recorded in the mission manager - see below. Fortunately I aborted the mission in time and could hit the return to home button before the Mavic would have crashed into the trees on the eastern border of the bog.

Needless to say, we did not try a further mission. But we checked whether there was an issue with the Mavic - no problem at all. We did a flight using the DJI GO 4 app; everything find, latest firmware, no warnings, nothing. 

Then, coming back, I found out that not a single photo from the first mission was recorded on the SD card! Thus we spent a whole day driving 400km to the site and back with no results at all.

This is unacceptable - how can pix4D release such crappy software?  Has this been really tested? I really expected more of Swiss quality.

Is there a way to revert back to the earlier, very stable version of Pix4Dcapture, which we used in spring?  

 

Also had a problem similar to this. Flying a DJI i had many missions where not a picture was taken!! I was given a hint to format my SD card using the DJI app (and not my PC) - it worked :slight_smile: or i thought it did :frowning: … after returning back in the office i found only 60 of the 90 expected photos were saved. Any hints welcome!!!

For the record: we reformatted the SD card on the previous day using the DJI GO 4 app.

I have had similar problems (related to no images being stored on the SD card) with the current version of Pix4Dcapture both with Phantom 3 Advanced + iPad Air combo and Mavic Pro + iPhone 6S combo. First, on Aug 7 I did two missions with P3Adv + iPad Air, and I was only able to get the images of the second mission to the SD card. I thought then that maybe the images of the first mission had been lost due to the fact that the mission did not finish completely due to low battery RTH. Then yesterday, on Aug 21, I did three missions with the P3Adv + iPad Air, and two missions with my Mavic Pro + iPhone 6S. This time only one of those five missions succeeded (the 2nd flight with P3Adv) even though Pix4Dcapture always said that everything is ok and that pictures are being taken at planned locations! Even pre-flight live view in Pix4Dcapture was always ok, and all the images and videos taken with DJI GO on those same days were fine.

This is REALLY frustrating, since our study sites are about 70 km away and the weather in Finland varies quite a lot this summer.

I had the same thing happen to me yesterday!  I completed a double grid mission, it reported on the screen that it was capturing images and when I checked the SD card there wasn’t a single photo on the card!

 

DJI P4P, Ipad Mini 4 Version 10.3.3 (14G60), Pix4D Capture Version 2.3.0 (16) 

@Martin

I am sincerely sorry to hear about the issue you recently faced.

We are aware of some crashes that happened with the two last versions but could not reproduce it so far. It seems to be sporadically, but rest assured we are keeping close on eye on this.

However, the communication between the app and the drone is made via the remote controller, so if the app crashes the link with the drone should not be broken and the pilot should be able to take over manual control, as you did, fortunately. If the signal is lost, then I would expect the fail-safe of the drone to be triggered.

Also the drone is responsible for not destroying itself (i.e. not going out of control) so I am surprised about the behavior at the beginning of the second mission. The app tells the drone where to go, when to take pictures, but we cannot give instructions that would override the safe behavior of the drone. The drone is actually the “driver” meaning it knows how to fly.

  • Could it be that the drone ran short of battery during the first mission?
  • Did you restart the app and turn on/off the drone with the remote controller between two missions?

@Martin, Frank, Anssi, Thomas

I understand the frustration. For optimal experience with Pix4Dcapture, we recommend to proceed with basic checks. This article helps users to troubleshoot app issues in most cases. Regarding the problem that you described, I would suggest that you check this community post related to the same topic: (Android, iOS) Images are not captured.

@Julie:

answers to your questions:

(1) In the first mission there was no shortage of battery: The Pix4Dcapture app crashed on the iPad. The drone kept flying on, but I took it manually down. The battery was still about 40% charged.

(2) Yes: I restarted everything after the first mission, and loaded a new battery before the second mission.

But why were no photos taken in the first mission before the app crash? 

 

@Martin

We would expect the drone to come back to the home point if the connection with the app is broken, but it is also not expected that the app crashes. If you can, please upload all the iOS log files you find on the device so that we investigate further:
https://www.dropbox.com/request/76uFQ35i2MBGLHuuqYMT

Regarding your second question, you can find more information in this active thread: (Android, iOS) Images are not captured.

I could only now upload the log files. You will find on the dropbox all files from August 14 when the mishap happened. They were in the directories debugLogs, LogFile, Logs, and SDK_logs. I hope this helps.

We tried a new test mission a few days ago.There are now of course several software updates that had happened since August: The drone is on the lastest firmware, the iPhone is on OS 11 and also your Pix4Dcapture has been updated. The first mission flew correctly, but again did not store any photos on the SD card. After reformatting and changing in the DJI Go 4 app the photo format of the drone to JPG (I normally record photos only in raw DNG format), the second trial mission did record the photos.