Support Website Contact Support Blog

PIX4D Capture experiences with DJI

Hi all,

I am licensed UAS pilot and get to use them on a regular basis at work for surveying and inspections.

I use Pix4Dmapper Pro for processing and have assembled reconstructions with over 20k images. In all the time using Pix4Dmapper Pro, I have only had the program fail a handful of times. This is even going back to previous versions over the recent years. It seems to be bulletproof. I can load a large dataset and let it run at 100% for 7 days and it doesn’t care, it will complete the task.

Get the developers off of the stupid desktop program and on to the mobile apps before you piss off any more people and the market looks elsewhere.

I had a mission to  inspect a large paved area. The Phantom 4 was in the air a total of 10 hrs over 2 days, those batteries got a workout. The IOS app crashed over 16 times, each time required the drone to be brought home and power cycled before the mission would upload or the camera would calibrate in the app. This wasted about 3 hrs and unknown battery flight time over the days. The drone would lift off and go to start the mission but not take pictures. I understand completely the “safe mode” in the mission planning and for the scale of the project it is unacceptable. The first day’s mission (4 person crew, 2 drones, fixed wing and P4) was to be the only one but after discovering the missing data a 2 person flight crew drove another 6hrs round trip to pick up the data. On the 2nd day the app continues to not send camera shutter triggers and while I did my best and caught most of the mission failures on both days, sometimes the app crashes and goes to the home screen.

This is a joke, and nobody is laughing.

The fact that a company has promised battery changes with mission resume for 2 years is absurd. I am very disappointed in reading through the forums about ALL the things that get pushed off by developers, citing bug fixes. THIS IS A BUG!

App crashing in front of a client. THIS IS A BUG!

Ignoring the requests of your user is a bug a level that is not software related. I demand priority treatment for the IOS app.

My company has grounded the P4 because of this embarrassing app performance and the loss revenue.

IOS, Pix4D Capture and DJI GO4 all up to date. dji go works fine and is not running while the drone is in mission. 

1 Like

I cannot recommend to anyone to use the Pix4D Capture app until works correctly, every time.

We have the same story and the same problems.  We’ve gone through 5 different tablets, cards, etc.  Dozens of hours lost because the app isn’t consistent.  Frequent crashes on one device, missing pictures on others, it is really painful.  

1 Like

I am sure apps from other automated services same issues…

Have you guys tried the DJI Ground Station pro? (if you use DJI products) 

I won’t give up pix4d because I really like the control of the data they give us as opposed to the others which are only cloud based.

2 Likes

Cesar, this post is not helpful and not related to the original topic. Would you care to share you experiences with the app crashing or performing less than optimal. I appreciate your optimism but that doesn’t pay the bills.

Best,

Dan

Hi Dan, I did not mean to deviate your post or make it less important. I am sorry about that, and I understand your frustration.

The helpful bit in my post is to try GS pro. It only run in IOS.

In all honesty I did experience some issues in an older android tablet, but not when I run the app from a cell phone (Note 5).  So yes, I sympathize with you, because from my experience the issues are related to the tablet or phone compatibility. I have not run their app on IOS. But like I said GS PRO works well for us. 

I fly an inspire and P4. and most recently did a project with a Mavic pro, no issues on the Note 5.

When we have to change batteries to continue, yes its a PITA.

 

1 Like

10-4 Cesar, i appreciate the insight and will bring it up to the team. Anyone else please pile on bad experiences with the app.

best,

Mr. Lench, I endorse your complaint. To change battery and resume mission is a very important feature that is still missing. There is always a way around it in case of small areas to be covered (like making a annotated map on paper) but in case of larger areas it is a failure. I recommend Map Pilot (Maps made easy) for iPad. It has got some issues but mostly solved by now. Still, Pix4D is easier to use. Regards, Petr Hanák (I am a farmer and real estate owner). 

1 Like

Thanks all, I appreciate the recommendations. Please keep them coming!

Cesar, do you think it may have anything to do with the cellular data connection being available in the Note vs the tablet? Or maybe the android version of the old tablet vs the Note?

 

best,

Dan

@Cesar Rullier   DJI GS Pro is not very good for larger scale mapping. It has limitations for distance, height and number of turns in the flight. I tried them all, like 6-8 programs. Maps Made Easy and Pix4D are the best. Pix4D has much better usability but Maps Made Easy have more features (battery change and resume, visibility of previous flights) and are becoming more stable than before.

1 Like

Had 3 app crashes yesterday and 1.5 hrs of wasted time again.

  1. Can someone from Pix4D comment on this thread

  2. Can Pix4D charge $40 for the app and fix it correctly, ASAP

I have deemed the Pix4Dcapture app basically unusable for me after the latest update…I’ve tried multiple devices and everything is up o date. I’m a surveyor for a construction company and we fly a Phantom 4 Pro almost daily on our earthmoving jobsites to verify quantities. For the last week or so every time I create a mission and it takes off…it will either not go to it’s designated elevation or it’s starting waypoint…or sometimes it will fly the entire mission and not have any pictures on the sd card. So I’m back to using DroneDeploy which seems to be working fine right now… but the whole reason I stopped using them before and gave Pix4d a shot was for basically the same reason. Also dronedeploy has the capability to resume the project after a battery swap.

1 Like

Hi all. I was about to write a fresh new post on this same problem but as I see, unfortunately, I am not alone. I am having constant problem with Pix4D Capture v 4.0.1 build 421 to fly a grid mission 400x500m at 100m altitude with a Samsung Galaxy Tab A tablet and with a BlackBerry Priv both Android. The mission starts surely, but at about 100 to 200 pictures into the flight it stops taking new photos.  With the Samsung tablet the Abort mission button did not work and I had to manually override and control back the vehicle, with the Priv it did the same but the abort worked this time.  I have both Android devices with all the latest upgrades and the Phantom 4 has the latest DJI firmware (v 02.00.0106). Any ideas for solution most appreciated.

1 Like

Thanks everyone again for your stories. keep them coming. 

Hugo, I had to switch to ipad because the android Nexus I have quit working with the app.

1 Like

Hi all,

Thank you for sharing your experience. I sincerely understand the disappointment, so do my colleagues involved in the app development. Obviously, Pix4Dcapture is not perfect but we are doing our best to improve it.

I understand it is frustrating, please remember that profanity is not appropriate in this community of Pix4D. Messages that include profane content may be edited or removed. We greatly appreciate when contributors are civil with one another. Thank you for your understanding.

@Daniel, Doug, Colby
Regarding hot issues that were reported:

  • It is true that the iOS app had recently more crashes than previously. We could not find all the reasons that could trigger them, but we already troubleshot some factors.
  • Several users reported images were not captured. Please find my latest comment pinned at the top of the post here.
  • As we cannot test all Android and iOS devices, there might be differences when using Pix4Dcapture depending on the smartphone/tablet. Many of you highlighted it. My recommendation would be to try another device if you can.
  • For latest news on the multi-battery flight, please check my comments here.

More generally, I recommend to proceed with basic checks. This article helps users to troubleshoot app issues in most cases as it provides many hints so users can better understand what could be wrong. Updating to the latest versions (apps, firmware) is not the only recommendation.

@Cesar, Petr
Thank you very much for participating in this thread to help! Your practical and positive comments are really valuable.

@Hugo
Could it be that space is missing on the SD card? How did you notice pictures were stopped being captured? Could you please contact us and send us the log files (learn more) so we investigate further?

2 Likes

Julie, thanks for the feedback.  In my case I am sure I have sufficient space in the on board SD card (59+ GB free).  In the interface I noticed that the camera icons, as well as the shutter sound, stopped roughly half way through the planned mission. 

 

How can I send the log files?  This browser is only allowing me to send image files. 

You can fill a support request in and attach the files. I will be following up :).

Julie, I am trying to send the log files, have you receive any? I am not sure if the support request form is working at my end. Thanks.

Hi Hugo,

We did not receive a request with your email address, or maybe you used a different one?
You should get a confirmation email if the request is received on our side. If you did not get an email from us, I invite you to submit a new form.