Support Website Contact Support Blog

[Android Beta] - Phantom 3 Professional / Advanced and Inspire 1

UPDATE: The version 2.0.7 is available

This version is publicly available and it is no longer necessary to be part of the beta group to download it. To download the latest version on Google Play: https://play.google.com/store/apps/details?id=com.pix4d.pix4dmapper

However, the Phantom 3 Advanced/Professional and the Inspire 1 are still labeled as beta.

For instructions on how to use the App: https://support.pix4d.com/hc/en-us/articles/202557269


Hello Pix4D members!

We are happy to announce that a beta version of the Capture App on Android has been released!

Please be aware that this is a beta and the App might be unstable and therefore it is intended for advanced users.

 
In order to be able to try the beta follow these steps:

1. Join the beta tester Google Group and download the beta.

  1. Log in to your Google Play Store account: https://accounts.google.com/
    2. Go to the following link and click Join Group  to join the “capture-beta” group: https://groups.google.com/forum/#!forum/capture-beta

  1. In the Join the capture-beta group pop-up, click  Join this group.
  2. Go to the following link to register as a beta tester: https://play.google.com/apps/testing/com.pix4d.pix4dmapper
    5. Click  BECOME A TESTER.

Note: After the registration, you will now receive the beta updates from Google Play Store (similarly to normal updates, but that will be the beta version).

  1. Download the app from the Google Play Store page: https://play.google.com/store/apps/details?id=com.pix4d.pix4dmapper
    Make sure that you are logged in with the Play Store account that you used to register as a beta tester.

  

2. Install the latest DJI firmware on your drone and remote controller.

The current the beta version 2.0.5  is compatible with the firmware  V1.4.0010  for the Phantom 3 Professional, Advanced and the Inspire 1.

  1. Download the firmware:
  1. Install the firmware on your drone following the instructions from DJI:

  

3. Start using the App:

  1. Turn on the remote control.
  2. Turn on the drone.
  3. Connect your phone to the remote control in USB.
  4. Make sure that the switch P.A.F is in the F position.
  5. Open the App.
  6. Go Settings > Drone type for this app and select the appropriate drone.
  7. (optional) If using the Inspire 1, enable the advanced mode: Go to Settings > Advanced settings and enable the advanced mode.
  8. Go to Grid Mission.
  9. Select Start.
  10. In the takeoff checklist, depending on the drone you may have the following:
  • Phantom 3:

To get all green checks and to be able to start the mission you need to takeoff manually

  • Inspire 1:

To get all green checks and to be able to start the mission you need to:

  1. Ignore the low battery level : Press on the Battery check and ignore this check (you need to have enabled the Advanced mode see point 6).

  2. Takeoff manually

  3. Press for 3 second the Press and hold to takeoff button.

 

Notes:

](https://support.pix4d.com/hc/en-us/articles/204068019#label1)

  • The Sync / Mission Manager is still unstable and you might have to force quit the App.

  • The user interface is not complete and it will be improved for the public release.

  • The USB connection is not stable in the current firmware, if it does not connect:

    1. Unplug the USB cable between your phone and the transmitter.
    2. Close the Capture App.
    3. Plug the USB cable and restart the App.

We hope that you will enjoy using the beta version and we are looking forward to receiving your feedback.

Regards,

Hi
Thanks for the detailed discription.
One question: Will the dji pilot app still work, even that the firmware has been upgraded?
Thanks,
Martin

hola no se instala el firmware en el mando

So it seems that no matter what I do I cannot get the inspire 1 to connect to my device. I have double checked my beta version on my Inspire and that I have the correct version of Pix4d capture app. I have done the above steps numerous times. Is there a selection of devices that work and some that don’t? I have tried a Nexus 7. Galaxy S5 and a Galaxy Note tablet.

Hi. I would also like to know if the original DJI pilot app will work as always after the firmware update.
Thanks

Hi all!

We expect that the DJI Pilot App should work with the beta firmware of DJI. We don’t see any reason why it should not.

On our side we have a firmware that is slightly different from the one that you can download and we did not had any issue when trying the DJI Pilot App.

According to this forum the beta firmware works with the Pilot App on the Phantom 3:
http://www.phantompilots.com/threads/dji-mobile-sdk-firmware.47982/

To confirm if the beta firmware of DJI works with the DJI Pilot App we would suggest to contact DJI Support.

Don’t hesitate to let us know if you have more information.

Regards,

UPDATE: We have tried to the DJI Pilot App with the Inspire 1 with the same firmware as the beta that you can download from DJI Developer (V01.02.02.18) and the DJI Pilot App worked.

I just downloaded 2.0.1 to two Hudl devices (Android v4.4.2)and both still stop with the error message of ‘Unfortunately, Capture has stopped’ when I select I1 (beta) as the drone. I have disabled 'sync auto … ’ too in case that helps, but it doesn’t. This is before I connect to the Inspire RC.

Thanks for the detailed information. Inspire 1 here.

I have some questions:

1 In the event that something goes wrong by flipping the into the S1 position, I will be in full manual (ATTI) mode. What happens if I then switch back to GPS mode? Will CAPTURE take over where it left off?

2 I want to make sure that a CAPTURE crash will not send my DJI crashing into the ground.

Thank you

Hello DDS CAD:

1- It will not take over where it left off: you will keep the manual control. Don’t flip it back too fast though, because it has to be detected ;-).
2- The drone’s safety is the problem of the drone (and it does that really well). Capture cannot crash the drone. The only thing it could do is sending it against an obstacle, but you can always take over in manual control.

@Jonas,

To reiterate, if there is a need to overide or go into manual mode, I can go into ATTI, then back to GPS but at that time CAPTURE is out of the equation. Meaning once you go int ATTI, you kill the connection to the commands by CAPTURE

@DDS CAD:
Yes, you are right. I always do this both on Inspire 1, P3 pro and P3 advanced!

Another question:

What will happen if I need to take off from an area which obstructions (trees). It sounds like at this moment we are unable to manually take off and take the UAV to a safe altitude or close to the start point.

https://play.google.com/store/apps/details?id=com.pix4d.pix4dmapper

Points to the ‘old’ app… It’s that intended?
Thanks,
Martin

Hello,

Thanks for accepting me to beta program. I also on beta program of DJI and using firmware V01.02.02.021 but i see that you say i need to upgrade to 018. Is this a problem?

Question, I have been using this with my inspire 1 and it works other then it spends half the flight spinning around in circles at every end point. Is this normal?

Hi all,

We have updated the instructions, see point 3 above. You need to enable the developer mode on your phone, read above how to do it.

Regards,

@ Martin: Once you have completed the registration with the link that you received with the invitation, connect to the Google Play Store using the email address with which you completed the registration. On the Google Play Store you should see a version number starting with 2.0.X.

Regards,

@ naz naz: If you have a more advanced firmware it should also work. For the Inspire 1 you should use the firmware 018 or above. Let us know if you are having issue using the firmware 021.

Regards,

@Martin: Once you are added to the beta group, you have to go here to activate it: https://play.google.com/apps/testing/com.pix4d.pix4dmapper. Of course you need to be logged in with the user that is in the beta group when you visit the link!

@naz naz: It should work for any version number higher than 018. It is just that some features were not enabled in previous firmwares. Let us know about your experience!

@Bill Jackson: Which firmware do you have? Ours is making circles during the takeoff, but then it stops and it always keeps the same heading. Does it only make circles when it reaches a waypoint (end of a line)? So the pictures are taken correctly, right?

hi there
having problems with .21 firmware not seeing battery, always @ 0%