Support Website Contact Support Blog

Connecting to Inspire 1 with Capture app (Beta version)

I’ve registered as a beta tester for the Pix4Dmapper Capture app to use it with my Inspire 1 drone, and am having difficulties with getting it working. I followed the instructions from the support site (https://community.pix4d.com/t/4828) but when I click “Start” in the app window and then “Next” the following pop-up states “Please connect to drone.” At this point, I am unsure what to do to connect to the drone. It connects fine through the DJI Pilot app, and I have the remote switched into the F position, I’ve allowed USB debugging on my mobile device, and have selected “I1 (beta)” in the upper right-hand corner of the app. I would appreciate any advice you can provide. Thank you.

Dave, we have had same problem with the preplanned flight with Inspire 1. As a work around for now, we have flown the Inspire 1 in manual mode and recorded pictures this way. We were able to calibrate the photos and create a 3d point cloud as well.

 

 Now that we got it to work we will be upgrading to the Pix4D mapper pro.

Geez, just made a post about this one. I am having the same problem. 

So Joe, you just fly using the DJI app and then upload the photos to Pix4D? 

Mitch, yes when you open capture app you will see preplanned flight and manual flight. We were able to use the manual flight with the automated pictures settings.

Then just download photos from SD card on inspire and upload to pix4d.

Hello,

If you cannot connect to the drone it could be for the following reasons:

  • The DJI Go app is running in the background. Make sure to properly close the DJI app before using the Capture App, swipe it away in the running. We have noticed some issues with our app when the DJI app is running in the background. 
  • The app did not get the SDK token. When you launch the app from the first time and from time to time, the app needs to connect to the internet to get the DJI SDK token. Once the token is activated, it is not needed to have internet access to use the app.

Note that we have released a new version of the app, version 2.0.4. Make sure to try it with the latest DJI firmware.

More information here:

https://community.pix4d.com/t/4828–Android-Beta-Phantom-3-Professional-Advanced-and-Inspire-1?page=10

Let us know if it helps!

Regards,

Thanks guys, 

I think it was just a case of user error. I believe the issue was my android tablet did not upgrade the capture app automatically and I assumed it did. Getting the hang of it. I successfully made a 3D model of my office and models of past photography projects over the weekend. It was raining non-stop so I haven’t been able to fly. I plan on going out this afternoon to try again. Your customer support is terrific, especially considering I’m still just using the free version right now. I do plan on purchasing the full version once I have finished negotiating with potential customers. 

Thank you,
Mitch Apple

I am having similar issues using the P3P Beta. I’ve followed the cookbook as well as:

“Make sure to properly close the DJI app before using the Capture App, swipe it away in the running.”

In either Grid or Free flight mode I am unable to get past “Please connect to drone”

I’ve tried this on both Android and iOS smartphones. Neither is able to connect. The interfaces at this stage of startup are slightly different.The iOS gives a button option of going to Wi-Fi Settings, the Android does not (but of course easy enough to access wi-fi setting on Android). The IOS brings you to the Capture settings, but only for detect location settings. In any case, I’m not sure how to connect to the drone - there is no wi-fi detected for the drone on either smartphone. Any thoughts here?

Hi Stefan,

Did you selected the appropriate drone in the drop down list when you are in the map view of the app? For the Phantom 3 Pro you should select P3P.

Make sure also that you are using the beta version 2.0.4 with the firmware version V1.4.0010 installed on the drone.

With the Phantom 3 you do not need WiFi to connect to the drone, you should use a USB cable between the phone and the remote controller.

You can find more information on how to use the beta on the following page:

https://community.pix4d.com/t/4828–Android-Beta-Phantom-3-Professional-Advanced-and-Inspire-1?page=12 

Note that the Phantom 3 is not yet supported on iOS but we are working on that. We will post updates on the following page when we have a beta ready:

https://community.pix4d.com/t/4464 

Best regards,

Thanks for the response on this. I have double and triple checked the setting P3P and beta and firmware versions. I have also uninstalled and reinstalled the app. Yes, USB cable between phone and RC, otherwise not much will happen. It seems most all the other postings here are having similar issues. I have followed precisely the information on page you for which you provide a link. Any other thoughts on why the capture app is unable to connect to the drone?

same here, posted the problem somewhere else. Try a different tablet/phone. My Z4 tablet works with 2.04 but not 2.05 or 2.07 while my phone and asus tablet works with 2.07. It is a bit trial and error with different tablet/phones. Welcome to Beta testing ;)…

Well having upgraded my s5 to a note 5, I can confirm that the capture app has a compatibility issue with 5.1.1. Both my Z4 tablet and Note 5 can’t connect while my samsung s5 with 5.0, no issue. I stop wasting my time on this app. No one seem to care. Back to good old x8+ with mission planner. 

Philippe - good to know I am not alone on this one. Following your lead - are you using APM Mission Planner?

yep and 2.08 didn’t change a thing for us with recent mobiles/tablet. yes mission planner with pixhawk (x8+). Shame though because the P3 is actually a very capable and cheap mapping platform. 

Hi Philip and Stefan,

There are indeed connection issues with the app. It seems to be related to some devices or Android version of the phone. It is difficult for us to investigate this bug since we cannot reproduce it with the devices that we use for testing.

We have recently released the beta 2.0.8 and updated the DJI SDK hoping that it would improve the connectivity. Unfortunately it seems that the problem is not resolved. 

Let us know on our dedicated forum post for the beta 2.0.8 what setup you are using (drone, drone firmware, device brand, model and Android version) and which version of the app works or not:

https://community.pix4d.com/t/4838 

It would help us to investigate the bug.

Thanks,

Best regards.