Support Website Contact Support Blog

[Android] Beta release 2.0.8

Hello Pix4D beta testers!

The beta version 2.0.8 has been released and can be downloaded on the Google Play Store: https://play.google.com/store/apps/details?id=com.pix4d.pix4dmapper 

Make sure to be a beta tester to download the beta: https://support.pix4d.com/hc/en-us/articles/206913853

Instructions on how to use the app: https://support.pix4d.com/hc/en-us/articles/202557269 

Please use this post give us feedback about the version 2.0.8.

Looking forward to your feedback!

 

What’s new

  • Upgrade to DJI SDK 2.4.1
  • Support DJI firmware 1.5.0030 for the Phantom 3 Pro and Advanced
  • Support DJI firmware 1.4.0010 for the Inspire 1

 

Known bugs

  • (P3A, P3P and I1) Synchronization of the images

    • At the end of the mission the images are not synchronized properly. Workaround:
  1. Disable the Sync automatically when mission ends option in the settings. For more information: 203873435.
  2. Transfer the images from the drone’s SD card to the computer.
  3. Create a new Pix4Dmapper project and process the images locally. For more information: 202557369.
  • (P3A, P3P and I1) Connection problem

    • With some devices and Android versions, the connection is failing and the application is requesting to connect by WiFi.

 

Tips to use the App

  • (I1): Sometimes the mission cannot be uploaded (in the preflight checklist). Solution: Hit “cancel” and to start the mission again.
  • (P3A, P3P and I1): “cannot fetch media list” If you get this message, it means that the connection with the drone is not complete. Solution: Unplug the USB cable, kill Capture, replug the USB cable and restart Capture.

Is 2.08 up? Play store seems to only have 2.07.

I’m not sure if it matters - but did you follow the instructions to join the “beta” group - might be your issue.

 

On another note I’m sad to report that the 2.0.8 did not solve my issue with connecting to the P3 - My guess at this point is that they do not support 5.1.1 on Android. Currently trying to find a device that is 5.0.

Running P3A - 1.05.0030, LG V10 - 5.1.1, Capture - 2.0.8

I am only seeing 2.07 as well.  Maybe we need to wait for it to propagate.  I am having the same issue as Zach with my P3P connecting.  I am hoping this will fix it.  Fingers crossed!

 ***UPDATE*** I just got the 2.08 update and I was still unable to connect to my my P3P.  Any ideas?  I did downgrade to 2.04 and was able to connect, but the preflight list was unable to get anything and the app kept crashing.

Samsung S6 - P3P (Also tried iPad Air)

Samsung Tablet SM T-700

Running P3P - 1.05.0030, Capture - 2.0.8

Flew two missions tonight flawlessly. It was dark, so no photo analysis, but app worked great.

One request…at the end of the mission, the update of the craft position stopped on the map. If I closed grid mission, and relaunched grid mission, the craft position refreshes just fine. I would prefer if I could always have correct craft position after the mission ends, and not have to relaunch grid mission.

Thanks for your work on this.

John

That is great news. What version of Android are you using?

@jason: 2.0.8 is in the beta channel right now. It should go in production next week, if it is not worse than 2.0.7 ;-).

 

@Zach: I just come back from 3 flights with the P3P - Firmware 1.5.0030 - Nexus 6 / Android 5.1.1. One problem I sometimes have is that the map view crashes when I click on “Grid Mission” from the main menu. In that case, I “Force Quit” DJI Go and then it works. I really don’t understand why it is not connecting for you.

Can you confirm that you get the Android popup offering you to open Capture with the detected USB accessory and that the “wireless icon” on the upper right corner of the map is blinking green at some point (which means it is connecting)?

Slightly different topic.
Would anyone in a warmer region be able to share about 100 pictures about a corn field (maize) recorded with 2.0.8?

If possible with some storm damages?

I like to convince an insurance company here that this can be done very nicely, but it’s winter here and there is no corn around…

Thank you very much.

Martin, Switzerland, www.luftbild.aero

@Jonas: Yes the phone is asking which app I would like to open the USB device with and I choose the Pix4D app.  It loads in and then I click on the grid but the wireless icon in the app is not blinking or anything.  It is not pulling any information from the done either.  I will let it sit there for awhile as well.  Then I will try to unplug the USB from my phone and back in and it will ask me again to use the Pix4D app, but it still does not connect.  Below is my setup:

P3P with 1.5.0030 - Samsung S6 with 5.1.1 - Pix3D Capture App with 2.0.8.

Is there a log file I can provide that might show something?

@Zach: I will try an S6 on Monday!

Unfortunately, the log file is not really useful for that. I am working on a new prototype, let’s hope this one will work!

@ Jonas: That would be great.  I look forward to hearing your results.

@Jonas:  I just got a hold of my brothers Samsung Galaxy S4 with Android 5.0.1 and it connected with the Capture v2.0.8.  I just ran a mission and it is processing now.  Only issue I had is that there were some gaps where it just didn’t take photos.  I think maybe it is because the SD card on the drone could not keep up.  I am going to try to use a better SD card and slow down the number of photos per second.  Definitely something to do with my S6.

I used a Samsung Tab S2 this afternoon with my Inspire 1 Pro, and though I had to reboot/restart about a dozen times, I was able to get two Capture flights out of it.

I assume that it was because of the overlap, but the slower flight speed meant that my batteries lasted significantly longer than my first attempt.

As for the missing images - I had a similar experience to Zach, a few were missed. The app does seem a *teeny* bit more reliable, so that’s a plus. 

Oddly enough, the only time my missions would work was when I received the “cannot fetch media list” warning. If I waited a few seconds, the drone would connect, and typically let me fly.

Also, the other factor letting me run a mission was that the prompt asking me to close DJI Go had to happen. If that prompt came up, I seemed to be good to go. 

I ran a single 230 photo mission today, at 300 feet.

It looks very good, and processed in Pix4d rather well, compared to what I was getting from 2.07. I suspect this is because 2.08 now will let you fly at a much slower speed. I flew at the slowest setting, which yielded 18 feet/sec. In 2.07 the slowest mine would go was 32 feet/sec.

I also increased the overlap to 85%, and I am observing a much denser tie point network in the adjustment report.

It also looks like our EXIF elevation data is now actual WGS84 ellipsoid elevation, as opposed to height above ground.

Nice improvements.

Can’t get it to work.

I’ve downloaded 2.0.8, set it up on my P3A, but the app isn’t connecting. The wifi icon on the apps is not turning green.

@Franie: Please provide the following.

Device:

Android Version:

Firmware Version:

Thanks for your E-mail: Just to recap then:

No connection with the following setup:

Device: Galaxy Note 5 android 5.1.1 and Sony Z4 tablet android 5.1.1

Phantom 3 Advance with 1.5.003 and latest RC firmware 1.5.7 

Go app, Litchi, drone deploy all work with current setup.

Pix4d capture works with above setup but lower android version for me.

I hope it helps,

Philippe

Does this version support ‘city reconstruction (visible facades)’ with Phantom 3 in a common way?

 

I am using Phantom 3 Adv (1.4.0010) and 2.0.5 now, and it seems that four flights are needed to shoot facades around the building.

 

 

 

@Jonas

Looking at these forums.  There seems to be a lot of issues with the Galaxy S6 Edge. Also noted above are the Galaxy Note 5 and Sony Z4. What do all of these platforms have in common?  Android OS 5.1.1.  I do remember some saying they had issues with the Tab S2, but that is 5.0.2.

So I have done some extensive research into the changes between 5.0 and 5.1 and the API levels are different 5.0 is 21 and 5.1 is 22.  So then the question is, what changed in 22. Android 4.4 is level 19

So my question is do you specify an API target level?  If so are you specifying say 19 for Android KitKat (4.4) or some earlier version to insure the Android API behavior for the app is consistent?

The issue may not be with your app but the DJI Mobile SDK which is running with the domain of the Capture App.  So by specifying the API target, you would force the DJI Mobile SDK to use an earlier API level and hopefully make these issues go away. My guess is the other competing apps are doing something similar and that would explain why it works for them and not the Capture App.

If however you are specifying/targeting an API level of an earlier Android OS then this isn’t issue.

…Just trying to help

@Jonas Any idea if this should still work with the new DJI Inspire 1 firmwares that were released recently?