Support Website Contact Support Blog

Beta 2.05 not working on Phantom 3 Pro

Hi, I tried the beta of Pix4D capture app Beta: 2.0.5-beta

The message I got was:

Failed to get media list from device. The drone takeoff checklist has only two options checked on the final options screen were drone connected a and phone status. All other items were (?) or (x)

My hardware setup was:

P3Pro Firmware: 1.4.10

RC Firmware: 1.4.30

DJI Go app: 2.3.0

Has anyone else got the beta working on the P3P, or found a way to solve the issues that I have experienced?

Regards,

Nick

Same hardware setup here, but I can’t even get my P3P to connect to the Pix4D capture app (Beta 2.0.5).  Was working flawlessly before the update.

 

-David

I also have the same setup with the same issue. The message on the screen is ‘Please switch on the drone’s wifi range extender and camera. Wait 10 seconds. If that does not work press Wifi Settings to connect manually’. There is no Wifi Settings button and when i check my wifi networks on my phone there is nothing to connect to. Please Advise. Thank you.

Dave

Same as Dave. Same error and same conditions. Have a Samsung Galaxy S6. 2.04 worked no problem but since the update we haven’t been able to do any work. We were standing in front of clients and we’re unable to fly. Very embarrassing, and at this point very costly. Please let us know as soon as you can provide a solution.

I should have also stated that I have tried and have had the same issues with both a Galaxy S6 and an LG G-pad 8.3x. 

Hi All,

About the connection problem with the Phantom 3, the WiFi connection is not needed with the Phantom 3 you should a USB cable to connect the phone to the remote controller. The WiFi connection is only used with the Phantom 2 Vision+.

If you have message about the WiFi connection and range extender:

  • Make sure to select the appropriate drone in the settings of the app: Go Settings > Drone type for this app and select the appropriate drone.

  • If you selected the appropriate drone and you still have the error message. It might be that there is a bug in the app and we have to investigate further. In the meanwhile that we find a solution, you can revert back to the 2.0.4. You can download the version 2.0.4 using this link:

https://dl.dropboxusercontent.com/u/18350968/index.html# 

Uninstall the beta on your phone and open the above file on your phone and it will install the version 2.0.4.

We will post update about the version 2.0.5 as soon as we know more about this issue.

We are sorry for any inconvenience.

Best regards,

Thanks for the info. In my case, I was using a Phantom 3 Pro via USB with the correct hardware selected in the app, and experienced the problems.

Regards

Nick

The below works every time with my P3P

Keenan Newton Wednesday at 11:00
@Everyone

I know I am going against Jonas’ suggestion of taking off in “F”, but don’t do it. I don’t think the problem is specific to the capture app, because I had similar issues with the DJI Go app. When trying to take off in “F”, when you try to start the rotors, they immediately shutdown 70% of the time. Then a few times, the craft took off immediately and started to fly in a random direction. I will admit I have only experienced this with the Phantom 3 Pro.

In short, I have consistently been able to take off in P mode, hover then flip the switch to F.

Here are the steps I have gone through with success each time.

Unplug the USB cable from the controller
Go to the Application Manager of the Android device
Find the DJI Go App and click the force stop button
Find the Capture App, if the force stop button is enabled, click it.
Start Capture App
Plug in the USB cable into the controller
You may be prompted to start the DJI Go App, Cancel it. ( If the DJI Go App starts you will need to re-do steps 1-6 )
Define Your mission as you see fit
Start the mission
Make sure you are in P mode
Start the rotors
Hover 10 ft (3 m) above the ground
Flip the switch to “F”
Click through the screens until you get to the checklist.
Ignore the battery check. (If you can’t Ignore, make sure in the settings of the Capture App, that you are in Advanced mode)
At your own risk Ignore the mission size if necessary
Click and hold take off for 3 seconds.
This is what works for me every time on both the Inspire 1 and Phantom 3 Pro

@ Keenan

 

Have had exactly the same experience with the P3 Advanced. When the DJI app wants to launch click cancel. If it does launch you will have to restart  your controller. then select the the capture app and you should have no issues.

I have also found that if you try to start the rotors with the switch in “F” position it shut down immediately. It also does not connect to the “ground station” or upload the mission. 

Take off in “P” and flick the switch to “F” while hovering a meter or to from the ground, all check boxes should turn green within a few seconds. then hold the take off button and you should have no issues.

I confirm that after going to a new site and restarting the app / controller I got the app to work ok. I took off in P, then switched to F and started the app which then took over and successfully acquired the images

 

Nick

Awesome! Thanks Keenan for that suggestion.

2.0.5 has a new version of the SDK, and some things have changed there. I have reported some bugs already, and I hope to have them fixed in the next version of the SDK. 

And of course, we try to improve Capture, too. Not everything comes from the SDK, but it is sometimes really difficult to tell =).

I can confirm that with 2.0.5 things are finicky.

But I can also confirm that the “Keenan Newton Wednesday at 11:00” instructions above work every time, if followed precisely.

To do multiple missions I had to force close Capture and Go and restart those instructions for each mission.

(DJI Go silently and mysteriously restarted itself in the background - “Force Close” was once again available after each mission)

I also spent a lot of time over the past couple of days. Here are my observations:

2.04 works perfect with P3A using my Xperia Z4 tablet.

2.07 on Z4 tablet no go, asking for wifi while USB is connected as if it was P2. When I click on different drones, app crashes.

2.07 works with samsung s5 phone and my asus tablet though…

I am very puzzled as it looks like the update made a change that is tablet specific. I would love to get the Z4 to work with 2.07! Mission planning on a phone is not so convenient. 

If anyone has any idea why some tablets dropped the connections past 2.04, please let me know! I am so keen to use the z4 for pix4d capture. It is already such a great tablet for the DJI go! Hopefully we’ll get to the bottom of it.

Quite a few bugs were reported recently. Let’s see how it goes when 2.0.8 is released! In the meantime, let me know if you get some more insights about your crashes!

I had initial success with the beta 2.04 but it auto updates to 2.07 which does not recognize the phan 3 advanced. Can anyone tell me how to stop the upgrade? Also are you using the dji Mesh for processing?

 

Hi Peter,

To stop the automatic updates you need to disable an option in the settings of your phone. Have a look at this article:

http://www.pcadvisor.co.uk/how-to/google-android/stop-android-apps-automatically-updating-3489674/ 

Make sure also to try the beta 2.0.8. Have a look on our dedicated forum post for the beta version 2.0.8:

https://community.pix4d.com/t/4838 

Best regards.

Hello

I use the Pix4D capture app Version 2.0.8

I tried the procedure as described by " Vertical Aspect Support"
I went carefully through all 17 steps. I used two different Android-Devices (Samsung Smartphone Galaxy Active with Android 5.0.1 and Samsung Tablet Galaxy Tab S2 with Android 5.0.2).

Always I got in the screens with the checklist the message “Ground station connection failed”. I can not find the reason for this message. Of course the Android-Device is connected by USB-Cable the the controller and the communication between the two works!

Can you give some hints, what I could do to be successfull?

Thank you

 

Jean-Marie

Hi 

when is the non beta app coming out?

Hi all

I recently bought an Inspire 1 Pro (with a Zenmuse X5 instead of the X3) and I went through all the pain described here too, and more. For me it’s good to hear that you have the same issues with the “normal” I1 and the Phantom 3, since Pix4D doesn’t support the I1 Pro at all.

Let’s briefly recap what I observed:

  1. Capture crashes very often, during mission setup, after mission setup and even after conducting a mission. It then restarts automatically but, speaking for my equipment, it never reconnects properly. I always have to stop, disconnect, etc., etc. - exactly the way Vertical Aspect Support described.

  2. The up- and downlink with Capture doesn’t work reliable, often I cannot upload a mission, often I cannot see the #satellites, etc. Today I had to retry the upload about 10 times until it suddenly worked.

  3. Beware of switching to “F”-mode while on the ground. I did so to upload the mission, then switched back to “P” for takeoff and to “F” again while hovering. All the check marks now appeared green, so I pressed then button for 3 seconds, the drone icon moved up but the drone didn’t go into waypoint mode. Instead, nothing happened at all. It took me many hours to find out. Why does it make a difference, if I switch to “F” and back to “P” while on the ground? If Capture cannot handle this, why are all the checks marked as OK, then?

  4. During waypoint flights, the I1 navigates very abrupt. I would prefer much smoother turns (aka adaptive turns, in DJI terminology).

  5. With the I1 Pro, the focal length is not properly taken into account, which I must somehow accept, since this model/camera is unfortunately not supported. With a 12mm (24mm equivalent) wide-angle lens I only get 75% forward lap instead of 90% - that’s just not enough.

  6. With the I1 Pro, the camera control doesn’t work well, exposure sometimes freaks out, it happens that some images are taken with much faster shutter speeds (e.g. 1/4000 instead of 1/320 sec).

  7. Android tablets (I used a Motorola Nexus 6 and a hp Slate Pro 8) are tricky when it comes to USB-connectability. You end up stopping apps and restarting, disconnecting USB cables and reconnecting, etc. - exactly as described in this thread. Of course this is not Pix4D’s fault.

The way things currently work, I cannot use my I1 Pro for mapping missions at all, unfortunately. Reliability is just not given.

I’m surprised, since Pix4D’s main product, Pix4Dmapper, is an excellent piece of software. I have rarely seen such a good application, extremely powerful, absolutely great. And support for Pix4Dmapper excels every other company, IMHO.

I’ve been having all the problems outlines above with Phantom 3 Advanced with the latest version of Capture (as 0f 21.02.2016) and rolled back to version 2.0.5 (using the link above for version 2.0.4 which in fact downloads version 2.0.5).

Very frustrating, I was so excited to see the Pix4d Mapping PC application but just wasted a morning trting to get this Capture App to work. Surely Pix4D can’t expect everyone to roll back their technology to the obsolete Phantom 2, the Phantom 4 is due out soon…