Support Website Contact Support Blog

Version 2.08: Could not fetch media list from drone

Hi I am having problems connecting the capture app to my drone. I am on the latest firmware for my phantom 3 and using V2.08. It actually worked a couple of times with this setup but then it started to fail uploading the mission to the drone. In one of the support posts it specified that DJI GO should not be running in the background as this can create a conflict, the problem is if I quit DJI go then I get the following error message:

Could not fetch media list from drone

From another support post it looks like it is trying to connect to the drone over wifi rather than USB, im not sure what is going on. So my questions are:

  • Should DJI GO be running in the background?
  • Does this error message mean it is trying to connect via wifi?

Any help would be greatly appreciated and thanks for making this fantastic app!

Hi Jonathan,

This error message, it means that the connection with the drone is not successful.
To solve this problem, we recommend that you unplug the USB cable, close Pix4Dcapture, re-plug the USB cable, and restart our app.

If the application is asking to connect to Wi-Fi, it means that there is a connection problem.
The error message is not specific to the Phantom 3 drone. Actually the phone connects to the remote controller through the USB cable and then the remote controller communicates with the drone through DJI wireless network.

The DJI GO app should not be running in the background. Note that it is launched automatically when the USB cable is plugged. Once you have connected the USB cable, check that the DJI GO app is not running.

We hope this will help you in taking full advantage of Pix4Dcapture possibilities.

Best regards,

Hi, the go app automatically opening was the problem. Every time I reinserted the USB it opened it in the background. I needed to remove it as the default app in the application manager and it worked, Thanks for your help!