Support Website Contact Support Blog

Phantom 3 Pro (P3P) grid mission error

hello,
i am on the beta program, Everything is up to date, but still always get an error when i try to lunch a grid mission.
“failed to upload ground station task to drone”

i have read that a solution for the problem is not upgrading to the 1.4.1 version (to late for that)
a second solution will be when you relies the next app upgrade 2.3.2.
is there another solution? manually?
thanks

Hi Lior,

Do you still encounter these problems with Pix4Dmapper Capture (2.0.8) and your P3P?

Hello Support

 

I have the same error. Pix4Dmapper Capture is 2.0.8 and the firmware of my P3P is the latest.

How I do fix that? 

Thanks. 

Hi Sebastian,

If the ground station is not connected, it is not possible to upload the mission on the drone and it is necessary that the drone is flying to have the ground station connected. So you should first make the drone take off and then the other checks should turn green. Sometimes it helps to take off first before arriving to the checklist.

Let us know if this solves the problem. Also note that Pix4Dcapture 2.0.8 is still beta for P3P drones, this is why it might be unstable depending on the Android device and hardware version.

Best regards,

I am having the exact same problem for the last week. I am flying a Phantom 3 Professional with Pix4D Mapper 2.0.8 and firmware v1.6.0040. Version 2.0.8 has worked for me (as long as my drone was in the air when it got to the checklist) on this drone with either my android tablet or phone. Today I spent an hour trying to get it to work. It successfully connected to the drone, the switch was in the F position and the drone was at a height of 8 metres when it went to the checklist. I tried it on my android tablet and phone. here are some additional step I tried:

  1. closing the DJI GO app
  2. restarting everything separately
  3. disconnecting from any local wifi network
  4. taking off from ground after checklist menu appears

No luck so far, if anyone has any luck, please let us know.