Support Website Contact Support Blog

P3 won't fly grid mission

Phantom 3 advance firmware V1.5.0030 

Capture Beta  Release 2.0.8

Samsung GT-N5110 tablet

Android version 4.4.2

I have tried numerous times and always have the same results,The capture App connects to my P3  all the check list items are checked and ready to fly. I launch the drone to get it flying hold the launch button on the tablet…the little plane on the screen moves to the top I get the grid screen but my P3 just hovers at what ever level I have launched it to. I have complete control of the drone,the camera does not point down even though I set it up to do that in  pre- mission set up.Though I can do that while it hovers above my head. I have flown the P3 without a hitch before but can not after the upgrade. I not sure what changed either in my drone or in the two firmware up grades. I can fly free missions,I can fly it with the DJI GO app,I have uninstalled both programs and reinstalled them,I have tried Capture without the dji go installed,I have switched from my tablet to my Droid Razor and still no grid mission. I feel there is something that is not letting my P3 go into autopilot. I can send the log file of a non flight mission…I have a lot of them. any light that could be shed on this issue would be helpful.

Thank you in advance

Gary

 

Hi, 

I had exactly the same problem and I managed to fix it by having the drone in the air before going to the checklist screen. I was hopping  between the dji go app and pix4dmapper when I discovered this. Even though the box ticks when I take off in the checklist screen it refused to fly the mission but if the box was already ticked on the checklist, it would! Let me know if you have any luck with this approach,

Thanks I will try this today…The thing that is so puzzling about this is I have flew for at least a month before this problem occurred.

Thanks it worked!!! I flew three missions with this work around.

That is great news, I am also glad to hear it is a bug as this is my first time using pix4d mapper and I would prefer to take off after the checklist is complete!

 

I had the same issue and came up with the same solution unintentionally.

I have exactly the same issue after latest firmware update. I will try the work around and keep posted.

I had the same issue, though I made everything regarding to the advices that can be read here in the forum. When I checked the MC Settings in DJI Go I found, that Distance Limit was On and MFD was 30 m. I turned DL and Beginner mode off, then exited from DJI Go, and closed it. After this Capture app worked well. I have P3P fw 1.6.40, Go app is 2.6.0, RC is 1.5.70, Capture is 2.0.8. Tablet is a Lenovo A5500, Android 4.4.2. I have only one issue, the live image is not displayed in Capture app when running on the Lenovo. But on my Samsung Galaxy S4 mini the live image displayed. The Samsung has Android 4.4.2 too. For me the system worked well when the mode swith was on “F” position when I started Capture app. It worked well also when it was on “P”, and switched to “F” just when the checklist appeared. I lifted the P3P to 5-10 meters manually when the Grid Mission message displayed.

Workarounds are all good…yay…but for the price of Pix4D I don’t want workarounds…I want it to work.   I tried my first mission today.  Planned it…Check.  Loaded it…Check.  Preflight check boxes…All green for go.  Hit launch button.  .   .    .  My Samsung S5 screen told me the mission was happening…although my drone icon didn’t move nor did my drone.   I waited a few minutes…nothing.  I finally aborted the mission.  Got an ‘Aborting Mission’ message for about 5 minutes (I was scared if I killed it I’d end up with a flyaway.)  App wouldn’t respond.  In the end I did a Forced Stop on the Pix4D app.   My drone is a P3S.  Works fine with DJI Go and when I did a point of interest flight and postprocessed the images I manually took I got fairly good (not excellent) 3d mapping.   Does anyone know if this was the same problem discussed above and if so, any idea when Pix4D are planning on fixing it???  I am thinking I’d like to buy…I mean rent… the software but for $3.5K + USD/year…I need to know it will work when I need it to.

 

Well, to be fair, the app is actually free. I use it with several different SFM applications. I had a problem with it recently where it recorded video instead of images. that was caused by my phantom firmware version requiring an upgrade.

The app is free but I consider it part of the package that is far from free.  I understand the cost of dev on this type of software and have no issues with paying for a licence…but then it has to work.  I am about to try again today…maybe I didn’t hold down the start button long enough???(although I gave it about 54 seconds).  I didn’t watch the icon rise …I will try in about 1/2 hour…hopefully that is the issue.  Any other insights into what may have failed will be well appreciated.

Ok…seems to have flown ok.  I noticed heavy electro-magnetic interference where I was flying (strange out in the middle of a large forest???Maybe geological??)  Would this affect Pix4d mission launch?  Maybe a safety setting.   DJI Go told me to fly with caution.