Support Website Contact Support Blog

Cannot upload mission to drone

I am flying P3P with latest app version. All proceeds well with preflight checklist except for uploading mission to drone. It appears to attempt it (hourglass icon) but then X’s out. I attempted numerous cancels and re-start and rebooting entirely. No dice. I see with the new app release it states:

Sometimes the mission cannot be uploaded (in the preflight checklist). Solution: Hit “cancel” and to start the mission again.

Again, I’ve attempted this multiple times. Can anyone else or Pix4D speak to this issue and progress on correcting?

I have the same issue. 

I’m flying P3P latest firmware and pix4d capture 2.0.8

 

Hi,

I just encountered a similar problem and saw they recently answered here
I have not tried yet but will go back soon on the filed to test…

Has anyone had any luck getting this working? In the other thread they mention it must be connected to ground station, do they mean DJI GO must be running?

I have issues with the app connecting to my P3 advanced. I recently updated the firmware today and downloaded the app today so I presume the are the latest versions. they need to upgrade the app

 

Hi all,

Regarding the problem with the mission that is not uploaded to the drone, sometimes it takes a bit long to send the mission details to the drone through DJI SDK (what allows the communication between the two). It could also be that the takeoff check list is not refreshed so the error remains and prevents you to start but the mission is indeed uploaded.

We would suggest to try the following:

  • Press Cancel in the takeoff checklist, and then Next again, it will refresh the status.
  • Cancel the mission, and slightly adjust the grid, e.g. the size, in order to force the app to upload the mission again.
  • Restart the mission, meaning close the app, disconnect the mobile device, switch off the remote controller and the drone.
  • Uninstall Pix4Dcapture and reinstall the app.

We have just released a new official Android version of Pix4Dcapture (3.0.1).
These are the release notes: https://support.pix4d.com/hc/en-us/articles/210447423

Our developers have added some features and fixed several bugs.
If you wish and have time to give it a try, we would be glad to read your feedback.

Regards,

Yo tengo el mismo problema, todo sale ok. menos la carga de la misión.

1 Like

I am flying Inspire 1 pro (x5 camera) and iPad mini 4.  I am new to Pix4dcapture.  I just downloaded the latest app version and my firmware is up to date.

Allok with the preflight checklist except for uploading mission to drone. Not orange, it just stagnate with the hourglass and does not complete.  

I have tried cancelling out and reloading, remaking a new mission, rebooting, getting the drone in the air and hitting start (maps made easy requires this).  Prettymuch everything mentioned in the response from Julie above.  Frustrating because the clock is running on my 15-day trial and am not able to test it out.

 

Any thoughts?

 

@Marco and @Stuart

We are aware of the fact that sometimes the mission loads quickly and sometimes very slow. It depends on many factor such as if camera is still syncing or doing something else. Sometimes we are just waiting on SDK answer and we just can’t influence it.

At the moment we recommend you to proceed with basic checks.
This article helps users to troubleshoot app issues in most cases.

Best,

I’ve did all the recommendations many times and it still will not upload mission. It is very frustrating. I’m trying to perform mapping for an important industrial corporation. We have several Pix4D licenses. This bug is killing my project. If not resolved we will be moving to a new mapping vendor. 

Is there a work around to the sdk issue?

i’m us iPad with inspire 1 wit z3 camera.

i’ve rebooted many time, uninstalled and reinstalled software,but same results.

tried small projects of every type, still no upload.

crazy software!

1 Like

Hi Kelly,

I think the issue you are encountering may be related to the Z3 camera.  The Pix4Dcapture application supports the DJI Inspire 1 with an X3, X5 and XT camera, but does not list the Z3 camera.  The Pix4Dcapture application is helpful to automate the flight and data capture process, but that is contingent on the software knowing the Focal length of the camera and as the Z3 zooms, these values  would change.

Best Wishes,

Aaron.

Flying with P3P latest firmware, latest app.
“Unable to upload mission to drone” error occurs frequently.

For us, setting flight altitude at 50m or above RESOLVES the issue.
Not sure why that occurs. Can you please help with any idea on why we have such a behavior?
To achieve ground poin density under 2cm/px we have to fly manually in free flight mode, but it’s obviously not an ideal solution.
Any help?

Thanks a lot!

Lorenzo

HI Lorenzo,

The issue may have to due with the number of waypoints that your mission would require.  I believe the P3P has a limit of ~100 waypoints, and if you are flying at a low altitude, the number of images/waypoints in your mission may exceed its hardware capabilities.

Hola

Ayer hice una plan de vuelo, pero estuve casi por tres horas ajustando los parámetros para que por fin la misión se cargara en el drone. Creo que el tema es relacionado con altura pase de 50 mts a 70 mts, pero no quería sacrificar calidad de imagen. sin embargo creo que la configuración debe cambiarse desde fabrica con una nueva actualización, por que es una aspecto que quita mucho tiempo y descarga las baterías. Y el tema es que no alcanzaba ni a las 2 hectáreas de recorrido.  Equipo Phatom 4, Iphone 6 plus. 

 

Gracias.

Wilmer

Hola Wilmer,

¿Está utilizando el modo rápido (fast) o seguro (safe) para capturar imágenes?

El comportamiento que usted describe puede ocurrir de vez en cuando. En caso de comportamiento inesperado, siempre recomendamos seguir nuestros pasos básicos de chequeo y resolución de problemas descritos en este artículo. Resolverá la mayoría de los problemas que se puedan encontrar.
Recomendamos especialmente reiniciar la misión desde cero. Para hacerlo, cierre la aplicación, desconecte el cable del dispositivo móvil, apague el control remoto y el dron. A continuación, encienda el drone y el control, vuelva a conectar el cable USB y abra Pix4Dcapture.

Saludos