Support Website Contact Support Blog

New DJI activation process to fly with Pix4Dcapture

Hello Pix4Dcapture users,

We just released an update to our Pix4Dcapture app to support the new DJI activation process that will be rolled out over the weekend. Upgrading is necessary to be able to fly DJI drones.

Make sure to update your apps:

  • Android: Pix4Dcapture 3.8.3 AND Ctrl+DJI 1.6.1.
  • iOS: Pix4Dcapture 2.1.0.

Please use the forum posts below to comment:

Pix4D Support Team

Android and DJI drones

Several users have crashes of the app when using devices running Android 4.4 or using x86 architecture for the processor. Our developers are currently investigating but it seems related to the minimum OS version DJI supports on Android.

For now it seems like upgrading the SDK (developing tools to allow mobile apps to fly the drone) is necessary to have these issues solved. Our developers are working on integrating it.

In the meantime, we suggest to use another device or previous versions of Pix4Dcapture and Ctrl+DJI. However, given the new DJI protocol to activate a drone to fly with a third-party application, it might not work.

  1. Download the .apk files: click here.
  2. Uninstall current versions on the device.
  3. Copy the .apk files to the internal storage of the device and install the apps, both Pix4Dcapture and Ctrl+DJI.
  4. Log in DJI GO (4) and connect to the drone to activate it.
  5. Force quit DJI GO (4).
  6. Open Pix4Dcapture and start a mission from scratch.

We will post update under this thread once we have a better understanding of the situation.

Issue fixed in version 3.8.7 released on October 16, 2017.