Support Website Contact Support Blog

Ctrl + dji stopped

 I have this problem with the app, please can you help me so that does not happen? It is urgent, my tablet uses is Android 7.0 operating system.

 

Thanks

Hi Giovanni,

This issue can be related to several reasons.
Would it be possible for you to tell:

  • What drone you are using?
  • Are you updated with the latest versions and latest drone firmware?
  • When does this error occur? When starting the application or when going through the takeoff checklist for example?

Here are the main reasons. Note that few users are also reporting that the same error occurs with the Phantom 3 standard in some cases but the root cause has not been found yet. A post exists on this topic here.

Case 1 - Hardware incompatibility

In the past, compatibility issues have been raised by Android users about the model of the mobile device and the running Android OS version. Hardware can vary a lot when running Android OS and it is impossible to support all different device configurations. Issues seem to occur especially with devices having x86 architecture and running Android version 6.x.

Solution : Consider updating the Android OS version of the mobile device or trying another device.


Case 2 - Default camera removed with DJI Matrice or Inspire drones

The bug arises with the Android latest versions of Pix4Dcapture (4.3.0) and Ctrl+DJI (1.9). It has been reported to the developers who will fix it as soon as possible. Check the community post for updates.

Workaround : Use the iOS version of Pix4Dcapture. An advantage over Android is the ability to set a custom camera.


 Case**  3 - Using a mobile device with Android Pie V9.0**

Pix4Dcapture is not compatible with Android Pie V9.0, it will be fixed in a future release. We will communicate on this thread when solved.

Best,

Hello Gael,

answering your questions, from the first to the last.

I use the phantom 3 standard,

the updates of the ctrl + dji, pix4dcapture and my drone’s firmware are recent

and I’ll tell you my problem:

When my drone is connected, I can fly it with the app dji go, but if I want to make a photogrammetric flight, when I open the ctrl + dji it does not connect and that’s where I get the message “ctrl + dji stopped”, and not I can use the pix4dcapture, I tried to open the pix4dcapture directly but anyway it does not work, I’ve read several comments on that problem, and I’ve done everything you recommend and nothing, still with the same problem the app does not work, before It worked, I think that with the new updates of the app, I miss something, if it works with previous versions, because I check it on another cell phone, and I also think that it only fails with the phantom 3 standard, because I could fly a Mavic Pro and I did not have any inconvenient, and for the operating system I do not think it’s the problem I have the Andriod 7.0

Hello Giovanni,

Thank you for the detailed description.
Few users are reporting the issue you are describing with the Phantom 3 Standard. We have tried to reproduce the issue using several mobile devices with several Android versions and testing two different Phantom 3 Standard without any success so far.

We are still investigating what can be the root cause of it and it seems to be related to the mobile device itself and to some permissions issue.

I would suggest you try to reinstall DJI GO and check that all the permissions have been granted when installing it. So as Pix4Dcapture and Ctrl+DJI.

I will let you know when we have some update or if we need more information from your side to troubleshoot.

Best,

Hello Giovanni,

What Android device are you using?

Did you have the chance to check the permissions in Ctrl+DJI, Pix4Dcapture and DJI GO?
You can tap Settings --> Apps --> Pix4Dcapture and check the permissions.
While in DJI GO, can you check in Advanced if Write systems settings is set to Yes?

Also, did you install the applications from the google store or you installed them by another way on your mobile device?

Best,

1 Like

The operating system of my phone is Android 8.1 Oreo, my phone is a Moto G5 plus, it was just updated a few days ago, and I checked all the permissions of the three applications and everything is fine, the applications were downloaded from the Google Play Store , maybe with this new update of Andriod work the Ctrl + Dji and Pix4dcapture, but I need to check it, the problem of Ctrl + dji had it with the Android 7.0.

Hi Giovanni,

Thank you for your feedback. We are still investigating what can be the root cause of those crashes. I will let you know when we have some update.

Best,

Ok, Gael, thank you.

Hi Giovanni,

A user reported on this thread that he was able to connect again to his Phantom 3 Standard using Pix4Dcapture with the latest versions (V4.4.1 and V1.9.3 for Ctrl+DJI). The fact that it integrates the latest DJI SDK may have solved the issue.
Let me know if it can work for you.

Best,

Hi, Gael.

 

I updated the applications of pix4dcapture and ctrl + dji with the versions that you recommended, but, the ctrl + dji app does not recognize the drone, it only says

“unknown Aircraft”, and I can not use the pix4dcapture.  What I can do?

Hi Giovanni,

I would suggest you to all along the basic checks and troubleshooting article. It may solve the issue encountered, it might take several tries to get the connection with your drone.

I would also recommend to do the following procedures if the isse persist:

Caution

The two procedures below may imply data loss so we recommend making a backup if there are important data saved. Connect the mobile device and copy the Pix4D folder (Local Storage > Device storage > Pix4D) to your computer.

1. Clear data and clear cache memory of the application

  1. Open the Settings application on the Android device.
  2. Scroll the list and tap Apps, Applications or Manage apps.
  3. (optional) On certain devices like Samsung, tap Application Manager.
  4. Scroll the list to find the application.
  5. From the list, tap Storage.
  6. Tap CLEAR DATA and CLEAR CACHE.

2. Re-install Ctrl+Plugin and Pix4Dcapture from scratch

  1. Uninstall Pix4Dcapture and Ctrl+Plugin.
  2. Connect the device to a computer and navigate to Local Storage > Device storage > Pix4D.
  3. Delete the content of all folders.
  4. Delete the Pix4D folder.
  5. Re-install the latest version of Pix4Dcapture and Ctrl+Plugin.
  6. (optional) Place the backup content back into the Pix4D folder to restore data.

Also, if possible, I would suggest you try another mobile device to see if it can solve the issue.

Best,