Support Website Contact Support Blog

CTRL+DJI unfortunately has stopped

Hello, I,ve installed CTRL+DJI and pix4dmapper on several tabletts using Android 4.4.2 and the latest 4.4.3 on NEXUS 7. On all three tabletts I got the same error message “unfortunately CTRL+DJI has stopped” and this message is repeated short after quit the message with the “ok” button. Thus pix4dmapper cannot be used.

M.B.

Hi Manfred,

The issue you are pointing at is commented here in this post:
https://community.pix4d.com/t/3844

I want to use the trial version, to evaluate the purchase, but I can’t even take images with android.

with iPhone (5s) the problem is that after the flight, images are never downloaded…

When will the error be fixed?

Thank yo

Some users are facing similar issues where the drones flies but then stops taking pictures. If you can send us the log files to using the request form, that would help this investigation.

More info about how to extract the log files: https://support.pix4d.com/hc/en-us/articles/215281483

How do I send them?

Using the request form to contact support: https://support.pix4d.com/hc/en-us/articles/hc/en-us/requests/new

Thank you :) Sent

My problem is similar after downloading trial.  Downloaded pix4dcapture, opened it and picked my drone (mavic pro), when i chose activate, it said I needed Ctrl + DJI for things to work, fine…downloaded that, closed the pix4capture app, restarted capture… let the infinate, “Unfortunately, Ctrl + DJI has stopped.” loop begin.

I am guessing there is no chance this will get fixed before my 15 day trial is up when this thread started in early July?  I must be missing something.

Hi Keith,

To make a fresh start after downloading and installing Ctrl+DJI, I would suggest that you force stop Pix4Dcapture.
If you need information about how to proceed: https://support.pix4d.com/hc/en-us/articles/209626486

Let me know if it does not help.

No combination of open, closed and forced stop installations mattered. 

“Unfortunately, Ctrl + DJI has stopped.” continues at every iteration.

I am Android 4.4.2, for what it is worth.  

Is there an escalation department.   I really want this software to work.

10 days left on my free trial and counting.

EDIT: The comment has been edited because it contained offensive language. Additional rude language from your part will not be tolerated and will result in a ban from the Community. Thank you for your understanding.

@Keith
As mentioned in previous comments, the Android version that you are using is the problem.
You will find more information here.

@Julie - I understand many of these issues related to the “Unfortunately, Ctrl + DJI has stopped” have been addressed in previous releases; however, I am experiencing the same behavior on my Google Pixel 2 XL (running Android 9.0 Pie). Prior to the OS update, the Pix4d software worked just fine - after the OS release, Pix4dCapture is now unusable. The mobile device had previously been used, without issue, to run Pix4Dcapture.

Is this new (but old) issue known by the Pix4D team and are they working on a fix?

Thank you.

Hi Christopher,

Thank you for sharing your experience with us.
Currently, Pix4Dcapture is not compatible with Android Pie 9.0 hence the issue you are encountering.

The developer’s team is looking for a solution to the problem and it will be fixed in a future release.
I would advise you to follow this threadwhich is dedicated to this particular issue. We will communicate on it when the bug will be solved.
In the meantime, there is no other workaround than using a mobile device running with a previous Android version.

Thank you for your understanding,
Best,

Hi Gaël,
Running with a previous Android version does not seems to be enough cause I have.exactly the same issue with my Android Marshmallow 6.0.1.Do you provide somewhere a kind of compatibility table with min-max version ?
Best regards,
Loïc

Hi Loïc,

In the past, compatibility issues have been raised by Android users about the model of the mobile device and the running Android OS version. Hardware can vary a lot when running Android OS and it is impossible to support all different device configurations. Issues seem to occur especially with devices having x86 architecture and running Android version 6.x.
What mobile device do you use?

When you are downloading the app from the store, the minimum Android version you need to have installed is written in the additional information:

If possible, I would suggest you:

  • To upgrade the Android version running on your mobile device to see if it might solve the issue. 
  • To try another Android or iOS mobile device.

Best,

Hi Gaël,
Thanks for the answer. My mobile is currently a Nexus 5 (LG) with Android 6.x.
I will try soon with a more recent mobile on Android 8.0
Best regards.