Ctrl+DJI refusing to work

I have used both my tablet (Samsung Galaxy Tab S7) and phone (Samsung Galaxy S10e) multiple times over the past several months to fly sites using PIX4Dcapture. I tried two days ago and I could not get a connection to the UAV (DJI P4 Pro v2) using either one. I tried all the usual tricks to no avail.

What I am noticing is when I try to open Ctrl+DJI directly, the opening screen shows up for about a half-second, then dissappears and the app never opens. It does show up in the running apps, but when you select it from that screen, it exhibits the same behavior as on a fresh start-up (i.e. doesn’t open).

My tablet says it’s running Android 12.0 and says it was updated to T878USQU2CULC on January 21st. My phone also says it is running Android 12.0 and says it was updated to G970USQU6HULD ON January 19th.

I’m suspecting that these Android update have messed up the Pix4D software but don’t know for sure. Can anyone help? I’m pretty much stuck until I get this figured out.

1 Like

Hi,

Unfortunately we are not offering support for the free PIX4Dcapture app, if you are waiting for us to give a solution. Let’s wait if other customer had the same issue and can say something about it.

I would recommend you to read our knowledge base https://support.pix4d.com/hc/en-us/categories/200300675

Best.

We are having the same issue. Ctrl DJI is not opening and allowing us to use Pix 4d. We have a fleet of drones grounded at the moment. This all happened with the Android 12 update. We are not going to be paying for our continued subscription if this continues without results. We have already been in contact with Pix4d experts about this issue. We have not received any information stating that they are looking into this.

I am also having this issue. I am being forced to another program from lost revenue.

Having the same problem! Since the latest Update on my Samsung device, the app crashes immediately after start.
Sadly totally unusable at the moment!

Hi there. I have the same problem. I can’t use your software after the update on Android 12. The plugin CTRL+DJI is crashing. I can’t do any survey right now and I have to wait until you will fix it.
And you (Jose Arnaudo) are able to write that you don’t give this problem attention? You should then. We paying for the service which is not working. Is that ok? I don’t think so. So, please would be nice to start taking care of this problem, how about that. Thank you.

Hello @michal.bursik, Sorry to hear about it. Can you please make a short video and send us the log file so that we can look into it. Just for your information, Pix4Dcapture is a free app and you don’t need to purchase a license to use it. This is available for everyone to use for free.
As you know, most the Pix4D’s software is image acquisition app agnostic. That means PIX4Dmapper, PIX4Dcloud, PIX4Dmatic, PIX4Dreact, and PIX4Dfields can process images taken virtually from any application(image acquisition app) as long as they are of good quality and overlap. So, you can use any other image acquisition app and still process the images using our Photogrammetry software such as PIX4Dmapper and so on.
If our image acquisition app is not supported, I would suggest you to go through the below support article on Which image acquisition app can I use with Pix4D’s software?

We understand that Pix4D Capture is free, and for that reason you choose to not officially support it. But we pay a very dear premium for PIX4D Mapper. Part of the appeal of Mapper is it is a turn-key solution for our mapping needs. It feels like a cop-out to not support Pix4D capture when it is intended to be part of the Pix4D workflow for capturing and processing data.
You should consider putting your effort into keeping Pix4D Capture up to date with current versions of Android rather than re-directing your customers to 3rd-party image acquisition apps. Basically you’re saying “my software sucks, go use someone else’s that actually works.” Not a good message.

1 Like

Very well said @Nadir9. You said exactly what I had on my tongue. Is that a really big problem for a company like this to fix it if you can see that customers complaining about that @Kapil_Khanal?

Hello @michal.bursik & @Nadir9, Thank you for your feedback. Currently, we are aware of the users having the issue so we are collecting information to resolve the issue as soon as possible. We will let you know once we find the cause and the solution for it.
Until that time, you can either use PIX4Dscan for the android device if the drone is supported, the iOS version of PIX4Dcapture, if you have any iOS device, or go through the below, support article on Which image acquisition app can I use with Pix4D’s software?

1 Like

Good morning @Kapil_Khanal, that’s great news. I’m looking forward that soon you will fix the problem. It took only 15 days to get attention from this company about this problem. I believe that you can also improve the communication with the customers in the future and respond early than after 15 days since was this topic post. Have a nice day.

Hello All, PIX4Dcapture is now working on Android 12 with the beta version of Ctrl+DJI (1.9.10). To download the beta version of Ctrl+DJI, go to the below community post.

1 Like

Good morning, thanks for the news. I will download and try. I let you know if everything running smoothly.

1 Like

Hello @michal.bursik, Please let us know how it goes?

Hi @Kapil_Khanal, I can say that working without a problem so far. I attended two flights today. I hope, that you will keep the software updated all the time for us, that we can avoid any future problems. Have a nice day.

@michal.bursik Thank you for the update. I am glad it is working for you.