Support Website Contact Support Blog

[Android] Pix4Dcapture will not connect to drone even though Ctrl+DJI is connected

Hi. Ctrl+DJI shows correct connection to Inspire 1. However when I enter a mission (old or new) I get a message “Do not switch off drone/Pictures can be viewed from the project manager”. At this point I can edit the mission but cannot connect to drone so I can’t start mission.  Ctrl+DJI continues to show connected state, GPS position, etc.

The problem started while editing a flight plan. I was connected to drone fine, then I had to disconnect phone for a while, and after connecting phone again it will not work.

I have tried deleting Pix4D folder and reinstalling pix4d capture and ctrl+dji but message still shows.

Hi Alonso,

It seems like a communication conflict happens here.
Is the behavior described happening for all type of missions?

I would suggest you to go through this following steps by order:

- Make sure that you have the latest versions of drone firmware, Ctrl+DJI plugin, and Pix4Dcapture version.

  • Restart from scratch respectively the drone, the controller, Ctrl+DJI, and Pix4Dcapture.

- Clear data and clear cache memory of the application. Make sure to backup the Pix4D folder first. 

  1. Open the Settings app on the Android device.
  2. Scroll the list and tap  Apps, ** Applications  or  Manage apps**.
  3. (optional) On certain devices like Samsung, tap  Application Manager.
  4. Scroll the list to find the app.
    5. From the list, tap Storage.
  5. Tap CLEAR DATA and CLEAR CACHE.

- Reinstall Ctrl+DJI and Pix4Dcapture from scratch:

  1. Back up your data if needed by making a backup of Pix4D folder (Local Storage > Device storage > Pix4D).
  2. Uninstall Pix4Dcapture and Ctrl+DJI.
  3. Navigate to Local Storage > Device storage > Pix4D.
  4. Delete all of the folder’s contents (don’t forget to backup it first if necessary).
  5. Delete the Pix4D folder.
  6. Reinstall the latest version of Pix4Dcapture and Ctrl+DJI
  7. Launch Pix4Dcapture and log in
  8. Optional: force stop Pix4Dcapture and place the mission folders that you saved in a different location back into the Pix4D folder. Relaunch Pix4Dcapture to verify that the missions are available.

If not solving the issue please consider to:

  • Try another mobile device if possible.
  • Format your SD card or try another one.

Best,

Hi, Ctrl+dji cannot connect to my phantom 4 after the latest firmware update 1.9.7, previously using 1.9.6 there were no problems. after changing back to 1.9.6 it can be connected normally, but for pix4d capture it doesn’t connect to my Phantom 4.

Hi,

In a first time, as this behavior was not reported to us so fa. I would suggest going all along the basic checks and troubleshooting steps described on our article online.

I would especially check the following steps to be able to connect to your drone.
Also, you can try unistalling both applications and reinstalling them if the issue is not solved.
Note that to be able to run properly Pix4Dcapture, you need to run Android V7.0 or above on your mobile device.

Best regards,