Support Website Contact Support Blog

Problems connecting Pix4D Ctrl+Dji with Phantom 4

I often face problems to connect Ctrl+Dji app with Phantom 4. Works very bad in conjuction with Pix4d capture app. 

Sometimes Pix4d capture app struck after starting mission. 

 

Hi Dinesh,

What do you mean by the app struck? Could you be more specific and perhaps describe what happens in the app and with the drone just after the mission has started? Screenshots could help if you have any.

We only support the latest version so make sure first you have installed Pix4Dcapture 3.1.0 on Android.
Could you confirm the latest firmware is installed on the drone. This can be checked with the manufacturer’s app.

If you have any doubts on the optimal workflow to follow with the app, you can refer to our getting started (Android):
https://support.pix4d.com/hc/en-us/articles/202557269

Regards,

I had a similar issue today with a Phantom 3 Pro. I was trying to fly a mission that i had pre-loaded “offline” of three similar sized grids. I flew the first Grid on my first battery then when I changed over batteries I could not connect back to the drone to “resume” the flights.

The Ctrl+DJI app said I was still connected and in a mission. So I tried to go back in and “Resume” the flights but couldn’t move on to next Grid. In short I had to turn everything off, “Force Stop” the Ctrl+DJI app and then hope that it would reconnect, which it didn’t. i Wasted a lot of time and Battery trying different combinations of starting and restarting, tuning things on and off in different orders and nothing worked, all the while the conditions were getting worse and the winds were picking up in speed.

What finally worked by fluke was moving away from my original “home point” a fair way and trying again. It then turned on and connected so I flew my second grid/Battery. Again changed the battery and the ap said still in mission, so i had to do the whole process again, abut moved to a new home point hoping this was the issue. It wasn’t.

I had to turn everything on and off do restarts all over again and somehow it connected again. 

Not a happy chappy. It makes me nervous to use in the future as the trust of what used to work once, doesnt now.

Bottom line, this used to work fine in older versions, now it is just hit and miss as to what is going to go wrong next.

 

Hi Anthony,

Regarding the resume workflow on Android we have some recommendations in this article:
https://support.pix4d.com/hc/en-us/articles/217115826

Usually the flight is automatically resumed if the mission is aborted with the Abort button or when taking over manual control (switch the P.A.F. button of the remote controller). If you tap Save , the resumed part of the flight is expected to be saved and you can fly it later if you go to the Project List to open it. If you want to fly the resumed part right after changing the battery and the app screen is still showing the Map View, you can directly tap Start.

Also perhaps this problem is related to the firmware. Which one do you have installed on the P3P?
Is it the latest v1.10.90 released on 29.11.2016?

Regards,

Olá, não estou conseguindo conectar o Drone (Phanton 3 advanced) com o Ctrl+DJI a parece a seguinte mensagem “For first time registratin, app should be connected to internet” sendo que eu estou com internet sim. o RC esta conectado ao Drone perfeitamente pós no app da DJI GO o Drone funciona normal. 

Hi Pedro,

There is no Portuguese-speaking agent in our Support Team, so we will reply in english. We hope you could take advantage of translator if needed.

Are you able to log in Pix4Dcapture (not Ctrl+DJI)? It seems like you already have a Pix4D account so there is no need to register. Could you perhaps share a screenshot so that we better understand the issue?

If you have any doubts on the optimal workflow with the app, you can refer to our getting started:
https://support.pix4d.com/hc/en-us/articles/202557269

I have a problem when aI try to connect a Samsung Galaxy tab A (Android 5.1.1)  with my phantom 4 using ctrl+dji.

I launch the application and a message of “For first time registration, app should be connected to internet”   appears. I have already a pix4d account and I have checked several times that I have internet connection. Also, I have tried with different accounts. I hope you can help me with this problem. Thanks. 

Hi,

The workflow is to go through Pix4Dcapture to connect to the drone, not through Ctrl+DI.
If you have any doubts on the optimal workflow with the app, you can refer to our getting started:
https://support.pix4d.com/hc/en-us/articles/202557269

The problem for me was the Tab A in the end. I took it to a technician who connected straight away with his iPhone. I then tried with my Galaxy S4 which worked. So i then found a phone at work that no one was using any more and it is all good now. Connects every time without fail. Using a Vodafone Smart 8. Only down side is the tiny screen. The work flow is right that is shown. It is the tablet from my experience that doesnt connect.

Hello Julie

I can not get my mavic to run a mission and take pictures. It ran one mission but took 0 pics. I have DJI go 4 , ctrl DI and your capture program on . what is the order to run them in . is ctrl di needed ?

 

Hi Jon,

Could you please confirm:

  • The latest versions of both Pix4Dcapture and Ctrl+DJI are installed. DJI+Ctrl is necessary to connect to the drone but the use of this plugin is silent in the sense that you should only interact with Pix4Dcapture.
    Please see our getting started for help: https://support.pix4d.com/hc/en-us/articles/202557269
  • The latest DJI GO 4 version is installed.
  • Latest firmware is installed on the drone and the remote controller.

Also:

  • Did you try to log in the DJI app and connect to the drone before opening Pix4Dcapture?
  • Did you make sure DJI GO is not running in the background when starting with Pix4Dcapture?
    https://support.pix4d.com/hc/en-us/articles/209626486
  • Could you try to reformat the SD card using DJI GO (4)?
  • Could you try to open Ctrl+DJI first and then tap Open Pix4Dcapture?

Could you perhaps give more information about your device (brand, model, OS version) and the type of mission (grid, double grid, etc.)?

mavic pro. totally updated. Should I run DJI go 4 before? Just trying to do curcle then double grid… when I do ge it to go on mission its blurry and never makes the picture taking noise… just black 1/2 seconds…

 

1 Like

The issue is related to the DJI SDK and can happen for some reason. Our developers are already working on integrating SDK 4.2 while now Pix4Dcapture relies on 4.1. The new version is expected to be more stable and we should release an app update within a week approximately. We believe this will fix the issue.

Julie

So does that explain why I could get this to work with my old p3S last week but not the new Mavic?

 

Could I please  get an extension on my trial as I know it is about to expire. I want to get the hang of this before I buy anything. 

Thanks

 

SDK 4 is used by all DJI drones except Phantom 2 Vision(+). However, the SDK of the Mavic Pro is not the same as the SDK of the Phantom 3 Standard, which explains why you faced different issues. Pix4Dcapture does not need a Pix4D license to be used, you can fly it with any Pix4D account.

Yes but to send it to the cloud for processing once the SDK thing is fixed  my time will be up. 

Julie,

I just sent a support request, but I believe we are having the same issue connecting to the DJI Phantom 4 Advance.  The app worked on my phone on Thursday when we received the DJI.  A co-worker applied the updates to the DJI and has the current version of the apps (Capture & DJI Go 4).    Today he took it out to fly and project and the Capture App keeps crashing.   If you have a better estimate of when the update of the application will be released, please let me know.  I only have a short window to fly and process the data, before I’ll have to return the drone and will have to continue using the Phantom 3 Pro. 

I have the same problem as Ashley David Gracia Barrera and Jon Pop. Any news Julie?

@Luke

We did not test the compatibility with DJI Phantom 4 Advanced at the moment. You can try to use DJI Phantom 4 Advanced by selecting Phantom 4 Pro in the app. Perhaps this is why it is not working. Feel free to share your feedback in a new post thread. Although the recommendations as above still apply :).

@Milos

There will be an Android and iOS release of new apps supporting JDI SDK 4.2 probably next week. We believe it will solve several hot issues.