Support Website Contact Support Blog

Latest DJI firmware, login, and Pix4D capture

I updated the firmware on my Phantom 4 Pro to the latest version which requires login thru the DJI app before it lets the drone get out of beginner mode. It no longer works with the Pix4D capture app. The Ctrl DJI app can connect to the aircraft and read telemetry data, but when I try to start a mission it always fails on the “Uploading mission to aircraft” step. I assume this is because of the firmware update (?). 

Is there going to be a fix for this in future versions? I can downgrade firmware, for now, to make this work but will be a big issue going forward.

I use Pix4d Capture on Android devices. The DJI Go 4 app is not installed on the same device as Pix4D per recommendations on this forum by Pix4D.

Hi Blake,

We are not aware of the issue you are facing and we believe that is not related to the firmware update. If Ctrl+DJI is connected it means the drone is successfully connected.
Check this article if you are still facing issues with uploading the mission: https://support.pix4d.com/hc/en-us/articles/217985263

To clarify, the manufacturer’s app can be installed on the device used to fly Pix4Dcapture app. Users just need to make sure that both of them are not running at the same time. 
How to force quit an app: https://support.pix4d.com/hc/en-us/articles/209626486 
Make sure no default app is selected: https://support.pix4d.com/hc/en-us/articles/212300043

Cheers,

I’ll retry adding the DJI GO app to the same device as Pix4D as you recommend and try flying with new firmware. However, I replicated this issue with two Phantom 4 Pro’s following the firmware update (i.e. the mission could not be uploaded to the drone). By taking both drones back to the previous firmware, the issue was alleviated and I was able to use Pix4D again. Thus, I do believe there is a change related to the new firmware preventing autopilot capabilities.

I had the exact same issue after latest firmware update. Pix4D capture plans and uploads as expected, but within 5 seconds of launch, about 2 seconds into the air, the drone looses flight control and pitches towards the ground. Reverting to the previous firmware fixed the issue, BUT my drone now has issues with DJIg4o as it is not up to date.

1 Like

Estou temdo o mesmo problema. o Ctrl+DJI parou de funcionar depois da última atualização da DJI.

@Roberto: there is a community post that could be related to the issue you are facing: https://community.pix4d.com/t/3844

Best,

To admit my bad; after updating firmware, and controller and recalibrating, everything is AOK with Pix4D Capture and my P4P.

We are glad you could fix the issue :). Thank you for lettings us know!

Hi Pix4D Support,

This seems to not be an issue for me anymore. Not sure what changed, which is frustrating, but at least its working again.

Hi All,

I brought 2 Phantom 4pro and everything worked fine until I updated the firmware on the Phantoms as required by the DJI Go App. Now I can still plan my missions and go through all the pre-flight checks without any problems as previously, but the Phantom will not start up to fly the mission. Luckily I had my Phantom 3 pros as a backup!

@Michael,

at this point, we recommend making sure that the firmware update of the drone and the controller was successful. Also, perform the calibration in DJI GO app if needed.

More information about basic troubleshooting can be found here: https://support.pix4d.com/hc/en-us/articles/115004119343

Best,

Hi,

I checked that the firmware update on the Drone was successful and it was, so no problem there. I tried Drone Deploy as well and to my surprise it did not work as well, so I come to the conclusion that is must be a problem with DJI. The strange part is that the Phantom works with Litchie!

Kind Regards

Michael