Support Website Contact Support Blog

Pix 4d mapper and the m1 Mac

Has anyone had success processing mapper projects with the Mac silicon m1 using cross platform software

Hi,

Welcome to Pix4D Community!

Have you tried to use Bootcamp in your Mac silicon m1? Unfortunately, Mac Systems using parallel is not supported, as they use a virtual Operating System which may give problems with the display of the rayCloud and may fail to process.

Otherwise, we have a stable PIX4Dmapper version for Mac OS X 10.11 - El Capitan or 10.12 - Sierra that you could explore. Please for more information, you could refer to the following articles:

macOS / Windows XP / Linux / Remote access / Parallel processing

I hope you find this information useful. Don’t hesitate to contact us if you still have questions or concerns.

Have a nice day,

Best regards

Heydi thanks for your reply
A recent review suggests the silicon m1 Mac max processor in the 16inch Mac Pro is not compatible with boot camp , just wondered if anyone had had success running pix 4d mapper using macs inbuilt emulation Rosetta
Regards kerry

Hi Kerry,

Until now, we don’t have information if any client tried to use inbuilt emulation Rosetta. At Pix4D we recently use M1 Mac for testing our PIX4Dmapper Desktop version for Mac and it works fine.

Maybe you could have a better chance with Parallel Desktop emulator software, as it is suggested in this article How to install Windows on M1 Macs - the super-easy way - 9to5Mac

Please if you tried let us know how is it goes. This information is valuable for us.

Best regards