Support Website Contact Support Blog

Phantom 4 Advanced

Hi , 

When the application for the phantom 4 advanced ??

Hi Lucio,

We did not test the compatibility with DJI Phantom 4 Advanced at the moment. You can try to use DJI Phantom 4 Advanced by selecting Phantom 4 Pro in the app. If you wish to give it a try, we will be glad to read your feedback.

I tested the DJI Phantom 4 Advanced and the  Pix4d app crashes every time you try to set up a job.

Could you first confirm you have installed:

  • Android Pix4Dcapture 3.8.3 and plugin app (Ctrl+DJI) 1.6.1 (last release 29.06.2017).
  • iOS Pix4Dcapture 2.1.0 (last release 30.06.2017).
  • Latest DJI GO (4) app.
  • Latest drone firmware.

Do you make sure DJI GO (4) is not running in the background (force stop) when Pix4Dcapture is being used?
Could you try to open Ctrl+DJI first and then tap Open Pix4Dcapture?

We would also suggest to restart from scratch (close the app, disconnect the mobile device, switch off the remote controller and the drone). This solves the problem in most cases.

Julie, so are you saying the App works on the Advanced just like the pro?

Why has this not been added to the Pix4Dcapture App yet?

Thx

We are have the same issue with our P4 advance on iPad mini 2. We are running the latest updates on the apps and drone firmware.
The app starts ok, but when I try to pan to current position the screen freezes and closes. It seems to work fine on a colleague’s android phone. Is there any information on a new update being available?

Hi,

I have tried the Phantom 4 Advanced in Pix4DCapture. the first time it only flew 1 of the 8 lines and then hovered until I took over and landed. The second time it reverted back to the settings for a Phantom 4 Standard, so I went into the settings again, changed it to the pro, and restarted the app. After these 2 issues, it completed the mission (skipped 1 photo), so was more or less a success.

Will you be adding the Phantom 4 Advanced to the Pix4DCapture app? It seems like it is mostly the same as the Phantom 4 Pro, but it would be great to have it supported properly, and having these issues mentioned above removed.

Hi Daniel,

Thank you for sharing your experience in the community!
I am glad to hear the mission was successful!

There is little difference between the Phantom 4 Pro and Advanced but if we add it to the list of supported drones, it means we have to test it extensively. For now, it is not in the pipeline and we do not have the drone here, but I reported your need to our developers.

Hey, this matter is resolved yet ?

Tell me some one pls !

 

Hi Nguyễn,

Do you face any special issue when using Pix4Dcapture? I would suggest to check the recommendations of this article for an optimal experience: https://support.pix4d.com/hc/en-us/articles/115004119343

For now, there is no update but we continuously report feedback from our users.
Supporting the Phantom 4 Advanced (i.e. having it in the list of drones you can select) is not among the highest priorities at the moment.

Any news will be posted in this thread, just click the Follow button at the top of the post to be notified.

Hello, I bought the Phantom 4 advance for its good features and I am surprised that for pix4d it is not important to support this drone in pix4dcapture. Can you explain why?

Hi Simon,

Do you face any specific issue? I would recommend to check my link above.

Exactly that is my problem. I can not say anything because I can not use Phantom 4 advance in Pix4d capture. Since July they are asking for it

I have reported the need for testing this drone to make it supported by Pix4Dcapture. Thank you for your interest Simon.

Any update on Phantom 4 Advanced support? The latest version still doesn’t seem to work with the P4A.

@Tariq, there are no updates about the Phantom 4 Advanced support. Could you tell us which platform (Android or iOS) do you use?

Did you select Phantom 4 Pro in the general settings of the app?

Best,

@Blaz I am using android latest version. Selecting “Phantom 4 Pro” doesn’t help, it goes back to “Phantom 4” as soon as I leave the settings menu.

Although it does work only when the area is very small and not far way, but it won’t take off area like 300 x 300 m. This is not the case with P4 or P4P, which function properly.

Any solution to this will be much appreciated.

Thanks

Same as @Tariq on android latest version. Selecting “Phantom 4 Pro” doesn’t help, it goes back to “Phantom 4” as soon as I leave the settings menu.

Hi Tariq and Adriano, Thank you for sharing your experiences. Unfortunately, the Phantom 4 Advanced is still not officially supported by Pix4Dcapture. However, your concerns have been shared with the developer’s team as part of the ongoing development of Pix4Dcapture.

In the meantime, please consider testing your Phantom 4 Advanced’s compatibility with another third party mission planning application. At the same time, you can keep the latest version of Pix4Dcapture installed on your mobile device to ensure that you receive update notifications when a new version is available.

Note that Pix4D’s image processing engine supports images that are captured with any third party flight planning application as long as you have sufficient image overlap for your project. so please feel free to fly with any application that fits your needs.

best,

1 Like

I used Pix4D demo with my Phantom 3 Standard wifi based bird.  I liked it and planned to start out 3D modeling by purchasing your $50 a month plan and upgrade to a Phantom 4.  The Phantom 4 Advanced is a great bird with everything a P4 Pro has except side sensors and minor things like 5.8 wifi band option.  The $300 price difference is not a small thing.

I purchased a Phantom 4 Advanced primarily with the intent of 3D Modeling.  It works great and flies LITCHI waypoint missions perfectly.

Was I disappointed VERY MUCH to find out the 4 Advanced won’t work with Pix4DCapture and your customer service answer is just guess.  You don’t even know if using the P4 Pro would work, though you suggested it, even after MANY users said it won’t work.

I will take my business elsewhere until you show more professionalism (as a company) and respond to these kinds of issues.

This has to be a minor problem that you should be able to fix if you would only take the time to look at it.