Support Website Contact Support Blog

[iOS, Android] supporting Phantom 4 Pro+ Version 2 (P4P+ V2)

Actuall DJI offer a open PH4pro+ system. In real the system doesnt work with pix4dcapture (djigo4 rules the USB). DJI support wrote me thats a problem of the manufacturer of the Thirdparty product. Do you have idea when you support the PH4pro+?

Hi Wenninger,

About the Phantom 4 Pro + V2 (P4P+ V2), as you can see on our supported drones webpage, it is not supported by Pix4Dcapture at the moment and it is not in the pipeline to support it.

it has been reported that the workaround that is valid to make work quite nicely P4P+ V1 is not working anymore with P4P+ V2.

We have not tested the compatibility of this drone with Pix4Dcapture and then every feedback/info from users is welcome.

Best,

Hi,

Are there any news about wheather it’s possible - and if yes how- to connect the drone with the P4P+ V2.0 controller ? We installed Ctrl+DJI and Pix4Dcapture on the RC (with integrated display) with the .apk workaround but it seems impossible to connect it with the drone. After pressing “start” in the pix4Dcapture App the “next” button is disabled. Switching on and off the RC and drone and forcing DJI Go app to stop doesn’t change anything. Any help is appreciated, otherwise we will send it back and get a P4P V2.0. 

Hi Kathrin,

We did not get any feedback from users so far telling us that they could make it work.
From a Pix4Dcapture point of view, we do not support the P4P+ V2 and it is not in our pipeline for the moment to develop the support for it.

If you would like to use Pix4Dcapture to make automated flight plan with your drone, then I would suggest you to get a Phantom 4 Pro V2 or any other drones that are supported by our application. (see the supported drone webpage here)

Best,

I was just checking to see if there has been update or workaround for the P4P+ V2 to use with Pix4D capture yet?

Hi TJ,

The status is still the same for the P4P+ V2 and there is no workarounds we are aware of.

Best,

Hi TJ,

I just found out about this workaround by patrickza:

https://forum.dji.com/forum.php?mod=viewthread&tid=173583&page=1#pid1680205

or     https://www.youtube.com/watch?v=DcLbVHZLdrU

Maybe this might be helpful for you. I can’t say if it works, as I returned the P4P+ V2 before knowing about this workaround. Would be nice if you leave a comment if it worked out for you.

This workaround does NOT work as it only works on v1