Support Website Contact Support Blog

Pix4DCapture for Phantom 4 Pro v2.0 crashing on iPhone

Hi all,
I got a Phantom 4 Pro v2.0 Plus. However, I changed and was able to connect the drone itself to a Phantom 4 Pro v2.0 remote controller (GL 300L).

I had DJI Go 4 and Pix4DCapture on my iPhone 12 Pro Max, linked with the RC. The DJI Go worked just fine with this new RC. However, the Pix4DCapture kept crashing/exiting after the check list even though I did force close DJI Go 4.

My understanding is that the only difference between Phantom 4 Pro v2.0 Plus and without Plus is the RC. If so, with the GL 300L, I assume that Pix4DCapture should recognize this drone system as Phantom 4 Pro v2.0 (no plus), which is a supported model. So, I am wondering why the software kept crashing? Please give me some insights.

Thanks.

So, I have just realized that pix4Dcapture worked on my Samsung Tab A (android) but not with my iPhones with iOS 14.4.x. Can someone (or pix4Dcapture team) please confirm me if pix4Dcapture works with iOS 14.4.x so that I don’t have to look for solutions to use my iPhone?
Thanks.

I am having the same issue on my iphone X and Phantom 4 pro. I had completed a mission before and it worked fine. When I tried Pix4DCapture on a new mission, the app crashes after the checklist is complete. I tried it on Android too and the same thing…The little icon shows the aircraft taking off but it just sites there and doesn’t start. I took off manually and then started the mission hoping once the aircraft is hovering, it will initiate the flight plan but it didn’t. I checked with the support and they are not offering support on Pix4DCapture…so I guess my next step is to just manually fly and capture the photos.