Support Website Contact Support Blog

Drone Aborts Mission

I Like many other frustrated users are experiencing the following ongoing problems.

(1) Drone Starts mission, does one line of photos then hovers, saying drone is going to land

(2) Then the drone flies completely in the wrong direction to the home point set and nearly gets lost

(3) Mission abort does not work and have to manually fly drone back.

I have yet to complete a successful mission from over 12 attempts.

 

The software used to work???

 

Now its just crap

What drone? Ios or Android? Firmware updated?

I’ve done more than 500 missions with my Phantom 3pro, and I had problems with only 3because I didn’t closed DJI app…

Did you close de DJI app before starting Pix4DCapture?

 

Thanks

Its Phantom 3 Pro

IOS Platform

DJI app closed

Latest firmware

Really? Thats strange…

Try to unistall app and then reinstall. Maybe it will solve your problems.

Have you tried to fly the drone with the DJI Go app and it had normal behavior?

had the same problem today. reinstalled the software, changed the pattern for the mission. nothing worked. the drone never stopped it slowed down to 0.5 ft/sec.

phantom 4 pro

ios platform

dji app opened ( close to airport )

latest firmware

 

@ James

A new release of Pix4Dcapture V3.3 has been done recently. Can you try if it works with it? Be also sure not to be in a No-Fly-Zone. I would suggest you also to do the followings when an unexpected behavior occurs as it may solve the issue:

  • Restart the mission from scratch. To do so, close and force quit the app, disconnect the mobile device, turn off the remote controller and the drone. Then respectively switch on the drone, then the remote controller and finally Pix4Dcapture. 
  • Make sure that the drone app is not running in the background.
    basic checks and troubleshooting.
  • (In DJI GO 4) check that everything is running fine. You should have a stable connection and the ability to takeoff and fly manually, to get the camera view and to take pictures.
  • (In DJI GO 4) make sure that no settings can prevent the mission to be done (Maximum altitude, beginners mode, …).

@ Randy,

Have you already been able to make Pix4Dcapture work properly at the location where you try to fly a mission?

It is interesting to notice that you are flying in a No-Fly-Zone, 
To be clear, the current status from Pix4D side is that we have not been able to practically test our application in DJI No-Fly-Zone. Then even if we were expecting our application to work, we can not confirm it and the latest information from a user is that any third-party application will not work properly even after having unlocked an NFZ.

My suggestion here would be to test Pix4Dcapture with your drone outside an NFZ.

I have flown in the same no fly zone many times after unlocking the drone with the dji app. Is there someway to roll bak the latest update and see if it is the problem ?

@ Randy: Do you use version V3.3 of Pix4Dcapture?
In a general way, we don’t provide the previous version of our application except to validate that something is actually wrong with the update. So far the behavior you are describing has not been reported.
DJI can change its policy in the No-Fly-Zone and as a third-party application, we will not be informed about that.

To diagnosis the issue you are experiencing, If you are flying with the exact same configuration as before, I would suggest you to try flying outside a No-Fly-Zone to see if the problem is related to that or not. Also, did you integrate a custom camera on the drone or you are flying with the default camera of the P4P?

Best,