Support Website Contact Support Blog

mission doesn't really start

i have a new problem (before everything was perfect).

When i start a new mission, each checking is green, the mission upload, no problem, then my drone go alone at the starrt point of the grid, then nothing happen, the drone stay at the start point, no message, only “on mission”

any help, thank you and sorry for my english

Hi Robert,

For optimal experience with Pix4Dcapture, we recommend to proceed with basic checks. This article helps users to troubleshoot app issues in most cases. If you have any doubts on the workflow with the app, you can refer to our getting started (AndroidiOS).

How long did you wait while the drone was hovering? You should try and wait for at least a minute for the mission to start.

Some users reported a similar issue on Android and iOS. We investigated several log files and could not find something explicit. There is nothing evident on the side of Pix4Dcapture that might prevent the drone from continuing the mission, even in case of poor connection. It seems that the issue is related to a miscommunication with the SDK of DJI. 
We recommend to check, in DJI GO (4), if the drone is correctly calibrated. If the issue persists try to restart the mission from scratch (quit the app, turn off/on the remote and the drone). 

Let me know it goes.

1 Like

I would get this when the camera wasn’t taking a picture or the feedback to the drone that a picture had been taken isn’t working (basically camera disconnected).  Pix4Dcapture waits to confirm a picture is taken and SD card, etc. ready.  Once they updated to a custom camera in iOS it can be setup to fly without these camera checks so doing that could help you troubleshoot.

thanks a lot for your help, now it works

 

@sim I gather you had a similar issue and I’m glad you found your answer on the Community :slight_smile: Do not hesitate to share your experience so that it might benefit other members of the Community.

Cheers!

I am having similar issues. I switch between the DJI camera on my Phantom 3 Pro and a Parrot Sequoia. When I start a mission with the DJI camera mounted on the drone, the app goes through the checklist as usual, then I start the mission and the drone takes off and goes to the mission altitude before immediately heading off to the start point and carrying out the mission. 

However, when I do the same process with the Parrot Sequoia, it goes through the checklist as usual and the drone takes off and goes to the mission altitude. At this point, it hovers for almost exactly 1 minute every time over the start point before going to the mission start point. Any suggestions?

@Matthew, did you have an opportunity to implement a custom camera profile in the app settings for Pix4Dcapture for iOS? Adam Jordan found that his drone would not hover for an extended period after he set up his camera’s custom profile in Pix4Dcapture’s app settings.

I have been using the Sequoia for a year now. The app used to have the default settings for the Sequoia in it so I used those and never had an issue with the drone hovering before starting the mission. When I did an update to the Capture app several months ago, it no longer appeared to have the Sequoia settings in it anymore. Took me a month to figure out that I had to add a new custom camera myself. Whenever I did that is when the drone starting hovering over the take off point for 60 seconds. It is pretty much exactly 60 seconds every time.

@Matthew, thank you for sharing additional information.

  1. My understanding is that your drone hovers for approximately 60 seconds above the home point at the mission’s height regardless of whether you enter a custom camera or select the drone’s stock camera in Pix4Dcapture’s app settings.  Is my understanding correct?

  2. You can find more detailed information about your comments regarding reduced amounts of image overlap that are reported by Pix4Dcapture at [iOS] Pix4Dcapture and Parrot Sequoia captures less overlap with custom camera settings.

My P3P only hovers when using the custom camera settings that I had to setup for the Sequoia. When I run it with the DJI camera with the default settings for P3P, it doesn’t hover at all. It gets to it’s altitude and immediately goes to the start point (whether it’s in polygon or grid mode). As I mentioned before, it seemed the app used to have the Sequoia settings already loaded into it, I would just need to select the camera. The app still didn’t control the camera which was expected and I worked around it. 

Hi Matthew,
The camera cannot be triggered by the app as it is not integrated to Pix4Dcapture. The camera can, however, take pictures by setting it to GPS (trigger based on location) or timer (trigger based on time-lapse) capturing mode, as long as the custom camera is defined in the general setting. 
As a side note, if the custom camera is not defined, and the default camera is removed, the preflight checklist cannot be passed and the drone will not take-off. 

Yes, that is correct. I have been using the timer capturing mode for the past year. The app appeared to drop the camera settings that were already loaded in it several months ago which was giving me fits and not letting the drone take off as you said because the checklist would never complete. Took me awhile to figure out I had load in the Sequoia settings in again.

The current issue I’m having is the checklist will complete and allow me to start the mission, but the drone won’t immediately go to the mission start point after takeoff. When I start a mission with the Sequoia onboard and the timer mode running on the Sequoia, and the custom camera settings defined in the app, the drone takes off and goes to the selected flight altitude and hovers for 60 seconds each time over the takeoff point. It’s like the mission wasn’t actually fully loaded or something else. It ends up using about 7-10% of the battery just hovering each time.

This only happens when using the Sequoia mounted onboard and the app is in custom camera settings. When using the P3P camera and the associated setting in the app, the drone gets to altitude and immediately goes to the start of the mission.

Thank you for your feedback, Matthew. It is indeed a behavior that has been seen by users and investigated on our side. It appears that it is related to the DJI SDK and unfortunately there is no way to change this behavior for the moment.

In the meanwhile, I would recommend you to remain updated with the drone firmware and Pix4Dcapture latest versions.

We would also encourage users to share their experiences and feedback about flying with the following configuration P3P / Sequoia custom camera / iOS

Has there been any work on this issue? As of July 2018, my drone was still hovering for a minute before going to the beginning of the mission. I am going to be doing a demo with the drone and Pix4D at a conference in October and it’s going to be odd to have the drone doing nothing at the beginning of each flight during the demo.

Hi Matthew,

At the moment, there are no updates on this topic. I would suggest you to remain updated with the latest drone firmware and to download and install the latest versions of our application. Indeed, from July 2018, Pix4Dcapture has evolved and for example, is now integrating DJI SDK 4.6 which might have fixed the issue.

Best,

Hello everyone!

Is there any update regarding this issue? I had many jobs in recent months and I think 1 minute hovering was so time and energy consuming. Moreover, Sequoia will take many useless images, since it is triggered by time interval (at least 30 images for 60 seconds hovering).

I have P4 and Sequoia attached as well, but it has no issue with 1 minute hovering

Hi Arif,

We do not have any updates about this issue. Is it possible for you to tell us if you are using the Android or iOS version of Pix4Dcapture?

Best,