Support Website Contact Support Blog

[Pix4Dcapture, P3P] Missions don't load and when it does, no pictures

Sept. 26 - 2017

Two P3P, two different iPhones (6S and 7S), one Ipad Mini 4, one Galaxy tablet - all of them with the latest firmware - all up to date.

A job that should be done in two days and I amnow in the second week of wasted efforts, because productivity has never been so low.

The issues:

  • More than half of the time, we set things up and during the checklist the mission never loads on the IOS;

  • If we do all the same with the Android, we pass the checklist, we hit start and the propellers never get started - no messages;

  • Then, sometimes, you do all the same again and … the drone takes off, however, when it does, half of the time is coming back with no pictures taken - none at all. Even although the app shows the camera symbol on the right spots and make the sound of the images being taken. No lost signal between the drone and the remote.

The flights are in an urban area, all around 13mins duration, 40m altitude, angle of the camera 65, fast mode for picture capture.

Any suggestions? Have anyone encountered the same issue in that consistent matter?

It all works fine if we take off with DJI Go for test.

 

 

 

 

 

Hi, 

Pix4Dcapture is not my specialty, but I found these two articles that show workarounds for the problems you describe: 

More specifically this part of the first article: 

"Sometimes there are some delays when sending the mission details from the app to the drone through the SDK (what allows the communication between the two). A time-out could prevent the mission from being completely uploaded. It is then suggested to try the following:

  1. Interrupt the mission.

1.1. If the drone is already is the air, tap  Abort  or take over manual control to land the drone.
1.2. If the drone did not take off, tap  Cancel  below the takeoff checklist pop-up if the mission upload failed.

  1. Restart the mission.

2.1. In the Map view, slightly adjust the flight plan, e.g. resize the grid. This will force the app to upload the mission details to the drone again since the flight plan was changed.
2.2. Tap  Start  and go through the wizard as previously.

  1. (optional) If the issue persists, start over the mission scratch, meaning close and force the app to stop, disconnect the mobile device, turn off the remote controller and the drone."

and this part of the second: 

“The SD card could require reformatting. Open the drone app, connect to the aircraft, and reformat the SD card using the corresponding option.”

Let us know if this or other solutions from the articles worked or if you found another solution. 

Pierangelo, thanks for the careful and detailed reply.

I have tried those approaches.

I would cancel or abort the mission and many times the mission would disappear.

I would go ahead and turn everything off and on again and replan the mission. The problem is that in some places I would go through this 5 times before being able to take off. Huge waste of time and also makes me quite insecure if I should be insisting or not on the flight as the app/drone seems to be having such a hard time.

The SD reformatting, the same thing - I would go on DJI GO and reformat the card, a hit and miss if I would get anything back at the end of the mission.

It remains to me quite a mystery. After, those two weeks of frustration, we suspended the project.

I have used Pix4D Capture in different sites with no problems, but that regions remains a big question mark to me. As of now, I am thinking there is something to do with the place.

However, I check the sensor, compass, signals, everything in DJI Go first and no problems, but Pix4D did not like that zip code.

 

 

Thais, glad to help!

Normally, retrying the upload from scratch should solve the issue. If the issue persists several times such as in your case, it could be that there is some interference. We had some feedback of users who had issues operating in areas with strong wireless networks or electrical pylons. Maybe that applies to where you flew your project and could explain the difficulties in starting the mission.

As for the images not being taken, a check you could make to see if the drone takes images is to switch from the map view to the camera view, then each time a picture is taken, the screen should blink.  

Also, this comment from Julie from another post should help explain the situation: https://community.pix4d.com/t/2910-Picture-capture-fail?page=2#community_comment_115004714086&gsc.tab=0