Support Website Contact Support Blog

[pix4dcapture] DJI Phantom 3 standard problem

 Hi everyone,

I’ve a problem with my P3Standard: I had used Capture few times with no problem, but it’s 2/3 that i could use only manual mission, because in circular, polygon or other, mapper upload the mission correctly, and then the Phantom:

  1. sometimes give Pix4d “internal error in upload” and it stay landed.

  2. sometimes appair “landed” on screen and it doesn’t start.

How I could do?

Thanks.

 

Hi Davide

For optimal use of Pix4Dcapture, we recommend proceeding with basic checks: https://support.pix4d.com/hc/en-us/articles/115004119343. This article helps users to troubleshoot app issues in most cases.

  1. From my understanding, the warning you are referring to is “mission cannot be started because of dji internal failure”. We are already investigating the cause of the error and we recommend uploading the mission multiple times and restart everything in between as we do not expect it to appear for all the missions. 

  2. Could you give us more information about the “Landed” status you see on the screen? Is the status visible after you have already flown a mission and landed the drone or does it appear even before starting the first mission? To troubleshoot the mission not starting, I would recommend you to check the article above.

Best,

Hi Blaz,

I’ve check all the basic info, and it’s all ok. Is not a no fly zone or other.

I’ve also read the other post: past week, the Phantom3 give me back this problem “mission cannot…” so I decided to fly in Free Mission (and it works). Last time I’ve tryed again, but there weren’t the same error, just the drone freezed and the “Landed” feedback on Pix4d BEFORE starting the first mission. Again, it will works on free mission.

Until now, I always use a Sony Xperia Z2 with Andorid 6, now I’ve bought a iPad and I will try with this and give you back a feedbak.

Thanks

To give you some insights, the Free Flight mission worked because it does not require to upload a mission (waypoints) to the drone before starting the automated image acquisition. On contrary, Free Flight operates without waypoints and solely relies on the current position of the drone in order to trigger the images. 

We do not expect the same warning on iOS version and I believe that you will be able to fly it without any issues. 

As mentioned, we are investigating the case and we will post updates in the “mission cannot be started because of dji internal failure”.

Hi,

with the new iPad it works well. Until there where some news, I use the Apple version. Thanks.

We just released a new Android version 4.2.2 in which the issue is solved.

I would recommend making sure that all the apps and firmware versions are up to date and try flying a mission again.