Support Website Contact Support Blog

[iOS] Phantom 3 pro and 4

I use the latest pix4d capture on android (galaxy s7). 

when it starts, the drones successfully go to the starting point of the grid mission but then it doesn’t move. 

I tested the app for phantom 3 pro and 4 but they showed same result.

so I happen to use an i-Phone and found out it worked well.

why is that?

Thanks

Best regards,

from a user in South Korea

Hi Hyoseong,

So far we can see one main reason. Sometimes there are some delays when sending the mission details to the drone through DJI SDK (what allows the communication between the two). A time-out could prevent the mission from being completely uploaded. We would suggest to try the following:

1.a. Click the Abort button to interrupt the mission or take over manual control to land the drone.
1.b. (alternatively) Cancel the mission meaning click Cancel in the takeoff checklist pop-up if the mission upload failed.
2. Restart the mission but slightly adjust the grid before, e.g. the size, in order to force the app to upload the mission details again.
3. (optional) If this does not work, restart the mission scratch, meaning close and force the app to stop, disconnect the mobile device, switch off the remote controller and the drone.

There are differences because the SDK is specific to each drone and to a platform, meaning that the Android SDK is not the same as the iOS SDK. Also from one mission to the other, many factors can affect the continuity of a flight this is why the problem can happen time to time. If you fly a new mission on Android, the problem might not arise.

In the meantime, I have sent you an email to test our latest app that is beta if you wish.

Regards,

I have the same problem… i have deleted the dji go app cause the software posted me a message that the dji go run on the backround but still the same problem.

the drone goes to the  start and loses the contact.  Ctrl+DJI saws me details of the drone. Hyoseong Lee did one of the solutions worked out?

buenos dias, yo tengo un drone phantom 3 standard, realizé un vuelo completo con pix4d capture, v3.1.0,excelente, luego preparé otra mision y sale un mensaje de “no coneccion al drone”, he probado de todo pero nada, y solo conecta con la aplicacion basica de DJI before P4, hice el vuelo con una Lenovo Phab 2.

Hay alguna solucion? o necesariamente tengo que usar iOS y Iphone?

gracias por la respuesta

 

@Vasilis, @Jorge

For optimal experience with Pix4Dcapture, we recommend to proceed with basic checks. This article helps users to troubleshoot app issues in most cases.

@Jorge
Make sure to have the latest version of our apps. If the issue remains, I suspect the Android device to be a problem. Are you able to fly with DJI GO? I would suggest that you try with another device.

Hi
Is the DJI Phantom 3 SE supported by Pix4Dcapture? Thanks

Hi Sebastian, I have reported your need. If you need to add more comments, please use the main thread about the Phantom 3 SE support here: https://community.pix4d.com/t/3229

Hi Julie;

Thank you for your quick answer.