Support Website Contact Support Blog

Pix4d Capture iOS - In no fly zone



I have the DJI Go app that is unlocked to allow flight in a no fly zone.

With my Phantom 3 airborne within the no fly zone (Using the DJI app) when i try to start a Grid mission through the Pix4d Capture app, the upload and tick boxes all go through fine but the app just comes up with mission finished and the drone doesn’t move.


Is there a fix?

Hi James,

We are not sure we understand. Are you using DJI GO and Pix4Dcapture at the same time? Usually we recommend to force DJI GO to stop because it should not be running at the same.

You had all checks green so you tapped Start but the drone did not move, is that correct?
Are you aware of the getting started procedure?

We usually recommend to make sure that:

  • The manufacturer’s app (DJI GO) is not running in the background especially after connecting the device to the drone. Also check that this app is not selected as the default app when connecting.
    (Android) If needed, force the app to stop, using the application manager of the device.
  • The appropriate drone is selected, please see: Settings of the app: Home screen > Settings > Drone type > …
  • The latest firmware is installed on the drone. Please check it with the manufacturer’s app.
  • The latest OS version is installed on the mobile device.


Hi I posted a Support request with Pix4D support and also with DJI in order to Fix this issue. We will lose a lot of quality in the sensing result when we start flying manually in a No Fly Zone. This is not an option.

At this point I have authorization until September 20, 2016 to fly in a military No-Fly Zone in order to capture data with Sequoia and to process in Pix4D.

I have received authorization from the Dutch Military Aviation Authority to fly with my Phantom 3 Professional (having a Dutch airworthiness certificate) in this No-Fly Zone.

DJI has provided me with the Unlock license for this zone until September 20, 2016.

Flying with the DJI Go App in this No Fly zone is working, however when I close DJI Go App and start Pix4D capture, the app will NOT download the waypoints to the Phantom 3P. This is probably because the unlock license is not activated any more (probably because the aircraft is stopped or the DJI Go  app is stopped) and therefore Pix4Dcapture gets the No Fly zone blocking info from the Phantom and therefore cannot continue with the fly sequence.

Pix4D should work with DJI to fix this issue because in countries like the Netherlands we have a lot of controlled airspace on top of agriculture locations.

Probably DJI has the key for the solution and that is that once that the No-Fly zone is unlocked in the Phantom by the DJI Go App, they should keep the unlock status ON in the aircraft until battery is switched off. In this case we can stop the DJI Go APP and start Pix4Dcapture to fly waypoints. DJI should make sure that the Pix4Dcapture app is then allowed to load in the waypoints and start the flying sequence.


Hi Rudy,

I also had this problem, and I don’t think it DJI Go App’s problem, DJI told me they decide to disable F mode when fly in NFZ, so basically there is no way our drone receive input waypoint and camera settings etc.

By the way did DJI sent you a customized DJI Go App to unlock NFZ? How are things working out for you?


Yes DJI give me a customized DJI Go APP where I can unlock the No-Fly Zone. By using this, the F-Mode is not working anymore and therefore we can only fly manual and cannot use Pix4Dcapture, DroneDeploy, Litchi, et cetera. This is unacceptable. We need constant fly path, height and speed in order to capture high quality images.

So for the present stage DJI is not working for me and I will start flying another vendors drone which support flying waypoints in No-Fly zones. For the time being DJI is from my shortlist.


Kind regards,



Thanks Rudy, that’s good to know, so what’s your alternative choice? We use inspire 1 all the time but when it comes to NFZ, we have to switch to manually fly and the result is very inconsistent, what’s your choice?




I’m going to test this one:


Awesome copter, good luck!