Support Website Contact Support Blog

Pix4dcapture (ios) - ChecklistCamera setting up

I tried to fly a mission today and pix4dcapture woudn’t continue after the checklist before the mission. 

Camera setting up had an hour glass to the side. I tried several times to turn off and on the drone, the remote controller and also the ios app. same error.


I tried the same using an Android phone the Camera setup was OK but no images were shown while doing the mission. I don’t know what could be the problem. In DJI GO 4 I can see the video as usual with no issues.


The last mission I flew was on 07/11 and had no issues, after that I didn’t do any upgrade on the drone’s firmware.


I’m using ios 12.1 iphone xs.Phantom 4 Pro


pix4dcapture version 4.2.0 (8)

Hi Javier,

Thank you for your feedback and details provided about the issue you encountered and the troubleshooting you have made.

The behavior you are describing has not been reported so far.
Can you detail what type of mission you were planning, the size of it, so as the flight height and overlap set? Also, were you trying to fly using the Safe or Fast mode to trigger picture?
Also, when it worked before, were you doing an acquisition with a mission that was similar?

In your case, I would suggest having a look at our basic checks and troubleshooting article.
From it, I would recommend you to have a special look at the following points, even if it worked using the Android version of Pix4Dcapture:

  • The area to fly is not a no-fly zone.

  • No interferences can occur in the location where you try to fly and the connection to the drone is stable.
    - The drone manufacturer’s app is not running in the background. Force quit if necessary: (Android, iOS) How to force quit an app

  • The drone’s camera and compass are calibrated.

  • No flight setting conflicts with the mission, including maximum altitude, beginner mode, geofences, etc.
    - Basic features in DJI GO 4 are working properly:

  • Manual takeoff and flying.

  • Live video feed of the camera.

  • Manual picture triggering.

  • Restart your mission from scratch. To do so, close and force quit the app, disconnect the cable from the mobile device, turn off the remote controller and the drone. Then switch on the drone and the controller, reconnect the USB cable and open Pix4Dcapture. 


I will try a new mission next week. The phone’s firmware was updated yesterday to iOS 12.1.1 I will check if there are any new firmwares for the drone and/or new pix4dcapture. The mission was done on a far without any airports in the vecinity and also have done missions on the same farm multiple times before.


I think one time also had this issue about the Camera Setting up and it was that I had to point the camera down 90 degrees, this time didn’t work. Is there any way I can submit any logs ?


Hi Javier,

In some cases, miscommunication between Pix4Dcapture and the drone can occur. Sometimes the SDK (programming tools for app development to interact with the drone) is not responsive and some delays affect the communication, which blocks the continuity of the mission.

Those one-time issues cannot be considered as bugs, and usually restarting from scratch will solve the unexpected behavior.
Before investigating some logs, let me know if it can work for you in your next tests and if the issue is persistent or reproducible as the P4P is the most used drone with Pix4Dcapture and that we had no feedback on similar issues.


Hello. I’m trying right now to enter the data for a new missing and besides the warnings for low battery and now enough satellites, which is ok since I’m on my apartment, the camera setting up clock is still the same. I uninstalled the app and installed it again. Now running ios 12.1.2. Same results.

Hi Javier,

If possible, I would suggest you to try the Android version of Pix4Dcapture to see if it can solve the issue?

I would suggest you focus on the following troubleshooting steps:

  • Be sure to be updated with the latest drone firmware.

  • Reinstall the drone manufacturer application

  • Check that the basic features in DJI GO 4 are working properly:

  • Manual takeoff and flying.

  • Live video feed of the camera.

  • Manual picture triggering.

  • Reinstall Pix4Dcapture from scratch:


The procedure below may imply data loss so we recommend to make a backup if there are important data saved. Connect the mobile device and use iTunes to backup files on your computer.

Re-install Pix4Dcapture from scratch

  1. Uninstall Pix4Dcapture. On your mobile device go to Settings > General > iPhone Storage > Pix4Dcapture > Delete App.
  2. Re-install the latest version of Pix4Dcapture.
  3. (optional) Place the backup content back into the Pix4D folder to restore data.


I’m having the same problem with a new iPhone 11 Pro. iOS 13.2 Pix4DCapture version 4.6.0(9)

You can see image from the camera while running the App.

Tried with Android on Asus Zenpad, Ctrl DJI v1.9.7, Pix4DCapture 4.6.0. I get camera setting ok, however when I select the camera no picture is shown, black screen.

I will fly the mission with dji go4 app then…

Hello Javier,

What kind of mission are you planning with iOS? What are your settings?

If you have some issues flying with Pix4Dcapture, we recommend going through the basic checks and troubleshooting steps. If properly followed, it will solve most of the issues that can be encountered by users.
Also restarting from scratch everything is usually quite efficient. Note that the drone camera may take a while to be ready/operational so I would recommend waiting a bit before going through the takeoff checklist after the drone is switched on.


Hello Gael, I went and flew the mission and when I was outside the message changed and it allowed the flight. I was going to post it on the forums later. As a suggestion, the dron still flies pointing to the mission direction after take off, wouldn’t it be better to fly pointing forward to take advantage of the ability to tilt the dron, in higher winds wouldn’t it be better?

hi Javier,

Glad to hear that you could make it work!
I will share your suggestion with the developer’s team as it as already been reported in the past. Note that it will not have any impact as the speed is not restricted when going to the first waypoint and the drone is able to balance itself properly with the wind for example. Note that we do not recommend to fly in windy conditions.