Support Website Contact Support Blog

Fail after new update !!!!

Today I went out for a job with my M600Pro and custom camera.

It was a simple 2D map which worked till now - before, the app triggered the DSLR and everything was fine.

But today, when choosing the M600pro and the custom camera, when trying to go to Settings and choose overlap and other stuff, there came out a blank page saying that the app cannot create parameters for this setup.

After switching everything on and off and choosing different cameras and then set my DSLR back, I got the setting page and could start the mission.

The app showed grey dots as if the camera took pictures, but the SD card was empty - no pictures.

What a dissapointment on site!!!

Went back to GS PRO and luckily everything worked well.

There is a bug and the Pix4D team should see what to do about it. And also the thing when you can’t make a Circular mission when having a non-DJI camera i s very annoying. 

Hi Dario,

“… before, the app triggered the DSLR and everything was fine.” 

With the custom camera, the app allows users to the camera parameters that are later used for calculating the overlap and the speed of the drone. It is not expected that the app will trigger a custom camera and it is necessary to set the triggering, e.g. triggering interval, in the settings. More HERE.

If the triggering was not set in the camera this could explain why no images were taken during the mission.

As for the “there came out a blank page saying that the app cannot create parameters for this setup” we would need more information to understand the issue. Do you maybe have some screenshots that you could share here?

Best,

 

Hi Blaž,

 

I would be almost 100% shure that the capture app triggered my DSLR before. But even if not, I don’t see a problem for the app to design it that way, other capture apps do the job.

Attached is the screen shot which comes out when you choose the M600pro with DSLR, both single and double grid.

 

Best regards

 

Indeed, the custom camera settings can be confusing and some users get the impression that Pix4Dcapture will trigger the custom camera automatically. We are already discussing this issue with our UX designers and considering more intuitive warnings about this. 

We are able to control the equipment (cameras, drones) that is included in the DJI, Parrot or Yuneec SDK. For the rest manual interaction is needed as we are technically limited to send instructions or commands. 

As for the “No settings available for this type of mission” issue.  At the moment there is no obvious reason why you experience this issue and we are also not able to reproduce it here in the office. As a side note, there are also no other users reporting this issue.

Could you please try to:

  • Upgrade the device to iOS 11.
  • Reinstall the Pix4Dcapture app

Best,

Hi,

I have exactly the same problem with a brand new phantom 4 pro v2.0 (updated firmware)

I got the “No settings available for this type of mission” message
It used to work fine for the first fly, and then I got this message … and impossible to get rid of it

I tried to restart app, IOS, drone … nothing works.
This message occurs with each kind of mission (polygon, 2d maps, 3d maps …)

I then tried another IOS device (Ipad Air)
It worked once, and I got exactly the same message then.

This is very annoying, because I can’t use pix4dcapture in any way … have to go back to GS pro … :-//

Is this issue known ?

Thanks

GP

Hi Greg,

Phantom 4 Pro V2.0 is not officially supported yet and then we do not encourage our users to use the Phantom 4 Pro v2.0 with Pix4Dcapture even if the integration of last DJI SDK on iOS allows it. 
As the development and testing for its support are still ongoing, you may encounter unexpected behavior when flying/using the app. My recommendation here would be to be patient just a little bit longer.
You can follow the main thread about P4P V2.0 support here.