Support Website Contact Support Blog

No camera view on iPad Mavic 2 Pro

Hi, I’m new to Pix and am having an issue. I am flying a Mavic 2 Pro with the latest firmware and using the Pix4D Capture app to fly my projects. The app is successfully flying the projects and taking the photos. My map view is showing up fine on my screen but I’m not seeing the view through the camera. When I fly with DJI Go4 I can see the camera view. My workflow is to turn on the controller (also on the latest firmware), connect it to my iPad Mini (latest IOS), turn on the drone and check all systems in DJI Go. Then I close out of the DJI app and open Pix4D Capture Again, map but no camera view. I’ve deleted and reinstalled Capture and since I’ve flown a couple of projects I’ve been through several power cycles on everything. Does anyone have a suggestion on how to solve this problem? Thanks in advance.


Hello Scott,

You should be able to have the camera view using the Mavic Pro 2 with the iOS version of Pix4Dcapture.

When something does not work properly, we recommend restarting from scratch.
To do so:

  1. Force quit Pix4Dcapture and DJI GO 4.
  2. Unplug the cable between the mobile device and the remote controller.  
  3. Turn off the remote controller and the drone. 
  4. Turn on the drone and the remote controller. 
  5. Plug the cable between the mobile device and the remote controller. 
  6. Run Pix4Dcapture.

Also, Sometimes the video view does not get updated when switching from DJI GO 4 to Pix4Dcapture, the problem should be solved by disconnecting and reconnecting the cable from the Remote Controller.


Thanks Gael. I’ve tried all that. I’m thinking it must be a DJI issue. 

DJI pushed me back to you. I’ve tried uninstalling and reinstalling Capture on my iPad. Is there any kind of setting I might be missing on the controller?

Hi Scott,

I tested it and was able to get the video feed without any issue. Normally, there are no specific settings to change. Are you using the original cable to plug the remote controller to the mobile device?
I would suggest you open Pix4Dcapture without opening DJI GO 4 first or to be sure that you force quit it. Once connected and that you can see the telemetry in Pix4Dcapture, you should be able to see the video feed by tapping on the small camera icon on the top right corner of the screen. If not unplug and replug the cable from the mobile device to the drone.

If the issue is persisting, I would suggest you, if possible, try another iOS mobile device to see if you can get the video feed and change back DJI GO 4 settings by default or even reinstall it.

Let me know if it can work for you.


Was this resolved i have the exact same issue.


I tried my Iphone X on another Mavic 2 Pro also using my cable and it worked on that one but it will still not work with mine.


I have both an IphoneX and an Iphone 6+ and neither show the camera view on Capture.  It will show using the DJI 4 app.


I am therefore assuming it is the controller having an issue with capture as i have tried each piece on another system and it worked fine.


Would be keen to hear if you found a solution.





The problem isn’t solved, but there is an effective and simple workaround. After you log into and out of DJI Go and then log into Pix4D Capture, pull the cable from your phone and plug it back in again before you fly. The camera feed shows up then. I believe Drone Deploy has the same issue, so who knows where the real bug is. 

By log out, do you mean close the program or do you actually mean log out/sign out from the software? I’m having the same issue and the work around isn’t doing it for me.

Have there there been any fixes for this? This is a very unfortunate bug to say the least…

Hi Jeff,

Can you precise me your configuration? (drone, camera, mobile device)?
Normally, if the camera view is not available, restarting everything from scratch as described in my comment of the 19/10/2018 should solve the issue.


Sure. I have a Mavic Pro 2 with the Hasselblad camera and I’m using an iPad mini. All are new. I should mention that the 1st person camera view works perfectly with DJI GO 4, DJI Ground Station Pro, and Litchi apps. 

You can only have one flight app open at a time. After you’ve logged in to DJI Go and made sure that all of the settings and firmware updates are good, close it. Then open Pix. Unplug and plug in your pad and that should do the trick. At least it does for me. Good luck. 

Hello all,

@Jeff: I would follow Scott’s recommendations here. That should solve the problem.

In a general way, as sometimes several components are communicating together, it might happen that conflicts happen but restarting properly from scratch should solve the issue. Also, make sure that DJI GO 4 is not running in the background.


Unfortunately, I’ve tried this with no luck. Regardless of which firmware version I am running, there is still no 1st person view. I’ve tried uninstalling and reinstalling Pix4Dcapture with no luck. And yes, all other apps are closed. 

What I’ve found is that I can use other peoples iPads or other devices on my Mavic gets the same result, no camera view. I can use my iPad mini to connect to other Mavic 2’s and I can see the camera display. Initially, this made me suspect that the culprit was my drone; however, using other apps (Litchi, GSP) I can see the camera view so this leads me to believe that the issue is with Pix4Dcapture app. 

On one occasion, I was able to get camera view to display on the screen when I switched the cord. I cycled thru 3 different cords and on the third one, the camera displayed for about 2 seconds. I then unplugged it and plugged it back in (same cord) and the camera view was gone and I haven’t seen it since. This happened well before I posted to this site. Thanks in advance for the help and my fingers are crossed to get this figured out. 

Hello Jeff,

Thank you for the tests done.

Before going further in the troubleshooting, I would recommend also the followings:

  • uninstall/reinstall DJI GO 4
  • Do a clean reinstall on your mobile device of Pix4Dcapture as explained below.


The procedure below may imply data loss so we recommend to make a backup if there are important data saved. Connect the mobile device and use iTunes to backup files on your computer.

Re-install Pix4Dcapture from scratch

  1. Uninstall Pix4Dcapture. On your mobile device go to Settings > General > iPhone Storage > Pix4Dcapture > Delete App.
  2. Re-install the latest version of Pix4Dcapture.
  3. (optional) Place the backup content back into the Pix4D folder to restore data.

Tell me if it can work,

Still nothing. I’ve tried hooking up the iPad via the port on the side of the controller as well as the USB port. 

Hi Jeff,

ok, you did a clean reinstall and nothing changed?
Can you try to plan a small mission and see if the camera view is not available at any point of the flight? For example by checking the camera view when the drone is flying and after the first waypoint?


Yes I did that and still nothing. 

Hi Jeff, 

We would need more information to investigate the issue, could you please send the log files: (Android, iOS) How to extract the log files? Use the email address: to forward the log files.

I have same problem here and i tried everything above. Live view is just black. 

Hi Jeff and Kizen,

@Kizen: What mobile device are you using to run Pix4Dcapture? Are you also with the Mavic 2 Pro?

It may happen that the camera view will be available at the first waypoint during the flight. Have you check that it is also not working during the entire flight?