Support Website Contact Support Blog

"mission cannot be started because of dji internal failure"

Hello,

struggling all week with pix4D : to connect to drone, then to upload mission and now this :

after clearing all steps and finally pushing the button 3sec in order to start the mission, puuuuuuusssssssshhhhhhhh and… nothing. the drone doesn’t move. nothing happened, except a message after a few seconds : 

“mission cannot be started because of dji internal failure”

I tried while flying, with engine working or not, rebooted, restarted, changed battery, close all apps through the setting panel (“force to close”), including DJi go, which obviously create conflict… I’m stuck now

I can’t fin any support about this. Does someone already solve this issue?

Regards.

on a p3p, dji phantom3 pro

Hi,

We were able to reproduce this issue and our developers prepared a fix version.

The fix should be available in the next version 4.1.0. 

As a side note, if a mission is successfully flown after getting the error message (1), synchronization is not triggered, UI pictures are not present in project detail and pictures can’t be downloaded although they are stored on the SD card.

Best,

thanks for your answer.

 

I’ve made 5 more tries. For some reason, it worked before the update has been issued. Same error message but the drone took off and completed the mission (without being able to sync, but I don’t mind this part)

After having been downloaded the update, I tried 2 more times. 

First time it worked perfectly. But today, same error and drone didn’t took off at all. Even after restarted the device, drone, RC and process.

I’ll try tomorrow with another device. I was operating on samsung tab 2

Thanks again for your concern.

Hello,

I tried again with a new tablet and failed again. Drone did’nt took off at all. 

 

So it’s something to do with the internal drone. No fly zone?

Users can check this interactive map in order to see if the area is inside a no-fly-zone. 

We expect the restricted zone option to work with Pix4Dcapture to fly automated missions even though the developers could not practically test the app in a no-fly area. You should first open DJI GO or DJI GO 4, unlock the no-fly zone option and then fly with our app (learn more).

We have little feedback on no-fly zones so if you wish to give it a try with Android or/and iOS, we would be glad to learn from your experience.

no fly zone was just a guess.

I always open dji go first and there weren’t no fly zone restriction. But OK I will let you know if news can be shared about this.

For now I’m not able to fly with pix4d

 

thanks

Good day, I have the same problem. A while ago after we did firmware updates on the Phantom 4 and the apps on our tablet we found out that the new software needs a tablet or phone with Android 6 or better. So we went and installed it on my phone running Android 6. This sorted that problem.

 

But now I went out flying in December 2017 and flew a big area without any problems, so earlier this month I went out to fly again in another area but I struggled for a few hours and everytime I try to take off absolutely nothing happens after you press the button for 3 seconds, I only get the “mission cannot be started because of dji internal failure”. 

 

So I saw there were firmware updates available and I then updated the drone itself, Dji Go 4 app, Pix4D and the Cntrl+Dji app but still no luck and I have not been able to use the drone with Pix4D auto missions

 

Is there any update regarding this problem? I need to get in the air ASAP.

Just to add to my post.

 

The area where I first found this problem was not in a “No fly zone”, so that possibility is ruled out.

Thanks

Okay so i have been playing around today. One thing that I found regarding the error mentioned above is the following:

Since I got the Phantom 4, I flew at an altitude of 150m above ground, but today I tested at various altitudes and distances away from me. What I found is that the distance away from me is not the issue but the altitude is. If I try to take off at an altitude above 100m then the error appears but if I try at 100m and lower, the drone responded normally like it use to.

 

Now I am wondering if any of the updates that have been released within the past 2 months or so change anything regarding the altitude that I am able to fly?

I have the same error alert.

I checked on DJI Geo System website to see if I was in a locked area.  Well, I was in an unlocked area. All green circles near to me.

What’s the problem? How can I solve? I resolve if I downgrade the firmware? I have to do a 3d mapping next week. I accept advice

@Phillip and @Top Could you do a quick check if the Maximum Altitude setting in DJI GO 4 is too restrictive?

Try to set to at least 150m if you want to do flights at 150m. Do you still face the same issue after changing the value?

Best,

Hi,

I have the same issue!!!

I have a Phantom 3 Pro, with a Samsung Galaxy S7 Edge. On my use, I just select “Just Once” at select the App and start the Drone, on this case a CTRL-DJI. For several times, the application don’t connect to the drone and I have to connect first with DJI GO and then return to CRTL-DJI.

When all is ok, connected and etc, I can start a mission (Ex. a mission on 40m above the take off), I can take off the drone, I can send the mission, but when I tried to finally start the mission, clicking and hold for 3 seconds, the drone only still hovering and shows the message: “mission cannot be started because of dji internal failure”. I have to landing the drone and I can’t collect the mission.

I have verified about the maximum fly altitude, it was less then 100m, and the fly zone is ok (not on Non-Fly Zone)

What can I do? I need to capture the region ASAP!!!

I checked the maximum altitude. I was at 150 meter on my DJI Go app (not 4).

As I wrote before, without change any setting I tried to map another area with the same setting. I flight without problems.

Now, I would to know why into another area free Fly-Zone (all green circles near to me), the drone no take off after holding for 3 sec take off?

I must to do a work with urgency. The customer wait to me.

I know I can fly and map with another app (Litchi), but I would to know why Pix4D works in some area and not in another area. (Same setting and green circles)

Please some advices from support?

We had a closer look at the issue and concluded that the error most probably originates in the DJI SDK and that it was not fully resolved in the 4.1.0 version of the app. We are gathering additional information to report it further. 

At the moment we recommend the following but we can not guarantee that it will work in all cases:

  • Aborting the mission, which did not actually start, and try again. 
  • Restarting the drone, controller, and the app could help case the drone is “overloaded” with too many consecutive missions or commands. 

 In some cases, the mission does not start also when the mission is inside the no-fly zone or if the settings in the DJI GO app, e.g. maximum height, conflict with the mission definition in Pix4Dcapture. 

@Fábio, the workflow that you follow seems to be correct. I would just recommend double-checking that the DJI GO app is not running at the same time as Pix4Dcapture. More information here: How to force quit an app

Best,

I tried several times restarting all (controller, drone, app) but nothing.

As I said before, with the same setting, in another area, it works fine.

 

Currently using App version 4.2.0 (build 903) and have found the same “mission cannot be started because of dji internal failure”.

Have I missed a fix in another post - possibly?

 

Thanks in advance

 

Good day,

 

So I went out a while ago. Before the last DJI Go4, Cntrl+dji and pix4d app updates. I did a small mission at 150m altitude and it worked perfectly. So I went out again on Friday to test the drone. So still at 150m altitude without the recent updates and I got the same SDK error. So I updated all the apps on my phone including the firmware on the drone.

So after all the updates I still get the SDK error, but what I found is that you can see while you are in Pix4D that the data from the drone refreshes every few seconds just after it gives the SDK error, so I timed it and just after it refreshes I started the mission, the drone did take off and completed the mission but it failed to take any photo’s so ultimately it was useless.

So then I refreshed the firmware on the drone again but this resulted in another problem when I open DJI GO4 app the drone does not connect at all. I even tried different USB cables to see if that might be the problem.

So this is becoming very frustrating seeing as I am encountering more and more problems as I go on.

Are there any solutions yet?

Just to confirm my current software:

DJI GO4 app version 4.2.8

Pix4D app version 4.2.0

Cntrl + dji app version 1.8.1

Drone firmware version is the latest one as refreshed on Friday 6 April 2018

So I haven’t flown for a few months.  I have tried 3 times over the last week.  RPA flies fine (P3P) using DJI Go app but as soon as I try Pix4d I get the same error.  DJI Internal Error message.  So a whole lot of users are all getting this error and it looks like Pix4d crew aren’t doing anything about it…very frustrating given the cost of Pix4d software and the fact that many (if not most) of the users utilise this software for commercial purposes…is there a fix on the way DJI?

I have found that it is a problem with the Android version of the App…not a DJI internal error as such. I was getting the exact same error suddenly on a Samsung tablet…

But after trying an Apple Ipad the Pix4d worked perfectly.

Different setup as there is no need for a Control App that is required for android…pretty annoying.