Support Website Contact Support Blog

DTM and Contours remain the same, despite having modified the Densified Point Cloud

Hello to the Pix4D Community.

We are processing drone data in order to create DTM and Contours. After having processed all steps 1,2,3 at Pix4D (version 4.2.26), the dxf Contours seems like this


where we may see that in the red circle there is a swimming pool that we would like to remove as an example.

So after editing the point cloud and removing the pool, the point cloud seems like:


The modified point cloud is exported (not very sure whether this is really necessary) after being prompted to save it and imported again with Process>Import Point Cloud for DSM Generation and logically there is a prompt to run again step 3

However the DTM and Contours outputs are identical to the previous ones before the editing, so I must be doing something wrong and any help would be really appreciated.

PS: I have a request for Pix4D, the industry really needs the DTM to be exported also in DXF TIN that many terrain processing software require. I see in the forums that this feature is requested by a lot of people, should you added it, it would make our lives easier.

1 Like

I’m having the same issue with my project as well. I removed a number of points that were generated from a water surface. P4D does not like water and it makes the point cloud go crazy. I removed the points and i also get the same outcome. It’s like I did nothing. I’ll be following for the solution.

Dear Theodore and Joshua,

Let me detail the steps through which you have to go in order to edit the densified point cloud, then generate a digital terrain model (DTM) based on this edited point cloud:

  1. Click on the tool “Edit Densified Point Cloud”.
  2. Select the points you want to edit (remove).
  3. Allocate the points to a new group. Make sure you allocated points you want to remove to the Disabled group.
  4. Click  Assign.
  5. Click Project > Save Project.

See this article for instructions about editing the point cloud, but ignore the last step (number 14), because it is only mentioned if external use will be made of the edited point cloud.
In order to generate outputs based on this edited point cloud, you do not need to export the point cloud then import it again in the software. 

  1. Run step 3.
    In the Processing Options, make sure you check the box GeoTIFF for the DTM, else it will not be generated.
    Step 3 needs to be run so that a new (updated) digital surface model (DSM) is generated, based on the edited point cloud. Then, based on the DSM, the new (updated) DTM will be computed.

Let us know if this helps.

@Theodore , I have reported your request for exporting the DTM in the format DXF TIN.

So I need to run step 1 and 2 to get the point cloud. Then I can clean the point cloud up and remove any points I don’t want used by placing them on the disabled point group. At this point I can regenerate the 3D mesh. And then I can run step 3 and generate the DSM and Ortho. Do the DSM and the Ortho take into account the entire point cloud or do they ignore the points on the disabled point group as well?  Lets say I want an extra output of a PDF of the contours. The problem right now is when it generates these contours it generates them for all the trees and buildings as well. Do I need to move everything except the ground points to the disabled layer in order to achieve contours of only the ground?

Hey Joshua,

After editing the point cloud by allocating points to the Disabled group and running step 3 after that, the results and outputs of step 3 (digital surface model DSM, orthomosaic, contour lines, etc.) will be based on the edited point cloud, i.e. ignoring the disabled points.

In order to generate contour lines of the terrain, and not the surface, you need to first generate the digital terrain model (DTM), then generate contour lines based on the DTM.

For more information about the DTM, please see: DTM.
For more information about generating contour lines based on the DTM, please see: Contour Lines using the DTM and How to generate Contour Lines based on the DTM.

Let me know if you have any questions.

I have this issue as well. I re-classify the points that need to be classified as buildings and re-run step 3 and the building roofs still show up in the DTM. What else do I need to do?

BTW, the link you have for DTM does not work. Can you provide a new one? I get an error that the page does not exist when I click on the DTM link you provided: https://support.pix4d.com/hc/en-us/articles/217263226

Hello Chistopher,

I changed the link and it now works.

The points which are in the building or vegetation layer will be smoothed strongly during the DTM interpolation by they are still taking into account.

If you want to really avoid those points what you can do is:

  • Run Step1 and Step2 (with classification)

  • Move all of the buildings, vegetation and man-made objects to the disable layer

  • Run Step3 and this time the DSM will be a DTM as only ground and road surface layers will be used (everything else will be disabled).

I hope this helps.

Regards.

I use the DTM to design an irrigation system and need the true ground. The pipeline cannot run over the vegitation or buildings.

I’m having the same problem still. I’ve tried this manual clasification to Disable and the results is still not correct.

Why do I have to manual try to create the DTM where the software does the clasification and does not take it into consideration?

I have to use a third party software, Model Maker to delete the points (xyz grid that I exported from Global Mapper) around the high vegitation and buildings. I spend a lot of time on this manual steps.

Has this been solved yet or do I miss the correct auto steps?

Regards

Div

 

Hello,

Pix4D does take the classification into account when interpolating the DTM. Points classified as terrain (ground and road surface) are taken as they are, whereas the off-terrain points (vegetation, buildings and man-made objects) are smoothed. That means that they have much less “weight” but somehow they are still considered. In order to not use them, they should be classified as disabled.

The problem is that if there is a large area covered by buildings and vegetation whose points are disabled, there will be a large empty area and the DTM will not be interpolated very precisely and in addition, if the terrain is not really seen in the images (for example with dense forest), there is no way to define it properly. The reason why the off-terrain points are still used is to avoid empty areas which might lead to holes during the interpolation.

As for the classification itself, Pix4D uses a machine learning algorithm which might fail in some extreme cases. As it is an automatic process, we always recommend checking and editing the misclassified points.

Regards.

 

 

Hi 

This is the area I’m talking about. Here you can see that the vegetation, buildings and man-made objects are not close to “much less weight” see the contours over the top. 

Why can Pix4D not remove these areas from the DTM and now I’ve got to do it manually?

Are these areas to large?

 

regards

Div

Hello again,

Are you using the DTM or the DSM for the contour line generation?

Have those points which belong to vegetation and buildings been moved to the disabled layer?

If that is the case, the contour lines should be generated using the DSM (as it will be DTM because the buildings and vegetation are not there any more).

Regards.

Hi,

Yes DTM. see photos

How do I move those points which belong to vegetation and buildings been moved to the disabled layer?

Div

 

 

Hi again,

This article explains how to do it.

Just select the points in the point cloud and “classify” them as disabled. Afterward, run Step3 but do not generate the DTM as the DSM will be de DTM because no buildings and vegetation points are considered.

Regards.

 

I don’t understand something. Please have patience with me.

Why do Pix4D classify the Layers Vegetation and buildings and Nan made objects and then they are not automatically Disabled to generate the DTM?
Why must I then manually reselect those areas and assign them as Disabled. Why can I not chose, move these layers as, to Disable layer and assign them?

Div

Ok, I see you are talking about the “points” in the Vegetation, buildings and man made objects and NOT their “layers”
So that mean that I have to reselect all these points in all these Laers and then move them to the disable layer and assign. Then Step 3 and DSM and not DTM.

Why can I not just move these “Layers” to Disable and assign them. Then I don’t need to reselect all the points again that Pix4D did
automatically?

Div

Or, can I delete these Layers?
Div

Hello again Div,

The standard process to produce a DTM is:

  • Step1

  • Step2 applying classification

  • Step3 generating a DTM which will use the classification computed in Step2

For some cases when there are large areas covered by buildings, vegetation and man-made objects, if those points are removed, there will be large empty areas which could be empty after the interpolation leading to holes in both DSM/DTM and Ortho. To avoid that, the points are not removed by default but sometimes, if you really want to not use them, they should be disabled, but as I said,holes can come out.

I hope it is now clear. If not, please do not hesitate to ask again.

Regards.

 

 

 

Hi.

Up to Step 3… I understand and I do it this way.

“For some cases…”
This is not a specific answer for me.
Let’s take my project above and answer according to this specific “case”.
Will these High Vegitation, Buildings and Man made objects create what you said big holes in DSM/DTM and Mosaic?
You can see that I removed the points in my Third Party software, Model Maker around the top building with white roof and also in the middle of project over those three buildings with white roofs.
The other buildings, Vegetation and Man made objects has contours over the roofs.

In all my projects like these I never got a DTM without contours over these areas.
So, I don’t know how the “some cases” you are talking about looks like.
You cannot call your DTM a DTM while the contours run over the tree tops and buildings.
Please show me how your “some cases” look like please.

Then my previous question was not answered.
Pix4D does the classification perfectly.
How can I assign any one of the Layers, Vegetation, buildings and Man made objects to the Disable Layer without having to manually reselect those points in those layers?
I see two options if I use the Edit tool.
Layers can be “Remove” and “Rename”
If I Remove it will it be removed before DTM is generated?
If I Rename, can I Rename High Vegetation, Buildings and Man made objects to “Disable” and then Pix4D will discart those areas for generating the DTM?

Pease see my questions as positive to understand exactly how Pix4D works.

Div

Hello again,

I would recommend opening a support ticket where we can share data and analyze your case better.

Go to Pix4D support site and click on contact support:

As for your question, there is no need to remove or rename any layer. You just click on “assign” (when vegetation, buildings and man-made object are selected) and select the disable layer, and the points will be moved there.

For example, in the  screenshot below, if I click on “Assign”, the selected points will be moved to the “Ground” layer:

You have to select all of the vegetation, man-made objects and vegetation and assign them to the disable layer:

 

I hope this helps.

Regards.