Support Website Contact Support Blog

DTM creation problems

Why doesn’t Pix4D respect the point cloud classes when creating the DTM? I have several places on a project where buildings or structures still have generated contours up to their height, instead of having a flat area for where the ‘hole’ should be. I edited the point cloud to fully classify the structures into buildings or man made objects, saved the project and exported the point cloud, but I still end up with these mounds where the buildings or structures are.

The classified point cloud after cleaning:

Is there a way to make the areas where building are truly flat (i.e - triangulate across their base) rather than mounded? See the attached images for what I’m referring to.

 

The originally created contours straight out of Pix4D (with the default 5x GSD sample size):

And closer to how they should look: 

Hey Mark, 

You can make these areas flat by editing the  Densified Point Cloud  and assigning these points to the Disabled Point Group
Then, you should process Step 3. again to regenerate the DTM and the contour lines. 

Let me know if this improves the final result. 

I’m having exactly the same problem still. I’m doing as instructed above with no success.

Any update when this will be corrected in the software?

Regards

Div

Hello,

I suggest having a look at this topic where the same issue is discussed.

Thank you very much.

Regards.