Support Website Contact Support Blog

Pix4D not respecting the pointcloud classification to create the DTM

I’m having some problems with the DTM creation. 

After ajust the automatic pointcloud classification process you can see I left not even one point of threes or buildings on my point cloud: 



Even so, the DTM proccess still having some unexpected elevation that complete disregards that classification: 

How can I (or anyone) trust the classification or the DTM result if the program it’s not taking on account those specification? 

 

How can I prevent this from happening and have every point on his correct classification? (I don’t want to classified all the objects on the “Disable” category. 

Hola Raúl,

During DTM generation, the disabled points are not definitively removed but rather smoothed which can lead sometimes to certain inconsistencies. Besides as the classification is automatic it might need some manual correction.

That’s why sometimes we would recommend to generate the DTM in the same way you do so for the DSM, but assigning all point from all classes, except “Ground”,  to the class “Disable”. This usually leads to better results.
If you want to preserve some features, you can keep them by assigning them to the class “Ground”. Make sure that all the points from features you want to preserve are assign to the correct class.

Then, when you are happy with your classification, you can launch step 3:

Make sure that Raster DTM is unchecked:

One more thing, if you DTM has some holes you can fill them using the “New Surface” tool:

Make sure that you have check the box “Use for DSM and Triangle Mesh”:

Hope this will you to improve the quality for your DTM.

Best,