Support Website Contact Support Blog

Point Cloud Classification Clean Up

 Using the latest desktop version, the point cloud classification works pretty well. However, there are always some problems like rooftop points classified as ground. So, I try to select the points and assign them to the appropriate class. Then, I run Step 3 to generate contours from DTM. However, the contours do not reflect the changes I have made manually. Someone suggested assigning them to the Disabled class, but that does not seem to fix the problem.

 

So, how do I manually assign points to the appropriate class in order to clean up the DTM?

Hello Brendan,

How does the DTM look like? Are these rooftop points removed from the DTM?

The solution for non-terrain points that have been correctly classified but they are not removed from the DTM is to assign them to the Disabled point group editing the point cloud and to re-run step 3, so that both the DSM and the DTM are regenerated. 

Could you please try this workaround and let us know about the results?

Regards,

Hi Antigoni,

The points have not been correctly classified, so I am trying to manually re-classify them. Is that procedure correct?

I have tried assigning them to the correctly layer, and rerunning Step 3. I have also tried assigning them to the Disabled group, and rerunning Step 3. Neither options changes the contours generated from the DTM.

After I select the points, select the layer, and then click Assign, is there anything else I need to do?

 

 

Hello,

I had a another thought. Are Automatic Tie points used for DSM/DTM generation?

When I turn off all other points, the Automatic Tie points are still showing, so I’m wondering if that is affecting my surface generation

Hi Brendan,

The DSM is generated based on the densified point cloud. The Automatic Tie Points do not affect the DTM results.

To assign points to the Disabled point group you should select the points, select the layer to be assigned, click Assign, click on the pencil icon (step 12 of the article) and save the project.
Is this the process you are following? Can you see if these points are indeed assigned to the Disabled point group by unselecting this layer in the Layers section and check how the point cloud looks like? Are these points displayed?

Regards,

Hello Antigoni,

I have assigned the points to the Disabled point group, per your instructions. I have confirmed that they are in the Disabled group by turning off the layer. Unfortunately, the contours still reflect the building.

 

This happens on many of my projects.

Is there anything else I can do?

 

Thank you

Hello Brendan,

To better understand the problem, would it be possible to send me a small dataset in which you are facing the problem?

You can maybe submit a support request attaching the .p4d file and the images. You can share the images using any file sharing platform. Please send me also the contour lines and DTM files.

Regards,

I am having the same issue. I have removed unwanted points using the point cloud editor and assigned them to “Disabled” however they still impact the results of step 3 when I run it again. At this point I would like a way to delete points completely so I know they are gone and will not be effecting my DSM/Ortho.

Please advise

Thanks

Also interested in how to solve this issue. Increased control over which classifications will be a part of the DTM generation would be nice. Especially when creating new pound cloud classification types.

I would also like some clarification on this process. 

Hello all,

The Disabled points are not used for the generation of the DSM and the orthomosaic. If the DSM has been generated before assigning points to the Disabled point group, step 3 needs to be reprocessed.

Regarding the DTM, the DTM is generated based on the point cloud classification, and more specifically the points that have been assigned to the Ground and Road Surface point groups. For most of the cases, when all the terrain points are correctly assigned to these groups the DTM and the contour lines generated based on the DTM are accurate.

However, we have noticed that in some rare cases, such as high and wide buildings, the DTM might not be correctly generated even if all the points are correctly classified. Our DTM algorithm seems to be unable to smooth out such buildings. Usually, the problem is that the points at the rooftop are considered as terrain points creating an inaccurate DTM in these parts of the project area. 
The workaround for these cases is to assign the building points in the Disabled point group, reprocess step 3 in order to regenerate the DSM and the generate the DTM. Please note that doing this the DSM will not be accurate, but the DTM will be.

In case that you are facing issues or the Disabled points are present in the DSM or the orthomosaic, I would need some more information, such as the version you are using, the PDF quality report, the DSM, DTM and contour lines files, in order to investigate on this.

Regards,

Has this issue been resolved or a solution found? 

I am using version 4.3.31
I have followed the same steps: Making sure the Point Groups are classified properly and assigning Buildings and Human Made Objects (in my case parked vehicles and some buildings that were miss-classified) to Disabled.
After I run Step 3 I am still getting values in my DSM and DTM for buildings, and my contours created from DTM still include building values.   

Hi Arden,

Please try the following workflow:

  1. Run Step 2.
  2. Classify the point could - add everything besides the Ground and Road Surface to “Disabled”
  3. Run Step 3 but do not mark DTM option as DSM will be already your DTM and mark contour lines.

If it does not work for you, please submit a ticket to Pix4D Support Team, and we will investigate the issue.

Thanks