Support Website Contact Support Blog

Cannot remove trees (high vegetation) from DTM

I have classified points in the DSM (added trees to high vegetation) and re-generated a DTM but the software keeps adding the elevation data for the trees in both the geotiff and contours.

Does it matter if I add the tree points to “high vegetation” or “disabled?” The main issue is that the trees are still throwing off my topo / creating humps. See the screenshots below.

Maybe I am not following the process correctly. This is what I do:

  1. In rayCloud I choose “edit Densified Point Cloud”

  2. Select points and assign to this case “High Vegetation” - I notice sometimes I have to left-click several times in a location when creating a selection

  3. Unclick “edit Densified Point Cloud”

  4. Process\ “Generate DTM” - This prompts me to save which I do.

  5. Process\ “Generate Countour Lines (DTM)”

Orthomosaic:

DTM:

Point Groups:

Contours (CAD):

Any help would be greatly appreciated! Thanks

You have to export the edited point cloud then proceed with Step 3.

Thanks for the response! I found this reference which is pretty good for others who run into this:

I will check to make sure everything works and then accept solution.

Ok, so I’ve been playing with this and still can’t get it to work. I export the edited point cloud as an las file and now what? Do I create a whole new project based on the exported las? Do I re-import it into the same project? I keep getting the same contour outputs that include high vegetation.

Did you overwrite the existing las file? If that still doesn’t work, try moving the high vegetation to disabled, then export again. That should definitely work.

Hi. Thanks for the response. No, I exported to a separate location. I only have two las files in the project data folder called result_tracks2_full_0.25.las (39mb) and result_tracks3_full_0.25.las (19mb). They are pretty small compared to the version I exported (1.6gb). Where do you find the existing las file?

Is there a straightforward tutorial or guide on how to do this? It seems like a core feature of the software but I am finding it very convoluted and confusing. Thanks!

You export it to this folder: \2_densification\point_cloud\

Hi @CK_FSLA and @Andrew_Milanes

Once the points are assigned to the Disabled class and others, the software is smoothing those categories depends on category weight the Pix4Dmapper assigns them.
We apply to the Disable class intense smoothing, but it may happen you still see some ‘‘leftovers’’. It actually depends on the dataset.

What you could do with your classification is to draw surfaces after you assign points to Disable category (to fill the holes) — more information in How to draw a Surface in the rayCloud. Afterwards, run Step 3 or use the Process\ Generate DTM and Process\ Generate Countour Lines (DTM).

Using the surface should flat out the vegetation area.

Hope this helps,

We apply to the Disable class intense smoothing, but it may happen you still see some ‘‘leftovers’’.

Well, that’s a horrifying revelation.

This is one of the most difficult and time consuming tasks in P4D. It really take a lot of editing and fine tuning of the point cloud to get the DTM to look right. However, if you only need contours, you don’t have to get the point cloud perfect. Just get it close enough and edit the contour settings to smooth out the lines. Increase your minimum spacing and feature size and it will ignore all the “leftovers”. Your DTM may not look great, but your contours will.

I wish P4D’s classification algorithm was better or could be fine tuned for each project. Because right now, it’s really not that great. Having a ground / not ground classification would be much more useful that what is there right now.

I stopped trying to generate a DTM in Pix4d 4 years ago. Classifying the point cloud ends up being more time consuming than generating a DTM in GIS with some better LiDAR tools. The only instances where I take the time to edit the point cloud is removing conveyors when doing stockpile calculations. Otherwise, surface building takes place in GIS.

Yeah same. I use ArcGIS pro for this.