Support Website Contact Support Blog

Beta OS X version of Pix4Dmapper 2.0

_This post refers to OS X Pix4Dmapper 2.0. Since the release of OS X Pix4Dmapper _2.1, we have created a new post here, on which you can post your comments and your feedback.
This post will be closed to comments.

We hope version 2.1 will better meet your needs.

----

Hello Pix4D members & Apple fans!

We are happy to announce the first beta OS X version of Pix4Dmapper! 
Please note that this is a beta version and is not (yet) intended for production or professional usage. Your feedback is very welcome to help us improve the OS X version and have an official release soon.

 

How to install the OS X version

Follow these steps to install the OS X version:

  1. Download the OS X beta version from here: https://mapper.pix4d.com/download/mapper/dmg/
  2. Go to Downloads folder and double click Pix4Dmapper.dmg.
  3. Move the Pix4Dmapper icon to the Applications folder. Pix4Dmapper is now installed.
  4. If you are not the Administrator, authenticate adding the username and password of the Administrator.
  5. Eject “Pix4Dmapper” image.
  6. Launch Pix4Dmapper.
  7. A warning message will appear: “Pix4Dmapper is an application downloaded from the Internet. Are you sure you want to open it?”. Select Open.
  8. Add your username and password. Pix4Dmapper will open.

 

FAQ

What about the licenses?

Your existing paid licenses will work just as well on the beta OS X version; it will just count as another installation but you can float easily from one device to another. You can also use the beta OS X version with the free Discovery license.

 

What are the minimum hardware requirements?

The beta version has been fully tested with these Mac computers:

Pix4Dmapper should run on other Macs of this period, with similar specifications. We recommend the fastest i7 processors and at least 16GB RAM.

We also plan to test the beta version on more Mac computers. Your feedback for compatibility issues with other Mac devices is more than welcome.

 

Is there any difference between OS X/Windows versions?

The main difference in the OS X version is the lack of Nvidia CUDA support. Also, it is not possible to use the SGM add-on for the point cloud densification and generate the 3D PDF output. It is possible to open a project only from the User Interface, after launching the software. 
We are also working on improving the display for Retina screens.

 

Is support provided for the beta OS X version?

The OS X version is in beta. Therefore, personal support is not yet provided. However, you are welcome to post your feedback on the Forum to help us improve the beta. You can post your comments, suggestions or issues in this section of the Forum.

 

Are the Manual and Knowledge Base valid for the beta OS X version?

Apart from the installation of Pix4Dmapper and the lack of GPU processing, the documentation of Pix4Dmapper is valid for the beta OS X version.

 

We hope that you will enjoy using the beta OS X version and we are looking forward to receiving your feedback.

Regards,

This is my system, do you think that it is sufficient to support OS X version of Pix4DMapper?

Hi Antonio,

We have not yet tested Xeon processors with the Mac version but your computer has good specs to run Pix4Dmapper.

Make sure also to update your graphic card to the latest drivers. On Windows there can be some issues with some AMD driver versions.

Let us know how it works!

Best regards,

Hi, I’m trying on my old “Mac Pro”. It crashes after creating a project, right when it should processes the EXIF of the projet pics. I’m trying to update to El Captan.

Hello Nicolas,

Could you please provide us the following:

  1. The log file generated by Pix4Dmapper.

  2. The Mac OS X crash log. When the software crashes, a pop-up window appears displaying a complete stack trace. You can save this information to a file and share it with us. This will help us find out more about your crash.

  3. The images of the project that crashed. We can try to reproduce the crash on our Mac devices.

 

You can send the aforementioned files to support@pix4d.com.

 

Best regards,

I have run successful test using both a Mac Pro (early 2009) with NVIDIA GeForce GXT 680 and a MacBook Pro (Retina, 15-inch, Early 2013) with NVIDIA GeForce GT 650M.  Both test were processed using the free Discovery license, but I presume all is working well.  Glad to see this on the Mac.

Dear David,

Thank you for the feedback!
Could you provide us all the specifications and the models of the Mac devices you tested to report this?

Best regards,

No problem.  Here is the model, cpu, memory and video details below. Let me know if you would like any additional information or configuration details.  I can generate system reports or also provide any logs if that is helpful.  I also have a Mac mini and MacBook Air that I could try testing small projects on.  

I captured a 117 pictures in free flight with a DJI Phantom 2 Vision+ today and that is currently processing on my Mac Pro.  The Pix4Dmapper is keeping the CPU’s working very hard.  

 

OS X 10.11 (15A284)

  Model Name: Mac Pro

  Model Identifier: MacPro4,1

  Processor Name: Quad-Core Intel Xeon

  Processor Speed: 2.26 GHz

  Number of Processors: 2

  Total Number of Cores: 8

  L2 Cache (per Core): 256 KB

  L3 Cache (per Processor): 8 MB

  Memory: 16 GB

  Processor Interconnect Speed: 5.86 GT/s

  Boot ROM Version: MP41.0081.B07

  SMC Version (system): 1.39f5

  SMC Version (processor tray): 1.39f5

NVIDIA GeForce GTX 680:

  Chipset Model: NVIDIA GeForce GTX 680

  Type: GPU

  Bus: PCIe

  Slot: Slot-1

  PCIe Lane Width: x16

  VRAM (Total): 2048 MB

  Vendor: NVIDIA (0x10de)

  Device ID: 0x1180

  Revision ID: 0x00a2

  ROM Revision: 3731

 

Mac OS X 10.11 (15A284)

Model Name: MacBook Pro

  Model Identifier: MacBookPro10,1

  Processor Name: Intel Core i7

  Processor Speed: 2.7 GHz

  Number of Processors: 1

  Total Number of Cores: 4

  L2 Cache (per Core): 256 KB

  L3 Cache: 6 MB

  Memory: 16 GB

  Boot ROM Version: MBP101.00EE.B09

  SMC Version (system): 2.3f36

 

Intel HD Graphics 4000:

 

  Chipset Model: Intel HD Graphics 4000

  Type: GPU

  Bus: Built-In

  VRAM (Dynamic, Max): 1536 MB

  Vendor: Intel (0x8086)

  Device ID: 0x0166

  Revision ID: 0x0009

  gMux Version: 3.2.19 [3.2.8]

 

NVIDIA GeForce GT 650M:

 

  Chipset Model: NVIDIA GeForce GT 650M

  Type: GPU

  Bus: PCIe

  PCIe Lane Width: x8

  VRAM (Total): 1024 MB

  Vendor: NVIDIA (0x10de)

  Device ID: 0x0fd5

  Revision ID: 0x00a2

  ROM Revision: 3688

  gMux Version: 3.2.19 [3.2.8]

  Displays:

Color LCD:

  Display Type: Retina LCD

  Resolution: 2880 x 1800 Retina

  Retina: Yes

  Pixel Depth: 32-Bit Color (ARGB8888)

  Main Display: Yes

 

 

 

Hi, I just installed the Mac version. I tried to open the Agriculture example dataset:

https://support.pix4d.com/hc/en-us/articles/202561429-Example-Datasets-Available-for-Download-Agriculture

 

but got this error:

Error e0067: Detected camera CanonPowerShotS110_5.2_4048x3048. This camera is not supported by this edition of Pix4Dmapper. To process more cameras, contact Pix4D.

 

Also tried manually adding the photos

@David: Thank you for the detailed information of the devices you have tested.

@Ben: This seems more like a license issue. Could you please check the license type in which you have logged in? To do so, click Help>About…

Ah. Yes I have the 3DR edition, so limited cameras.  

I wish you had other Pro licensing terms, $350 per month is problematic for a business just exploring the field, especially in a country with very weak currency (South Africa).

Thanks for the reply!

seems to work just fine on my macbook pro and its an older version - doesn’t work on bootcamp on the same computer :smiley: great work! looking forward to updates. totally happy that now i can use it on mac OS X

I will test it on my iMac with the same demo files see how that works!

 

Can I check if the DSM module is working on the Beta? I cannot activate the radio button.

@ Ben: You can get a discount of 100% of what you have already paid in rentals after 1 year, in case you want to buy the permanent license. This option is very well received by small companies worldwide. In any case, you can use the Discovery version which does not have time limitations, but some output limitations. More information: https://support.pix4d.com/hc/en-us/articles/202559479

@ Barry: Thank you for letting us know the configuration of the device you have tested. This is very helpful for us!

@ Michael: This seems more like a license issue. Can you check if you are logged in in Discovery mode? To do so, click Help> About…

Looks as though some of the buttons on the Video Animation Controls window are messed up.  I’m running the 2015 Macbook Pro with the specs listed in the ‘fully tested’ table.

I’m able to do most things with the pix4d mac version.  But creating a shape doesn’t seem to work on a laptop if I’m not using a mouse (haven’t tried with a mouse).  How do you terminate the polygon?  Instructions say to use right-click on the mouse, but I am using a trackpad.  Here’s what I’m seeing.

 

 

I am also seeing some layout issues with the text for maximum speed in the Video Animation Trajectory window.  

Double click the p4d file launches mapper, but does not load the projects. Also, there is no place to set the default folder to use for projects.

 

Running on a 17" Pro

Model Name:    MacBook Pro 17 (early 2011)
  Model Identifier:    MacBookPro8,3
  Processor Name:    Intel Core i7
  Processor Speed:    2.3 GHz
  Number of Processors:    1
  Total Number of Cores:    4
  L2 Cache (per Core):    256 KB
  L3 Cache:    8 MB
  Memory:    16 GB
  Boot ROM Version:    MBP81.0047.B2A
  SMC Version (system):    1.70f6
  Serial Number (system):    C02FG03YDMGH
  Hardware UUID:    A30CEA9F-7CB0-5EB2-BEF5-5771F1C7C641
  Sudden Motion Sensor:
  State:    Enabled