Support Website Contact Support Blog

Weird Navigation Problem - laptop screen vs. external monitor

I’m doing some demo/trials with a new employer, hopefully to ultimately prove the worth of implementing a drone/photogrammetry program.   So for now I’m stuck with some fairly basic hardware…though it seems reasonably powerful enough to accomplish my current goal.  

The laptop is a ThinkPad P52s - i7-8550U @ 80GHz, 32GB RAM, Intel HD graphics 620 and NVIDIA Quadro P500.  I have an external monitor connected though a ThinkPad USB-C dock.

The problem I’m running in to is when I have a project open, everything seems to work and navigation in “standard” mode is as expected ONLY when I’m using the laptop’s monitor.   If I flip Pix4D over to my external monitor without changing anything else, it becomes impossible to navigate.  None of the controls react the way you’d expect.   It’s almost like a mix of trackball & first person modes.  I’ve tried closing the latop’s “lid” and using only the external monitor.  I’ve also tried bypassing the dock and connecting the monitor straight to the HDMI output on the laptop.  Nothing so far has had an effect on the issue.  

 

I’m convinced it’s a graphics issue, but I’m stumped on where to go.  I’ve tweaked some of the settings in the NVIDIA panel, but haven’t seen any change and I really don’t see anything that would cause this problem.

 

Any tips on where I can start?

Hi Bryan,

This issue can appear if the screens are not properly set up. Could you try setting the screen on which you work with Pix4D as the main screen?  

Let me know how it goes,

Hi - I had tried that previously (as well as tried using only the external monitor with the laptop monitor completely disabled) and it didn’t seem to change the problem. 

 

It wasn’t currently set as the main screen, however I just changed it and the problem still  persists.

Hi Bryan,

This is likely to be linked to some Windows setting about zoom level. 

Could you please try to right-click on the pix4dmapper.exe file, select the Compatibility tab and enable ‘Disable display scaling on high DPI settings’: the checkbox below should be checked.

Additionally, can you please check the monitor connection and the mouse settings? What screen are you using?
You could also maybe try the following:

  1. Check the settings on your graphics card, and find an option like “Scaling Mode.”  Change it to the “Aspect Ratio” setting (or the setting most similar to “Aspect Ratio”) instead of other options like “No Scaling”.   You should be able to find this option in the nVidia and Intel graphic boards. 
  2. Go to Control Panel-> Personalization->  Display, and check the option “Let me choose one scaling level for all my displays”. 
    Finally, it might be related to the GPU. Could you please make sure that the latest drivers are installed? If so, can you try to adjust the GPU resolution?
    Could you also please check the screen resolution of Windows?