Map View and Two Displays in Windows 10

I was recently running Pix4d Mapper 4.6.4 and then updated to 4.5.7. In both versions I was confounded by display problems in the Map View, rayCloud, and Index Calculator. The Map View and rayCloud were blank and the Index Calculator had many issues with menu choices.

I discovered that if you have a multiple display system in Windows 10, the Pix4D mapper display problems (basically blank screens) only manifest when the mapper window in not on “Display 1” as defined in Windows itself. When I confine the use of mapper to display 1, everything functions as expected.

Hi @mauryhumes,

Thank you for your message and for sharing all the information about the problem.

Is the issue appearing only with the expanded window or also with the resized window?

Make sure you are using the “high performance” mode for your graphics card:

  1. Close PIX4Dmapper if running.
  2. On your computer, go to System > Display > Graphics and browse PIX4Dmapper.exe (typically found in " C:\Program Files\Pix4Dmapper ") if not already appearing in the app list.
  3. Click Options and select High Performance.
  4. Open PIX4Dmapper and calculate the volume.

Also, make sure that your graphics card drivers are up to date (How to update the NVIDIA graphic card). If this still does not help, please completely uninstall PIX4Dmapper (How to completely uninstall Pix4Dmapper) and install it again.

Please let me know how it goes.


I had the same issue and your solution solved it. Thank you!

1 Like


Couple of observations.

First, before I changed anything, I verified that the issue on the physical “Display 2” monitor was the same with an expanded window or a resized window. The issue was specific to the physical display, not how the window was sized or expanded.

I then changed the “high performance” mode for Pix4DMapper, as you suggested. It was “Let Windows Decide” before. After the change I don’t notice any difference. I rebooted the machine and still don’t notice any difference. I verified that the setting was saved.

Additionally, I updated the NVIDIA drivers (prior driver was dated 3/22/22) and it seems to not have any effect on the display.

At this point I can operate by just restricting my use to “Display 1”. That might not work for all if Display 1 is smaller (such as a laptop with a larger external monitor), but for my specific case the two displays are the same.

As an aside. In moving the window between displays and expanding and unexpanding the window (i.e. playing with it to see if the issue was still there), Pix4DMapper did eventually lock up after I moved the window between the physical screens.

Final edited edition for this post. I read through some older posts referring the display issues prior to 4.6.1 when the service data changed. The behavior for me on Display 2 is pretty much the same as those issues.

Thanks for the reply.

Hi @mauryhumes,

thank you for your reply.
My question was to find out more about the behavior. It is possible that the issue is always happening on physical display 2 but only with an expanded window.

Could you please try to switch the cables (connect Display 2 where Display 1 was connected and vice versa) and let me know if the issue is on the same physical Display 2 or if it changed with the display port?


The issue for physical display 2 occurs with both the expanded window and a resized window smaller than the entire display. I tried reducing the window size to a very small display and the behavior is the same.

My first switch of the cables was a bit problematic. Bit hard to describe, but after I switched the cables, windows could recognize what is normal the physical display 1 monitor as “Display 2”. However, it initially only recognized one of the two monitors (and windows identified that monitor as Display 2. So essentially at that moment there was no display 1. Then I brought up Pix4D mapper on “Display 2” when there was no “Display 1” and the display operated as normal.

This points to just a basic resource problem. To test that, I changed the cables back and then reduced the resolution of the displays and then Pix4D operated normally on both Displays (1 and 2).

For my normal operation there are two 32-inch monitors with a resolution of 3840x2160 each. At 1600x1024 and everything worked on both Display 1 and Display 2. I haven’t tried a series of settings to determine the “breaking point”, but I’m presuming the “total” resolution being displayed is an issue, or just the video card can’t support the necessary resources when pushing the two displays at 60 Hz and full resolution. The card is an NVIDIA GeForce RTX 2080 Ti. This card was advanced in 2018, but a bit dated now.

Thanks for the reply.

Hi @mauryhumes,

Thank you for your reply and all the tries you have made.
What we have noticed it could help, is to change the scale of the monitor(s).

Please try different options.


let us know if this helps.


You are correct, the scaling did the trick. However, for my own use I would rather keep the scaling as it was (150%) and just use the Mapper on Display 1. Smaller fonts that come with the scaling change are not preferable for me.

For reference:

  • I reduced the scaling to 100% and the Mapper displays worked correctly (same 3840x2160).
  • I reduced the scaling and then reduced the resolution, which also worked as you expected.


1 Like

Hi @mauryhumes,

Thank you for your tests.
Unfortunately, this is a limitation that cannot be solved at the moment, you would need to keep the modified scale/resolution values.
I will provide the information to the product team for evaluation.
Thank you for understanding.