Trying to Run Pix4D for first time, stuck on "Loading Templates"

I have downloaded the trial version of P4D and am attempting to run it for the first time. It loads a gray window with P4D logo with no buttons, no interface, and it loads a separate white window that says “PIX4DMapper, Version 4.7.5, Loading templates…”

I’ve let it sit for 10 minutes and nothing has happened.

Hi fleming,
Do you have an antivirus program installed. It is quite common for AV programs to prevent the start up of PIX4Dmapper. I would either temporarily disable of whitelist PIX4Dmapper as safe within the AV program settings.

Hello Mike,

thank you for the response. I spent an hour or two with our IT support and they were unable to get past this issue. They wrote me a synopsis of their attempts here. Please let me know if there’s something we can do to get this activated.

The AV is not enabled at this point where it could block the software. We removed any HP antivirus and I checked the firewall web filter to see if the Pix4D urls were blocked and they were not. We also reinstalled the software and removed any remnant folders and did a reinstall as an administrator and that did not help. I also ran GPU updates for that nvidia GPU with no results.
Event viewer also picked nothing up so I would see if the support for Pix4D has any other ideas.

Thanks,

Hi @fleming.talton ,

From our side, I could see the privacy setting of the account is not set up.
This actually affects the users’ access to PIX4Dmapper.
Could you please give it a try and see if it helps?


Since you were unable to use PIX4Dmapper during your trial, I can extend the trial for you once we solve this issue.

Sincerely,
Rosana (she/her)

Give what a try? I have no idea what this screenshot is telling me to do or how to get to where it’s pointing me to.

Hi @fleming.talton

I am sorry I didn’t attach the link that leads you there.

  1. Go to the PIX4Dcloud page and login with the credentials of the Pix4D account associated with the license.
  2. In the top right corner, click the user icon to open the user menu.
  3. Select Privacy Settings.

I also send you a support ticket to ensure we can get this sorted for you as soon as possible.
I look forward to hearing from you via the support ticket.

Sincerely,
Rosana (she/her)

Hi @fleming.talton
How did you solve it? I met the same issue.

Hi @shaoyuwangndsc ,

Would you be able to provide a screenshot?

Sincerely,
Rosana (she/her)

Hi Rosana,
Here is the screenshot.

Hello @shaoyuwangndsc , that actually did solve my problem! The application is soft-locked by the privacy survey referenced earlier in this thread.

1 Like

Hello @Rosana.Lin ,

thank you for the help, I was just able to get the program to launch.

Would you be able to reset my 15-day trial period?

Thanks!

Hi @fleming.talton , thank you so much for your reply.

Hi @Rosana.Lin, The ‘Loading Templates’ is before the login interface. I logged in to the webpage and changed ‘Privacy Settings’. It still does not work. Pix4D was installed by an administrator but I’m not the administrator. I wonder whether this is the reason that I cannot launch the software.

Hi @fleming.talton ,

I am glad it worked! :+1: Usually, if you see a black screen, it has to do with the privacy setting was not set up, yet.
No problem. I just reset the 15-day trial for you. Please feel free to also write us a support ticket during your trial if you encounter any questions, Pix4D technical support. All the valid licenses (including trial) have access to personal support. :slight_smile:

Sincerely,
Rosana (she/her)

Hi @shaoyuwangndsc ,

Thank you for sharing that screenshot. It is very helpful.
May I ask if you have tried restarting the computer, reconnecting to the internet, or are you able to right-click and run as the administrator?

Sincerely,
Rosana (she/her)

Thank you @Rosana.Lin . I see that Orthomosaic and DEM are disabled in the trial version.

Is there any way to create / export an Orthomosaic in Pix4D Trial?

Thanks

Hi fleming,
You are logged into the Discovery version. If you have a valid trial then you will need to log out and then log back in. Be sure to select your trial licens


e.

@Mike_K @Rosana.Lin

Excellent support! Thank you so much. One last thing -

would it be possible to again reset my trial period now that I am finally on solid footing with the trial?

Thank you!

Sure. You have another 15 days. I hope this helps.

Thank you very much for your solutions. I reinstalled the software under my administrator account and it works. It seems I cannot launch the software if other accounts installed the software.