Pix4Dmapper new project blank screen


I’m new in Pix4D software, but I can’t even test it. I can’t start new project because there is a blank (white screen). I also tried to start demo project but there is a screen: pix4d1

I have Lenovo YOGA 720 with 8 GB of RAM, Intel i7 with two graphic cards:
Intel HD Graphics 630 and NVIDIA GTX 1050
OpenGL 4.5

I’ve tested ver. 6.4.6 and 7.4.3 with the same result. No problem with firewall, trying many ways with turned off Intel 630 or GTX1050 graphics in device manager. Newest drivers. Uninstalled many times Pix4D. I’ve read previous topics with this issue, but there aren’t any solutions. Is there any way to run Pix4Dmapper on Lenovo computers?

Best regards,

Hi @Piotr_Fr,

Can you please follow the instructions of this article and send me a screenshot of the Summary tab:

It would also be helpful if you could provide me the Event logs generated while reproducing the error.

To generate these files:

  1. Start PIX4Dmapper and start processing

  2. Then open the Windows Event Viewer by searching for it in the Windows search

  3. Then follow the steps indicated in the image below to save the log file as . txt

  4. Kindly send that . txt file to me to review


Hi @Nikoleta_Dimopoulou, here is screenshot:

pix4d.txt (3.8 KB)

I’m also attaching event report (from last hour), I can’t process any project in Pix4D, so I tried to run demo project, then Pix4D crashed.

Thank you for help,

Hi Piotr,

Thanks for sharing with me the files.

I noticed on the event log that the Qt5Core.dll file is creating the error. I researched online and found this thread mentioning it is a websocket issue and you probably need to update your web socket. For more have alook here:

I hope this helps.


Hi, i am getting the same error and blank window while creating new project. I am using a remote workstation with specifications of 8gb RAM and AMD5 processor. I tried to solve reading all the suggestions on the pix4d website. can you please suggest me what to do next?

Hi @f.nex,

The rayCloud does not display all / some layers, appears black /white or displays artifacts and this error may come caused if A Remote Access / Virtual machine (server connection) is used.

Can you please have a look at the article and the solution proposed?

I hope the information provided is helpful to you.