Support Website Contact Support Blog

Trouble getting a solid mission

We are trying to get this working hopefully to use in commercial applications but so far have run into multiple issues.

To start, we fly with a DJI Inspire 1 Pro paired with a ZenMuse X5 (everything with latest updates). We have both Apple and Android tablets.

  1. We have yet to successfully “sync” and get a .p4d file on any device. We have flown about 12 missions now.

With the iPad, after the drone returns, nothing happens. It lands, shuts off, and the app/software stays on either the cam view screen or map screen and the only button we have is the “abort” button. This happens with or without the auto-sync selected. With no other options, if we do hit the abort button, we get the spinning wheel and it never does anything. Once, we let it set and “work” for a full hour and at that point we surmised nothing further will happen. If we try to hit any buttons while this is (not) working, the app tells us to wait until sync has finished to view the home or options screens. If we close everything down, restart the software and check the missions, the missions are there but they all have the yellow “!” triangle and “error”.

With the android, if the auto-sync is selected, we get a ‘sync failed’ message as soon as it comes back. If auto-sync is off and we tell it to sync, it says there are no photos found despite there being all the photos. We did manage to upload these “non-existent” photos and get the processing to work, of course without the additional help the .p4d file provides, so (I think) our end result is not what it could be, though I can’t be sure since we can’t compare it. I confess I have not scrutinized the processed results of the provided missions versus ours. If we look at all the missions in the missions section of the app, they all have green boxes and check marks like everything worked out, but selection one and going into the next screen, the box is red and it gives us the ‘no photos found’ message again.

 

  1. We have seen strange behavior on the autopilot. For example, the last mission it flew, it reached the end point and then just stopped. Not fall-out-of-the-sky stop, but it just sat there and did not return to the home point. I could abort, or just take control and hand fly it back. I chose to abort, but I don’t know what the correct option was. I don’t know if “abort” causes issues with syncing or after-flight processing in any way.

 

  1. We have a problem with the camera not focusing. We think we have this worked out but not 100% consistently, and compounding this problem is the bug that causes the live video feed to not come through on Nvidia Shield tablets (which we happen to have), so we cant see if the photos are sharp or not unless slave a second remote hooked up to our iPad. The focusing thing is confounding because we dont get it every time, it seems random, and we don’t see blur through the live feed… only when we get back to the lab. It hasent happened to use for the last few missions, we suspect is has to do with DJI Go interfering, but all our cam settings so far have just been on auto in similar conditions so we don’t know whats going on.

If we can get #1 sorted out, we can deal with #2 and #3. Any thoughts?

#1 (the not-syncing) is a known issue with the current version on Android. You can process without the P4D file with no issues.

#2 aborting should not cause any issues with syncing, as that is a separate issue on the X5/Pro. 

#3 I ran into this same issue during a mission today where the camera didn’t focus properly while in a mission that was focused at the grid centerpoint with the camera at a 45° angle. I happened to notice the out-of-focus on the screen while flying though, and so I tapped on the screen of the second controller to autofocus. After I did this, the remaining images came out sharp.

Good info, much appreciated!