Support Website Contact Support Blog

Managing X5 Autofocus with Matrice 100 and Pix4DCapture

Hi Support team,

I read this post :

https://community.pix4d.com/t/2833-Trouble-getting-a-solid-mission#gsc.tab=0

and had the same issue recently , the autofocus of X5 works fine after tapping the screen even when still on the ground in most of the case, but recently i got a blurred mission by doing same handling.

So is it needed to start with DJI GO then do an autofocus at mission altitude then close dJI GO and pass to pix4D and start mission?

Is there a way to have X5 autofocusing without this ?

Is forcing DJI GO to close an issue as it is sometimes asked by Pix4D ?

To be more accurate , my question is : 

  1. Does pix4D Capture manage an autofocus at the beginning of the mission by itself (if X5 is setup in autofocus mode) as this  is the 

feeling i had from the beginning ? 

  1. Or does user have to  do an autofocus at mission altitude then close dJI GO and pass to pix4D and start mission?

I need to do so (step 2) from a recent time , not sure it could be related to latest version of pix4DCapture i had downloaded on 6th April then on 21rst April 2017. 

Mission are grid missions i setup with overlap of 85 % 

Regards

Benoit

Just uploading last flight logs

I can provide you full logs

I get errors like this one :

event":“Error”,“metaData”:{“message”:“Error getting gimbal serial number with error: Not supported”},“sessionInfo”:{“deviceManufacturer”:“samsung”,“deviceModel”:“SM-T710”,“deviceOS”:“6.0.1”,“sessionID”:“58da4e9f-9af8-4ef0-ac27-505ebf34a988”,“userName”:“benoit.filliatre2@free.fr”,“version”:“2.0.42”},“timestamp”:“2017-04-24 13:30:53.735+0000”}

Gimbal is the standard X3 X5 Gimbal from DJI

 

A full line is :

{“droneInfo”:{“cameraName”:“Zenmuse X5”,“droneType”:“Matrice 100”,“flightControllerFirmware”:“03.01.06.103”,“remoteControllerFirmware”:“1.7.60”},“event”:“Error”,“metaData”:{“message”:“Error getting gimbal serial number with error: Not supported”},“sessionInfo”:{“deviceManufacturer”:“samsung”,“deviceModel”:“SM-T710”,“deviceOS”:“6.0.1”,“sessionID”:“58da4e9f-9af8-4ef0-ac27-505ebf34a988”,“userName”:“benoit.filliatre2@free.fr”,“version”:“2.0.42”},“timestamp”:“2017-04-24 13:30:53.735+0000”}

Regards

Benoit


EDIT from Pix4D Support : We have merged the comments that you have added to the post to your original post. Please consider editing your original post if you would like to add more information to the question, click “Post actions > Edit” at the top left corner of the post. 

Hello Benoit.
We currently use a Matrice 600 Pro and Zenmuse X5. We’ve had issues with our photos in missions as well. I would recommend that you open DJI Go and use Manual camera settings. Take drone to mission altitude and turn camera down and adjust the settings to “look” good for photos. And set the Zenmuse X5 to Landscape mode. I leave DJI running in the background as if you close DJI your camera settings will revert to default. then switch over to Pix4d. Before I take off for mission in pix4d I’ll switch back to DJI Go and make sure my settings have set. After running your mission when processing the photos, edit your camera to the rolling shutter before initial processing. Auto focus for the Zenmuse at high speeds has been unreliable in most cases.

Edit: Also set your flight speed to normal. It helps with the quality of photos.

Thank You Levon for these details.

I have just one question  :

When you say : use Manual camera settings. Take drone to mission altitude and turn camera down and adjust the settings to “look” good for photos.

Do you mean by manual :  Use Manual Settings (instead of Shutter or Aperturue priorities) ?

I usually setup Shutter (Speed) Priority.

I use slow speed to my flights (ie below 50 % of the slow-fast bracket and also landscape mode)

Regards

Benoit

 

Hello,

It seems that you have the latest version of firmware installed. The latest release was on 13.04.2016 for Zenmuse X5 http://www.dji.com/product/matrice100/info#downloads. Last version (X5): 1.3.1.00.

Could you let us know which version of Pix4Dcapture you used? Is it 3.8.0? Did you have a chance to make tests with the latest release of Pix4Dcapture? The latest version is 3.8.1 which was released on 24.04.2017.

Note that for all missions, the focus is constant during the flight and defined by Pix4Dcapture. There is no need for user intervention. The focus is automatically set to infinite before starting to shoot when using Matrice 100 on Android device.

However, you may try to set manual focus in DJI GO.

  1. Open DJI GO.
  2. Set Manual Focus
  3. Move the slider in DJI GO to set the focus to Infinity.
  4. Open Pix4Dcapture, start the mission as per normal. Make sure DJI GO is not running in the background when starting the mission.

Note that blurry images not only happen because of out of focus. The exposure time can also create blur. Since the exposure is supposed to be constant over the flight (automatic DJI exposure), changing light conditions can negatively impact the quality of the images.

Best regards,

Hello,

I have version 3.8.1 of Pix4DCapture (update of 21-April-2017).

About version of X5 i have last one i guess but i am checking with DJI about this.

I recalibrated X5 for photo mode and autofocus (which was already done anyway) and now things are better and i get back the former behavior or almost (i did 2 missions today by focusing with DJI Go before running missions) and will test asap by doing nothing specific as you stated  (as i did before this issue) and will confirm soon if behavior is correct.

Regards

 

 

Yes Benoit, using manual mode with your own settings for camera quality. Just make sure focus is always on infinite.

 When starting a mission i like to use DJI Go and set my X5 manually before i run a mission in pix4d. (Even though pix4d states it takes complete control.)

It seemed to help my issue a lot with blurred images.

Setting Shutter and Aperture setting according to the weather that day. 

 Everything else you’ve stated is correct. But for my X5 and Matrice i use Landscape mode. All in all this seems to be a long experimenting process. Failed attempts and corrections. Also with the X5 seems to be an issue with fine details on things such as wires and fences. But upon doing some research it seems getting a fish eye lens may be the fix for the X5 and these issues. Will post results when i have time to test.

Thanks Levon for these informations :

After calibrating lens again by following these 2 posts  :

http://www.inspirepilots.com/threads/final-and-detailed-guide-on-x5-lens-calibration.9337/
and
http://forum.dji.com/thread-34186-1-1.html

i was able to conduct missions in autofocus mode with no specific action :

  1. just doing the setup in DJI GO (Shutter or Aperture priority depending on weather)

and autofocus mode.
No specific focus action (first time i just did one autofocus when still on ground just to trigger autofocus).

  1. Then i start Pix4D and drone take off to execute mission.
    Result was ok

Regards