Support Website Contact Support Blog

DJI Mavic Pro Autofocus Issue

I recently flew a mission using your Pix4D Capture application.  With the lack of DJI Mavic’s autofocus, how does this work?  Can you please provide me with some details?  Perhaps that’s built into the software?  Thanks!

I’ve had two complete mission failures due to lack of autofocus.  I have my C1 button on the back set to invoke autofocus through Go4, but it doesn’t seem to work through Capture.

I have same issue on IOS.

Latest Firmware.

Slight out of focus on all images.

 

 

I experienced the same. I also use the C1 button. But I am not absolutely sure if that works during the flight using Capture. I think it does. I would appreciate when this would happen automatically with Capture.

 

Same problem.

HELLO PIX4D, PLEASE CAN YOU HELP?

Hello,

We are really sorry for the inconvenience. Unfortunately, we are aware that in some situations images captured using Pix4Dcapture and Mavic Pro might have focusing issues.

Mavic Pro’s auto-focusing capabilities require Pix4Dcapture to actively define and set a proper focus for the selected altitude/scene before starting the mission. Our goal is to provide a stable and flexible focusing method, without requiring any manual intervention from the user. Apparently, this is not working as expected in some cases.

Rest assured that the development team is working to identify and solve the issue. In the meantime, we will soon try to provide here some workarounds that will allow you to set or verify that the focusing is properly defined for your Pix4Dcapture mission.

Also, we will update this post as soon as we will have an estimation about when the issue will be fixed and in which release.

Regards

Great news. I hope this also crosses over to the P4 Pro series. I have lost 2 days of work due to out of focus images :-/

@James

We’re sorry to know that.

According to our tests, P4 Pro focusing appears to be way more stable than Mavic Pro’s. But we are of course taking your feedback in consideration and will investigate further.

Regards

I think the problem arises with the way the vibrations can adjust the focus slightly. Even when shooting pics or video on DJI Go I have to keep  re-focusing to make sure everything is sharp… However the new firmware apparently has continuous auto focus so this might help?

@Mattia 

I have the same Problem as James Hughes.

I’m testing the app with Mavic Pro for a big company and the result is not so pleasant.

Hi James and Rainer,

You could also try to assign C1 button to focus, fly the drone manually to the altitude where the flight is supposed to take place, press C1 before starting the mission with Pix4Dcapture. This worked for some users.

We apologize for the inconvenience.

Regards,

I have my C1 set to auto focus, flew to 40 meters and focused, landed, started a grid survey at with a 40m altitude and all the pictures are still out of focus. Also the p4d files are not uploading to the cloud and when I email them they do not open.

Same here.
I flew to 40m
Set focus
Started mission
Still poor focus
Also error about syncing data

Hi Kory and Steven,

Thank you for the feedback.
Did you try to set the focus to infinite and manual in DJI GO before flying with Pix4Dcapture?

It would be helpful to further investigate that you share with us the flight images.

Thank you for your help.
Apologies for the inconvenience.

Regards,

I really think it is actually a DJI issue.
I have tried 3 mapping solutions and all 3 have focus and exposure issues.
If get time I’ll fly same mission tomorrow with focus set to infinity if I can work it out.
Never had a problem with my phantom 3 pro.

Uploading photos now. I will try to do the infinity focus, today.

 

I have the same issue here and in my opinion this is caused by Pix4d… becouse when you fly with DJI go the focus is almost correct. But Pix4D Capture app seems to set the focus wrong and than shoot all the following 500 pics of the mapping with wrong focus too…

in my opinion it would be good that the drone starts to the first point of mission, set up the camera and switches into view mode, asking the pilot for confirmation if focus is correct or trying to do a refocus…

I have lost almost 0,25 km² of mapping becouse of wrong focus… now I don’t know what to say to the client…

Hi Igor,

We are sorry to hear this.
Did you try to set the focus to Infinite and Manual in DJI GO before flying with Pix4Dcapture?

At the beginning of the flight, we would recommend to always switch to the Camera view showing the video feed to verify that the drone is shooting as expected. Therefore, if something is wrong you can interrupt the mission.

Regards,

Hi

I had a few flights and what I can say is that the C1 Button during Pix4d Mission is not working. I have to fly manually to the altitude I would like the mission to start, press the C1 Button (Focus) and then fly the Pix4D Mission.

And than hope…

Rainer

Rainer, Im not shure if C1 button doesnt work… i will do a test about this since I have a suspect that it could work

 

@Pix4DSupport

Would it not be much easier that Pix4D does automatically a camera setup to manual focus & then put the focus to infinite. It would be much secure. it is completely time loss for each flight open DJI Go app, than connect, than set focus, than kill the app becouse pix4d can’t work at the same time…

Please fix this as it would improve a lot the workflow

Thanks