Support Website Contact Support Blog

Blurry Images, DJI M210, X4S, Pix4D Capture

I have had 2 jobs produce blurry images. Both Jobs had multiple flights in them. Some images would be clear and others blurry. I was told to fly slower. My drone was set to fly at the fastest speed in the Pix4d Capture app. My cendence controller was telling me that the drone was flying at 5.6m/s which seems slow for the fastest setting. Even if I do need to fly slower why would some photos be clear and others blurry. Flying in safe mode isn’t an option because the job is so large. (1200 images). Any information would be appreciated. Both jobs took place on cloudy days without sun shadows.

Hi Joshua,

I assume that you are using the iOS version of Pix4Dcapture to make acquisitions. The behavior you are describing has not been reported to us so far. Can you detail what type of mission you were planning, the size of it, so as the flight height and overlap set?

In your case, I would recommend checking the following to see if it can improve the sharpness of the images acquired. Note that the camera settings using the iOS version of Pix4Dcapture are set to auto/standard:

  • Make sure that the latest drone firmware and latest Pix4Dcapture versions are installed.

  • Change the drone speed sliders to slow so that the drone will fly at a lower speed than 5.6 m/s.

  • No interferences can occur in the location where you try to fly and the connection to the drone is stable.

  • Fly higher if possible so that motion blur does not occur (if it occurs)

  • The drone’s camera and compass are calibrated.

  • No flight setting conflicts with the mission, including maximum altitude, beginner mode, geofences, etc.
    - Basic features in DJI GO 4 are working properly:

  • Manual takeoff and flying.

  • Live video feed of the camera.

  • Manual picture triggering.

  • Restart your mission from scratch. To do so, close and force quit the app, disconnect the cable from the mobile device, turn off the remote controller and the drone. Then switch on the drone and the controller, reconnect the USB cable and open Pix4Dcapture. 

In a general way, I would suggest you have at our basic checks and troubleshooting articleon our Knowledge Base.

Best,

All the firmwares are up to date. The drone performs fine with the DJI go 4 app. I don’t want to fly higher because I’m trying to get a very hi-res image. Everything is set to auto/standard.

Overlap: 80%-70%

Altitude: 190 Feet

Camera Angle: 80 Degrees

Drone Speed: Fast

Picture Trigger Mode: Fast

White Balance: Auto

Weather: Overcast, 32 Degrees F

DJI M210, X4S, iPad (all up to date firmware)

Pix4D Version  4.2.0 (8)

 

All these settings used to work fine for me. The last two jobs I have flown I have had blurry images. I’m not sure if its just because its overcast skies and the images are darker than they are in the summer with sunny skies. One other question… When the drone is set to normal speed, does the camera focus for every picture or is the focus set on the very first picture for the entire flight?

 

I just went and flew another job today except this time I took my mavic pro. I was flying a stockpile so I flew an orbit mission and then I flew a double grid mission at 150’. Sunny day. Both flights produced blurry images!!! You guys have something seriously wrong with your pix4d capture app. I never used to have problems with this.

So just for the hell of it I tried another mapping application. That application worked perfectly. No blurred images at all. This tells me it’s definitely an issue in the Pix4Dcapture application.

Hi Joshua,

Sorry to hear that the application is not working as it should with your different configurations.

During your flights, did you use the Mavic Pro or Mavic 2 Pro? If using the Mavic Pro, we are aware of some issues with the image focus when flying it. These issues seem to happen randomly as no clear pattern was identified so far. Developers are looking to find a solution so that it can be fixed in a future release.

At this stage, I would suggest you:

  • Reinstall DJI GO 4.
  • If possible, use an Android mobile device to see if the issue also occurs or not.
  • Reinstall Pix4Dcapture from scratch.

Caution

The procedure below may imply data loss so we recommend to make a backup if there are important data saved. Connect the mobile device and use iTunes to backup files on your computer.

Re-install Pix4Dcapture from scratch

  1. Uninstall Pix4Dcapture. On your mobile device go to Settings > General > iPhone Storage > Pix4Dcapture > Delete App.
  2. Re-install the latest version of Pix4Dcapture.
  3. (optional) Place the backup content back into the Pix4D folder to restore data.

I look forward to your response before asking you the logs and investigating further on.

Best regards

So my original flights were with the DJI M210. This past weekend I tried with the Mavic Pro just to test the pix4d app and see if it was a problem with my M210 or if it was the app. Everything had the latest firmware. I used iOS devices, with the M210 I used an iPad and with the Mavic Pro I used an iPhone X. All are up to date and drones are up to date with no conflicting issues such as no fly zones. I have not deleted and reinstalled the app yet but I don’t anticipate this fixing the issue. The Pix4D Capture app seems to be focusing the camera before the drone is at its flying altitude or something similar to this. I’ll try reinstalling sometime this week and see if it works.

So a little update on this. I have flown 2 more jobs since the initial job I discovered the problem with. I had the same results, blurry images. I thought maybe the drone was just flying too fast so I even did a flight with the drone in slow mode (1.8m/s) which isn’t really practical for the large jobs I do. Even this super slow flight produced blurry images. I have no idea what could be causing this. The drone never used to have this problem until this past December when I discovered the issue. Hopefully you guys can come out with a fix for this.

 

P.S. this is using an apple iPad.

Hi Joshua,

Thank you for getting back to us.

Are you flying using the latest iOS version V4.3 of Pix4Dcapture?

Did you have the chance to try the Android version of Pix4Dcapture in your configuration?

Best,

I don’t have any android devices to try with. Yes, I am on the most current version of Pix4D as well.

I flew a job today using another 3rd party app with zero issues. Images were perfectly clear.

I just sent you my logs this morning. Hopefully that will help.

It’s been almost a month. Do you guys have any update on the focus issue?

Hi Joshua,

Thank you for coming back to us. I will answer you via the ticket that has been created for your issue.

Best,

I sent you another e-mail concerning this. I’m still having issues with blurry images. Your team really needs to get on this issue and get it fixed.

Hi Joshua,

We did not get any emails from you in our system. Is it possible for you to resend it?

Best,

Hi Joshua,

I can report that I have repeatedly seen the same problems on our M210 set up as well.

If you look back there a numerous threads on the forums related to similar focus issues across various drone platforms with Pix4DCapture, these date back to at least 2017 and from what I have read on those posts it appears that no additional resources were being diverted to try and address the focus problem. It looks to be a recurrent problem somewhere in the DJI > PIX4D Capture Pipeline, so I wouldn’t hold your breath for a fix coming any time soon.

Here are a couple of examples.

https://community.pix4d.com/t/2962

https://community.pix4d.com/t/2908-DJI-Mavic-Pro-Autofocus-Issue-Android-?page=3#comments

I have been looking at alternative drone mapping apps to use with the M210 to bypass this issue as I cant see any workaround solutions that apply to the M210, can I ask what other apps are which you have used successfully with this drone configuration?

Cheers 

I was going to say, I got an e-mail back from support on my issue that has been occurring for 6 months. The P4D support person stated that they don’t see this issue being fixed anytime soon. That answer really surprised me. Why put out an application that doesn’t work. It’s not like they don’t have resources available to fix this issue. If I were running Pix4D I would want as many people using my pix4dcapture app as possible because those people are more likely to end up using the processing software. I’m really disappointed in P4D because I really liked their capture app when it worked and now they are forcing me to use another company. So disappointed that I may look into other processing software to use because I don’t see why I should give them my money when they clearly aren’t concerned with my needs.

As far as other capture apps, I have used drone deploy which seems to work fine and DJI ground station.(I believe its called) I think that’s only available on the iPad for some weird reason.

I am having the same problem. We fly a M210 with the CrystalSky and the X4S camera. This is a real problem. I did not initially associate it with the Pix4D app, but after reading a few threads, it might be the app. Pix - I’ll submit a support ticket and upload some images.

In DD you can specify to use the manual settings that are set in the Go4 app.  However, in Pix4D you can not set that.   Am I missing something?  I want to be able to go to Go4 (or ideally in Pix4D) and set my exposure settings, and then fly up to mapping altitude, focus, and then change to MF so that it simply does not change.  At 100+ feet infinity focus should be tack sharp.    If this is done it would seem impossible to have blurry images.  But I think Pix4D is trying to AF on each shot.  If I’m wrong I will stand corrected.