Support Website Contact Support Blog

Blurry images with Inpire 1 X3 camera

I’m trying to get the test data for Pix4Dmapper with Inspire 1 Zenmuse X3 camera and Pix4Dcapture app. Some captured imaged were good, but the others were not good. The captured images with problems were quite blurry, so I think they cannot be used for generating quality results with Pix4Dmapper. I wonder how I can get the successful capture with Inspire 1 Zenmuse X3 and Pix4Dcapture app. 

 

Hi Wanho,

If it was windy the images might indeed be blurry. In this case, there is no other choice but to fly again.

It could also be that the focus of the camera was not correct. Before starting the mission with Pix4Dcapture, you could for instance switch to the Camera view (tab with the camera icon at the top of the Grid Mission screen) and check whether the camera is well focused when taking pictures.

With the latest versions of the app, Android 3.0.1 and iOS 1.2.2, we are not aware of similar problems. This could have been solved.
Let us know if the issue remains when you fly with Pix4Dcapture.

Regards,

I also have blurry images with my mavic after testing the app, I think the app isnt stopping the drone before taking the image. On the lastest DJI GS Pro app the drone stops for a sec takes a photo and moves on to the next point rather than flying and shooting photos.This solves the blurry photo problem but with the Pix4 app it doesn’t so the images are blurry. Can this please be fixed in the app

I also have blurry images with a Mavic, but not due to motion, it appears that the camera will not focus, at least I have not figured out how to focus it.  I can take good shots flying manually at speed with DJI Go4 with manual camera settings (altitude 60m, ISO 100, shutter speed >500). However with the same camera settings and same altitude running a mission with Pix4d capture, all the images are out of focus.

To Pix4D support; how do we focus the camera with the Mavic? Also is there no way to adjust camera settings in the capture app?  Currently I have to fly up to altitude with Go4, adjust manual camera settings, land, shutdown then reboot with Pix4D capture. Is there a better way?

Regards

Hello Dean,

We are aware of some issues with the focus of the images taken with Mavic Pro. The current procedure is that the drone goes to the first way point of the mission and the camera makes an auto-focus on the current view. This might set a wrong focus if for instance the camera focuses on a building while most of the mission is about mapping lower objects. All the images are then expected to be blurry.

Please note that some improvement on the Mavic Pro focus was made in the new Android release (3.6.0). We recommend using this version next time to fly the drone. 

Regarding the camera settings, they are set to automatic so that the images are optimally captured to ensure a good reconstruction with Pix4Dmapper. Unfortunately, it is not possible to change them before starting the mission. 

Regards,

 

@support.    also blurry often.  listened to your advice.  moved first waypoint to top of building roof (and off of parking lot 50feet lower).  worked ok.  but can only do single grid mission. double grid and the point of focus changes too much.   Im stuck showing potential client sub par results.  tried many flights.  plus really got me stuck on that aspect during your trial.  needed more time to explore processing cloud first then fixing in desktop. can you simply program the mavic to focus every second or two. and we can slow down our flight times so theres no near misses on focusing.  i wish i had better data to show off !!!

Hi Michael,

Thank you for your feedback.

At the moment the DJI SDK of this drone does not allow the flexibility we would like to have, but our developers know the problem and are working on improving the way the focus is set at the beginning of the mission. We apologize for the inconvenience.

You could also try to assign C1 button to focus, fly the drone manually to the altitude where the flight is supposed to take place, press C1 before starting the mission with Pix4Dcapture. This worked for some users.

Regards,